• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't upgrade from Windows 8.1 to Pro on Lenovo U310


jdarling

New Member
Posts
1
#1
I have a Lenovo U310 Touch that came from the store with Windows 8.1 on it. I need to install Hyper-V and that requires 8.1 Pro.

I have a product key from my MSDN subscription for 8.1 Pro and attempted to use the "Add Features" program from the system screen to upgrade. It takes the code, validates it as ok, goes through some downloading and other stuff then reboots the system. When it comes back up after the reboot it states "Couldn't add features" along with a contact Microsoft Support link.

I looked around and can't find a log file or any error codes that I could post here, if anyone knows where it is I'll be happy to post anything I find.

I tried contacting support, but the two different people I talked to just walked me through the same process to then punting to another person who ran me through the same and came to the conclusion "can't help you".

I've done this on 2 desktop machines to enable Hyper-V with no issues but for some reason this doesn't work on this "Ultrabook".

I've tried this on a hard network connection and on a wireless connection to see if anything changed. Still broke both ways.

The machine does have 2 drives in it, one 20GB SSD for recovery and recovery drivers and the primary drive. I've read where there may be files mapped on that drive that are causing problems, but have no clue how to actually find these and move them.

Any ideas?

- Jeremy
 

My Computer

System One

  • OS
    Windows 8.1 & Pro