• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Can't uninstall apps from Metro


Omlet

Member
Member
Posts
14
#1
I'm attempting to uninstall apps downloaded from the Windows Store, but they keep coming back. Windows Store reports updates for the apps, but attempting to update them results in an "This app couldn't be installed" error. I'm guessing the apps were uninstalled properly, so now I cannot install them nor remove them. I've been told that refreshing the PC would do the trick, but I'd rather not go through the hassle of re-downloading programs.

Any suggestions?
 

My Computer

System One

  • OS
    Windows 8 Pro

Brink

Administrator
Administrator
mvp
Posts
24,164
#2
Last edited:

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Omlet

Member
Member
Posts
14
#3
Hello Omlet,

Did you uninstall the Store app like in the tutorial below?

AutoPlay - Turn On or Off - Windows 7 Forums

If so, then you might clear the Store cache to reset the Store to see if that may help.

http://www.eightforums.com/tutorials/13133-store-cache-clear-windows-8-a.html

Hope this helps, :)
Shawn
AutoPlay? :confused:

Also, I've tried clearing the Store cache, but the problem permits: I cannot updates apps nor can I remove them. Is there perhaps a way I can remove them manually?
 

My Computer

System One

  • OS
    Windows 8 Pro

znod

New Member
Power User
Posts
2,156
#4
I'm attempting to uninstall apps downloaded from the Windows Store, but they keep coming back. Windows Store reports updates for the apps, but attempting to update them results in an "This app couldn't be installed" error. I'm guessing the apps were uninstalled properly, so now I cannot install them nor remove them. I've been told that refreshing the PC would do the trick, but I'd rather not go through the hassle of re-downloading programs.

Any suggestions?
Shawn's idea probably is better than mine. But, can you do a system restore back to a point that is satisfactory to you (e.g., one where you've, in effect, uninstalled everything you want uninstalled (including install remnants) and, at the same time, not uninstalled, in effect, a satisfactory number of the things you don't want uninstalled?
 

My Computer

System One

  • OS
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY Rig; MacBook Pro (MBP)/Parallels/Boot Camp; HP Pavilion dv6500t Laptop
    CPU
    Intel i7-2600K (sometimes OC'd to 4.8 GHz)
    Motherboard
    ASUS P8P67 Deluxe Rev B3
    Memory
    16 GB Corsair Vengeance
    Graphics Card(s)
    EVGA 570 SC
    Monitor(s) Displays
    Gateway
    Hard Drives
    Dual Boot:
    Win7 Ult RAID 0 on OCZ Revo x2 and
    Win7 Ult RAID 0 on Caviar Black SATA 3's
    PSU
    Cooler Master Silent Pro 1000W
    Case
    Cooler Master 932 HAF
    Cooling
    Zalman CNPS9900MAX-B CPU Fan
    Keyboard
    Logitech Cordless Desktop MX 5500
    Mouse
    Logitech Cordless Desktop MX 5500
    Internet Speed
    20 Mbps Download/2+ Mbps Upload
    Other Info
    Pioneer Blu-ray Burner/DVD Burner

Omlet

Member
Member
Posts
14
#5
I'm attempting to uninstall apps downloaded from the Windows Store, but they keep coming back. Windows Store reports updates for the apps, but attempting to update them results in an "This app couldn't be installed" error. I'm guessing the apps were uninstalled properly, so now I cannot install them nor remove them. I've been told that refreshing the PC would do the trick, but I'd rather not go through the hassle of re-downloading programs.

Any suggestions?
Shawn's idea probably is better than mine. But, can you do a system restore back to a point that is satisfactory to you (e.g., one where you've, in effect, uninstalled everything you want uninstalled (including install remnants) and, at the same time, not uninstalled, in effect, a satisfactory number of the things you don't want uninstalled?
If I cannot fix it any other way I'll probably have to go that route.

By the way, I ran a SFC scan and got a issue with a particular file:

2012-11-27 10:21:51, Info CSI 000006c0 [SR] Cannot repair member file [l:24{12}]"mdmgl004.inf" of mdmgl004.inf, Version = 6.2.9200.16384, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type = [l:24{12}]"driverUpdate", TypeName neutral, PublicKey neutral in the store, hash mismatch
2012-11-27 10:21:51, Info CSI 000006c2 [SR] Cannot repair member file [l:24{12}]"mdmgl004.inf" of mdmgl004.inf, Version = 6.2.9200.16384, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type = [l:24{12}]"driverUpdate", TypeName neutral, PublicKey neutral in the store, hash mismatch
I don't think it's related to the Store issue, but I figured I'd post it anyway.
 

My Computer

System One

  • OS
    Windows 8 Pro

Brink

Administrator
Administrator
mvp
Posts
24,164
#6
Hello Omlet,

Did you uninstall the Store app like in the tutorial below?

AutoPlay - Turn On or Off - Windows 7 Forums

If so, then you might clear the Store cache to reset the Store to see if that may help.

http://www.eightforums.com/tutorials/13133-store-cache-clear-windows-8-a.html

Hope this helps, :)
Shawn
AutoPlay? :confused:

Also, I've tried clearing the Store cache, but the problem permits: I cannot updates apps nor can I remove them. Is there perhaps a way I can remove them manually?
Sorry, that should be this instead. :eek:

http://www.eightforums.com/tutorials/5278-apps-uninstall-metro-apps-windows-8-a.html


Were you able to do a system restore using a restore point dated (if available) dated before this happened?

http://www.eightforums.com/tutorials/4692-system-restore-how-do-windows-8-a.html
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Omlet

Member
Member
Posts
14
#7
Hello Omlet,

Did you uninstall the Store app like in the tutorial below?

AutoPlay - Turn On or Off - Windows 7 Forums

If so, then you might clear the Store cache to reset the Store to see if that may help.

http://www.eightforums.com/tutorials/13133-store-cache-clear-windows-8-a.html

Hope this helps, :)
Shawn
AutoPlay? :confused:

Also, I've tried clearing the Store cache, but the problem permits: I cannot updates apps nor can I remove them. Is there perhaps a way I can remove them manually?
Sorry, that should be this instead. :eek:

http://www.eightforums.com/tutorials/5278-apps-uninstall-metro-apps-windows-8-a.html


Were you able to do a system restore using a restore point dated (if available) dated before this happened?

http://www.eightforums.com/tutorials/4692-system-restore-how-do-windows-8-a.html
Actually, I just fixed the issue. For some odd reason, the 'AUInstallAgent' folder wasn't located in the Windows directory, and apps couldn't be removed nor installed. I re-created the folder, rebooted, and I was able to install/remove apps just fine. I'm not sure why the folder was missing to begin with.

Thanks for the great support. :thumb:
 

My Computer

System One

  • OS
    Windows 8 Pro

Brink

Administrator
Administrator
mvp
Posts
24,164
#8
That's great news. Thank you for posting back with your results. :)
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

znod

New Member
Power User
Posts
2,156
#9
@Omlet: Way to go.
 

My Computer

System One

  • OS
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY Rig; MacBook Pro (MBP)/Parallels/Boot Camp; HP Pavilion dv6500t Laptop
    CPU
    Intel i7-2600K (sometimes OC'd to 4.8 GHz)
    Motherboard
    ASUS P8P67 Deluxe Rev B3
    Memory
    16 GB Corsair Vengeance
    Graphics Card(s)
    EVGA 570 SC
    Monitor(s) Displays
    Gateway
    Hard Drives
    Dual Boot:
    Win7 Ult RAID 0 on OCZ Revo x2 and
    Win7 Ult RAID 0 on Caviar Black SATA 3's
    PSU
    Cooler Master Silent Pro 1000W
    Case
    Cooler Master 932 HAF
    Cooling
    Zalman CNPS9900MAX-B CPU Fan
    Keyboard
    Logitech Cordless Desktop MX 5500
    Mouse
    Logitech Cordless Desktop MX 5500
    Internet Speed
    20 Mbps Download/2+ Mbps Upload
    Other Info
    Pioneer Blu-ray Burner/DVD Burner

Users Who Are Viewing This Thread (Users: 0, Guests: 1)