• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Can't set virtual machines to use hyper threading


RixzZ

New Member
Posts
4
#1
Hello, 2 months ago I built a new machine with a Gigabyte Z97X Gaming 7 motherboard and Intel Core i7 4790K. It is running Windows 8.1.

I have virtualization enabled in BIOS and Hyper-V disabled but, in some machines on VirtualBox or VMWare, i can't set it to use 8 cores instead the 4 physical ones. In other, it allows me to use it. At this time I could only set it to use 8 cores in a Windows 7 VM in VMWare.

I checked CPU capabilities with coreinfo and it says Hypervisor is disabled and the other two options are OK.

Did I forget to change some setting or something? I can't understand why sometimes work and sometimes not.


;)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel Core i7-4970K
    Motherboard
    Gigabyte Z97X Gaming 7
    Memory
    Kingston HyperX Fury 1866MHz
    Graphics Card(s)
    Gigabyte GTX970 G1 WindForce OC
    Sound Card
    Onboard
    Monitor(s) Displays
    ASU VG248QE / Samsung SyncMaster P2350
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung EVO 840 - 250GB
    Seagate Barracuda 7200.14 3TB
    PSU
    Tacens Mars Gaming 800W
    Case
    Corsair Carbide SPEC-03
    Cooling
    Corsair Cooling Hydro Series H80i
    Keyboard
    Razer Blackwidow Ultimate
    Mouse
    Razer Orochi 2013
    Internet Speed
    100/10
    Browser
    Chrome

jimbo45

New Member
VIP Member
Guru
Hafnarfjörður IS

Posts
4,373
#2
Hi there

VMware Workstation 11 in the VMware settings for the VM you cans et the nr of processors - I think 32 is the max. !!! You don't need to set it in the Virtual (or HOST) Bios. Use the settings in the VM.

Cheers
jimbo
 

Attachments

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)
Posts
1,870
#3
For your processor the maximum number of cores you should assign is 3 (one less than the number of real cores in your processor). Most of the time though allocating only 1 core will be faster due to the overhead required to synchronise the assigned cores. If you assign more than 3 your VM will become unstable and freeze a lot. See https://forums.virtualbox.org/viewtopic.php?f=6&t=35256

I run 8.1 Pro x64 in VBox and have 4 physical cores. I've found that it runs fastest (for me) with 1 core assigned - I've found adding more cores makes it slower.

As for why you can't change it - what guest OSs are you running? Are they 32 bit or 64 bit?
 

My Computer

System One

  • OS
    Windows 10 Pro Prieview x64
    Computer type
    Laptop
    System Manufacturer/Model
    MacBook Pro Core2Duo
    CPU
    T7600
    Memory
    3
    Graphics Card(s)
    ATI Radeon X1600
    Monitor(s) Displays
    Internal
    Screen Resolution
    1440 x 800
    Hard Drives
    40GB
    Keyboard
    Apple
    Mouse
    Apple
    Internet Speed
    Varies
    Browser
    Various
    Antivirus
    Defender

RixzZ

New Member
Posts
4
#4
Thanks for both replies, but I think you didn't understand well my question. I'm saying that in VMWare if I select 1 processor, I can't select 5-8 cores that my processor have. It only allows me to select 1-4.

In VirtualBox, that thing is the same, but Virtualbox, when you go to Processors Tab, you can see how many cores it allows you to use in green, and up to 8 in red. If you select a number in red zone you get a warning saying you selected more cores that available ones.

I other computers I had or I worked in, proccesors with HyperThreading and 8 total threads, shows up as 8 cores in VirutalBox. That's the difference with my computer. I attach a screenshot of that window.

As for why you can't change it - what guest OSs are you running? Are they 32 bit or 64 bit?
I tried it with different guests, all 64 bit. I have virtualization enabled on my BIOS, Hyper-V disabled on Windows 8 and VT-x enabled in all virtual machines with extended features.
 

Attachments

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel Core i7-4970K
    Motherboard
    Gigabyte Z97X Gaming 7
    Memory
    Kingston HyperX Fury 1866MHz
    Graphics Card(s)
    Gigabyte GTX970 G1 WindForce OC
    Sound Card
    Onboard
    Monitor(s) Displays
    ASU VG248QE / Samsung SyncMaster P2350
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung EVO 840 - 250GB
    Seagate Barracuda 7200.14 3TB
    PSU
    Tacens Mars Gaming 800W
    Case
    Corsair Carbide SPEC-03
    Cooling
    Corsair Cooling Hydro Series H80i
    Keyboard
    Razer Blackwidow Ultimate
    Mouse
    Razer Orochi 2013
    Internet Speed
    100/10
    Browser
    Chrome
Posts
1,870
#5

My Computer

System One

  • OS
    Windows 10 Pro Prieview x64
    Computer type
    Laptop
    System Manufacturer/Model
    MacBook Pro Core2Duo
    CPU
    T7600
    Memory
    3
    Graphics Card(s)
    ATI Radeon X1600
    Monitor(s) Displays
    Internal
    Screen Resolution
    1440 x 800
    Hard Drives
    40GB
    Keyboard
    Apple
    Mouse
    Apple
    Internet Speed
    Varies
    Browser
    Various
    Antivirus
    Defender

RixzZ

New Member
Posts
4
#6
Thanks for replying.

Yep, I know it is 4 physical cores, but as I said before, in some computer I saw virtualbox detects threads as cores.

So is there a reason to virtualbox over a mac with I7-2600 works different? That computer is the other one I said before, where have 4 physical cores and 8 threads VirtualBox shows 8 cores as available. Maybe is the way how osx handle cores/threads that makes VirtualBox detect it as 8 cores.


Can someone corroborate this?
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel Core i7-4970K
    Motherboard
    Gigabyte Z97X Gaming 7
    Memory
    Kingston HyperX Fury 1866MHz
    Graphics Card(s)
    Gigabyte GTX970 G1 WindForce OC
    Sound Card
    Onboard
    Monitor(s) Displays
    ASU VG248QE / Samsung SyncMaster P2350
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung EVO 840 - 250GB
    Seagate Barracuda 7200.14 3TB
    PSU
    Tacens Mars Gaming 800W
    Case
    Corsair Carbide SPEC-03
    Cooling
    Corsair Cooling Hydro Series H80i
    Keyboard
    Razer Blackwidow Ultimate
    Mouse
    Razer Orochi 2013
    Internet Speed
    100/10
    Browser
    Chrome
Posts
1,870
#7
I have a macbook with i5 3210M with 2 physical cores ARK | Intel® Coreâ

I get the same issue as you - it counts the threads. VirtualBox gives me that message if I use more than 4. According to this support ticket it should be 2 https://www.virtualbox.org/ticket/12480 - supposedly they have fixed the retrieval of cores

VirtualBox does not emulate hyperthreads but only physical cores.

Certainly from their documentation you should base the number of processors assigned up to one less than the number of physical cores.
Looks like a bug in VirtualBox - I get the same issue with VirtualBox version 4.3.22 released yesterday.

Screen Shot 2015-02-14 at 14.41.28.png
 

My Computer

System One

  • OS
    Windows 10 Pro Prieview x64
    Computer type
    Laptop
    System Manufacturer/Model
    MacBook Pro Core2Duo
    CPU
    T7600
    Memory
    3
    Graphics Card(s)
    ATI Radeon X1600
    Monitor(s) Displays
    Internal
    Screen Resolution
    1440 x 800
    Hard Drives
    40GB
    Keyboard
    Apple
    Mouse
    Apple
    Internet Speed
    Varies
    Browser
    Various
    Antivirus
    Defender

RixzZ

New Member
Posts
4
#8
The error seems to be on mac, not on my windows computer. I just checked the mac with updated version of VirtualBox and is the same. It shows 8 cores in green and 16 as max.


Until now I didn't know which one was right, and how virtualbox takes threads.


Thank you for helping :)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel Core i7-4970K
    Motherboard
    Gigabyte Z97X Gaming 7
    Memory
    Kingston HyperX Fury 1866MHz
    Graphics Card(s)
    Gigabyte GTX970 G1 WindForce OC
    Sound Card
    Onboard
    Monitor(s) Displays
    ASU VG248QE / Samsung SyncMaster P2350
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung EVO 840 - 250GB
    Seagate Barracuda 7200.14 3TB
    PSU
    Tacens Mars Gaming 800W
    Case
    Corsair Carbide SPEC-03
    Cooling
    Corsair Cooling Hydro Series H80i
    Keyboard
    Razer Blackwidow Ultimate
    Mouse
    Razer Orochi 2013
    Internet Speed
    100/10
    Browser
    Chrome
Posts
1,870
#9
You're welcome. I'll report it as a bug over at VirtualBox.
 

My Computer

System One

  • OS
    Windows 10 Pro Prieview x64
    Computer type
    Laptop
    System Manufacturer/Model
    MacBook Pro Core2Duo
    CPU
    T7600
    Memory
    3
    Graphics Card(s)
    ATI Radeon X1600
    Monitor(s) Displays
    Internal
    Screen Resolution
    1440 x 800
    Hard Drives
    40GB
    Keyboard
    Apple
    Mouse
    Apple
    Internet Speed
    Varies
    Browser
    Various
    Antivirus
    Defender

Users Who Are Viewing This Thread (Users: 0, Guests: 1)