What's new

Can't change input language.

whitebloodcell

New Member
Using Windows 8.1. I have English and Japanese input languages added, and both are listed as options in the language toolbar, but it is impossible to select anything but English. Windows+Space allows me to navigate to Japanese, but releasing the keys or pressing Enter does nothing. The Left Alt+Shift shortcut also does nothing.
 

My Computer

System One

  • OS
    Windows 8 Pro

Kari

Old geek, new tricks
Team Member
VIP Member
Pro User
I installed Japanese input language for the sake of screenshots, let's see if we can fix this for you.

First things first, the basics in using Japanese input language. If input language is installed and enabled, you will see it on your input method selection dialog:

2014-06-22_11h59_16.png

When selected, the Japanese input language shows two icons (my Taskbar is vertical at left, image might look different than the same on your display):

2014-06-22_12h00_12.png
1 = Japanese input language active
2 = Keyboard layout selector (by default Half-Width Alphanumeric)​

You have to right click the keyboard layout selector (2) to select either Hiragana, Katakana or Alphanumeric layout to type using the layout you need:

2014-06-22_12h09_37.png

You can also select one of two input methods, Romaji or Kana:

2014-06-22_12h19_09.png

A bit confusing although somewhat logical default behavior of Japanese input language might cause user to think the Japanese is not working, as it defaults to Half-width Alphanumeric keyboard layout which is basically as an English layout, using western alphabet.

Kari
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Name
    Kari The Finn
    Computer type
    Laptop
    System Manufacturer/Model
    HP ENVY 17-1150eg
    CPU
    1.6 GHz Intel Core i7-720QM Processor
    Memory
    6 GB
    Graphics Card(s)
    ATI Mobility Radeon HD 5850 Graphics
    Sound Card
    Beats sound system with integrated subwoofer
    Monitor(s) Displays
    17" laptop display, 22" LED and 32" Full HD TV through HDMI
    Screen Resolution
    1600*900 (1), 1920*1080 (2&3)
    Hard Drives
    Internal: 2 x 500 GB SATA Hard Disk Drive 7200 rpm
    External: 2TB for backups, 3TB USB3 network drive for media
    Occupation
    Back from retirement, IT consultant
    Cooling
    As Envy runs a bit warm, I have it on a Cooler Master pad
    Keyboard
    Logitech diNovo Media Desktop Laser (bluetooth)
    Mouse
    Logitech MX1000 Laser (Bluetooth)
    Internet Speed
    50 MB VDSL
    Browser
    Maxthon 3.5.2., IE11
    Antivirus
    Windows Defender 4.3.9431.0
    Other Info
    Windows in English, additional user accounts in Finnish, German and Swedish.
    Country Flag
    Finland
    State/Region Flag
    de saxony

whitebloodcell

New Member
Thank you for the detailed response. I have been using Japanese input on other computers for many years and am familiar with it. It is visible on the input method selection menu, but it is impossible to select it, so it never changes from ENG and I never get to choose hiragana or otherwise. On my Desktop computer running Windows 8 Pro (not 8.1 - I dislike not having more direct control over SkyDrive as with 8.1) there are no issues with selection at all.
 

My Computer

System One

  • OS
    Windows 8 Pro

Kari

Old geek, new tricks
Team Member
VIP Member
Pro User
OK. As the default Alphanumeric selection keeps confusing quite a many users when a non-Latin keyboard is selected, I thought it would be important to clear that first. I did not mean that you do not know what you are doing :).

I had some issues to get both Finnish display language and input language to work on one 8.1 PC. I was able to resolve the issue with these simple steps, which I suggest you'd try now:
  • Uninstall / disable Japanese input language
  • Reboot
  • Run SFC /SCANNOW (tutorial). If first run does not find anything, it's OK, if it finds but is unable to correct all errors, reboot and run it again as many times as needed (always rebooting between the runs) until it finds no errors
  • Now install Japanese language pack (display language, tutorial here) even if you do not need it
  • Add Japanese input language to your default display language (English?)
  • Reboot and check if Japanese input works
Kari
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Name
    Kari The Finn
    Computer type
    Laptop
    System Manufacturer/Model
    HP ENVY 17-1150eg
    CPU
    1.6 GHz Intel Core i7-720QM Processor
    Memory
    6 GB
    Graphics Card(s)
    ATI Mobility Radeon HD 5850 Graphics
    Sound Card
    Beats sound system with integrated subwoofer
    Monitor(s) Displays
    17" laptop display, 22" LED and 32" Full HD TV through HDMI
    Screen Resolution
    1600*900 (1), 1920*1080 (2&3)
    Hard Drives
    Internal: 2 x 500 GB SATA Hard Disk Drive 7200 rpm
    External: 2TB for backups, 3TB USB3 network drive for media
    Occupation
    Back from retirement, IT consultant
    Cooling
    As Envy runs a bit warm, I have it on a Cooler Master pad
    Keyboard
    Logitech diNovo Media Desktop Laser (bluetooth)
    Mouse
    Logitech MX1000 Laser (Bluetooth)
    Internet Speed
    50 MB VDSL
    Browser
    Maxthon 3.5.2., IE11
    Antivirus
    Windows Defender 4.3.9431.0
    Other Info
    Windows in English, additional user accounts in Finnish, German and Swedish.
    Country Flag
    Finland
    State/Region Flag
    de saxony

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top