• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't boot from USB Error code 0xc0000225


New Member
So I got my Rikomagic MK36 to connect up the the tv for the Mrs to use. Awesome little thing for the 5 minutes I had it working! It dual boots windows 8 and Android.
It was running WIndows 8 perfectly. So I had to go and install Windows 10 which doesn't run so well on it.
So using the recovery USB I made while doing the Windows 10 upgrade I tried to rollback to Win 8. After a couple of restarts I got to a screen saying:
Your pc ran into a problem and needs to restart. process1_initialization_failed.
It then restarts and goes to:
Your Pc couldn't start properly. A requried device isn't connected or couldn't be found Error code 0xc0000225 You'll need to use the recovery tools on your installation media.
I must have seen those blue screens about 1000 times in the last couple of days. I could still see it when I went to bed!
So I am stuck in a loop and can't even load Android on it.
So I've tried booting from a USB drive by changing the boot order. The USB drive show up in BIOS boot it will not boot from it at all. It just goes back to the blue screen loop.
Photos of the blue screens and BIOS settings. https://drive.google.com/folderview...laM0lrTlZGU19tellDTms5VnVSaWxzTEE&usp=sharing
This is the product. I managed to use the coupon on it so it was pretty cheap. Rikomagic RKM MK 36 Intel Z3736F Dual Boot (updated) - FreakTab.com
My wife is giving me plenty of grief for this. She seems to think that I break every bit of technology I have. Of course I deny this to her but I do seem to be rather unlucky most products.
Need to get this fixed up asap for the sake of my reputation to my wife. I'll be on the computer all day so any suggestions I'll try immediately and get back to you straight away. Thanks guys

My Computer

System One

  • OS
    windows 8.1