What's new

Can't access shared drives on Win8 Pro PC -- sometimes

Mark Phelps

New Member
VIP Member
Pro User
Have two Win8 machines and one has a bunch of drives connected to it, that I use informally as a file server.

Generally, what happens is the following:
1) Boot the Win8 "server" machine (Win8 pro, not a Server OS)
2) Boot my Win8 Pro desktop
3) Open file manager app, double-click the icon for the server PC -- and drive icons open

But sometimes, when I do 3), I get an error message saying that the machine name is incorrect (which it is NOT).

When I click Details on this to see what is wrong, it says "no issues" -- but still can't connect.

This is generally resolved by rebooting the "server" box (and trying again), or rebooting the desktop box (and trying again), or going through repeated reboots of each -- until a connection is finally made.

I've checked the sharing permissions on the "server" box and they are set as follows:
1) Each partition -- read by everyone (used by the desktops to download files)
2) Shared folder in each partition -- full control by everyone (used by the desktops to upload files)

And ... password-protected sharing is enabled, such that when a desktop first tries to connect, you must enter valid account info. After that, the info is saved and you don't have to enter it again.

I've gone through removing sharing and reapplying it several times, and there are no changes as a result.

And it's always all-or-nothing, that is, it's never a situation where some of the shares can be seen/used but not others.

Problem is, there are times when I really need access to the "server" drives from the desktop and can't reboot either because something is going on that takes a long time and I don't want to have to restart it.

I also run XP on this box (which never gave me these problems) -- and would really like NOT to go back to using XP.

Anything I can try to resolve this?
 

My Computer

chev65

Closed
I'm really not sure why you would be seeing this type of error message but have you tried setting up a Homegroup between the Windows 8 machines?

Did you check in the Advanced Sharing settings that the settings for All Networks are enabled for sharing as well as the Private network settings?
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Mark Phelps

New Member
VIP Member
Pro User
I'm really not sure why you would be seeing this type of error message but have you tried setting up a Homegroup between the Windows 8 machines?
Don't really want to use a HomeGroup as there are other machines that need to access the "server".

Did you check in the Advanced Sharing settings that the settings for All Networks are enabled for sharing as well as the Private network settings?
I looked in Advanced Sharing and all I saw was an option for users, didn't see anything about Networks.
 

My Computer

chev65

Closed
You don't see the All Network settings in the Advanced Sharing settings like what is showing in the picture?

I'm not sure what you mean by "File Manager App".
 

Attachments

  • All Networks settings.PNG
    All Networks settings.PNG
    23.8 KB · Views: 127

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Mr Sardonicus

New Member
VIP Member
Power User
I find that after clicking on "Network" at the bottom of the page, accessing the folders from the top location seems more reliable, as compared to accessing the folders from the bottom. Give it a try if you haven't already. As long as you don't get an error, the folders usually open.

Capture2.JPG
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self built
    CPU
    Intel Core i7-4790
    Motherboard
    GA-Z87X-D3H
    Memory
    G.SKILL 8GB (2 x 4GB) DDR3 F3-10666CL9D-8GBNT
    Graphics Card(s)
    Sapphire ATI Radeon R7 250
    Sound Card
    Realtek ALC892
    Monitor(s) Displays
    Samsung UN32EH5000, Dell 1703FPT
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD5003AZEX
    WD10EZEX
    Samsung HD103SJ
    Samsung 128 GB 840 PRO
    PSU
    SeaSonic M12II SS-500GM
    Case
    Fractal Design Define R4
    Cooling
    Zalman CNPS9900ALED
    Keyboard
    Logitech K800
    Mouse
    Logitech M705
    Internet Speed
    16 Mbps
    Browser
    Firefox
    Antivirus
    Avast
    Other Info
    Bose Companion 2 Multimedia Speakers

xunile

Member
Member
Have you tried mapping the drives, or do you always click on the "server" first then access the shared drives?

Also, have you tried using a static ip for the "server".
 

My Computer

System One

  • OS
    Windows 7

Mark Phelps

New Member
VIP Member
Pro User
To reply to the responses ...

As to Advanced Sharing, I was only looking at the dialogue boxes for the partitions, not the one in Networking. So, I went to that, and for All Networks my settings are:
- Public Folder Sharing: Off (since I'm not actually using the "Public" folders)
- File Sharing Connections: use 128-bit ...
- Password Protected Sharing: Off

As to where to click, I find when it fails, it doesn't matter whether I click the PC in the Computer portion of the Network panel, or if I click the Network icon and then click the computer at the bottom of the panel. I have had situations where clicking the bottom icon failed, but clicking the icon in the Computer portion of the top did then work. But, more often than not, if one fails, they both fail.

I don't map the drives because I only turn on the server when needed.

As to IP address, it's currently set to use the DHCP server -- but I'll change it to a static IP and see if the problem returns.

Thanks to all for your feedback.
 

My Computer

chev65

Closed
It may help to change the Workgroup name to something else then reboot and change it back.

I've heard of this problem before and that was about the only thing that had an effect.

The Network icon shouldn't be failing when you click on it.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

XweAponX

New Member
VIP Member
Pro User
When this happens to me, I simply unplug mu router, wait 10 seconds, then plug it back in.

I have a crappy WRT110 router. So what I did to fix the problem was that I used the Router DHCP and I assigned each machine's MAC address a permanent Local Area Network IP address. I have three main machines that are wired in, and 2 others using WiFi. Each have their own IP address.

Once you set up the DHCP and assign the addresses, they don't drift and each connection between machines is stable.

Also, what the last person said: ALL computers in the LAN need to be in the same WORKGROUP. Even if it is named "poop" they ALL have to be on Poop.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.
Top