• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot auto-reconnect to WiFi network with hidden SSID


wpcoe

Member
Member
Mérida, Mexico

Posts
42
#1
I prefer to keep my home WiFi network from public view by disabling the SSID broadcast, i.e "hiding" the network.

With two modem/routers (a Belkin Play Max F7D4401 ADSL modem/router and now a Cisco EPC2325 DOCSIS modem/router) on two computers (home-built desktop and Acer TM8172T notebook), after the initial connection Win8 Pro would not reconnect without tediously re-entering the SSID name and password. Once it does connect, it displays the original SSID name with a new one with an incrementally increasing appended number like:

manage_WiFi.gif

I was manually deleting them all (except the original) using netsh, until I realized you can <right-click> on an entry in the screen above and choose "Forget this network."

This is the process I go through each time to re-connect. Is there something I'm missing?

connect_to_hidden_SSID.gif

I read that if Win8 saves too many WiFi connections, it cannot "remember" them to automatically reconnect to them, so on the notebook, I deleted all but wpcTrue (the original), and it now automatically reconnects, although occasionally it will add a new connection with an incrementally increased number -- currently the notebook shows both wpcTrue and wpcTrue 2. I had used the notebook on the road, so had about five WiFi connections saved. On the Desktop my home network is the only WiFi connection I've ever made. However, no matter what I do on the desktop, it NEVER remembers to automatically log on when the SSID is not broadcast.

I even tried manually setting up a connection via Network and Sharing Center > Set up a new connection or network, to no avail -- the desktop computer will not automatically reconnect.

I doubt that this is relevant, but the Belkin modem/router, the Belkin USB adapter I use on my desktop computer, and the notebook's Broadcom internal modem are all b/g/n. The Cisco modem/router is b/g.

If I "unhide" the SSID, i.e. broadcast the SSID, all is well in the world. Both computers automatically reconnect to the modem/router. If I hide the SSID, and then disconnect or reboot, the desktop computer will not automatically reconnect.

Any ideas?

PS: I just noticed that the pop up WiFi connection column shows "WiFi-2 Off" -- what does the "Off" mean?

And, why is it "-2" ? My notebook just shows "WiFi', period. (The first image with "WiFi (Off)" was from a previous Win8 installation on the desktop computer. I decided to change from EFI-boot to non-EFI so reinstalled Win8. I simply used the old image as a quick way to show how the connection name assignment runs away.)
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    i3-3225
    Motherboard
    H77M-D3H (micro-ATX)
    Memory
    12GB
    Graphics Card(s)
    none (Intel HD4000 IGP)
    Sound Card
    mobo integrated
    Monitor(s) Displays
    Dell U2312HM & Samsung 171N
    Screen Resolution
    1080x1920 (portrait) & 1280x1024
    Hard Drives
    Intel 520, 120GB SSD
    Kingston SNV425S2 64GB SSD
    WD WD10EARS 1GB HDD
    PSU
    Cooler Master eXtreme Power Plus 460W
    Case
    Silverstone TJ-08E
    Cooling
    Intel stock HSF
    Keyboard
    Logitech K260
    Mouse
    Logitech M210
    Internet Speed
    10Mbps/1Mbps DOCSIS

ultradj83

New Member
Posts
2
#2
Same problem here.

Microsoft's support says this is not a technical issue and refuses to assist.

No comment...

By not best workaround is to delete all profile, do a 1st connection to hidden network then disable automatic connection to the network; hidden network will be listed and it will be possible to manually click on connect button.
 

My Computer

System One

  • OS
    Windows 8 Pro
#3

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wullail

Active Member
Pro User
Posts
467
#4
What chev65 said , hiding your SSID just causes more problems than the security it provides , its not just windows 8 , people using various hardware (phones/android tablets) report similar problems when their SSID is hidden in a networking forum I frequent.

The standard answer from everyone in the know there is 'unhide your SSID'.
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Users Who Are Viewing This Thread (Users: 0, Guests: 1)