What's new

BSOD with StorPort.sys.... possible cause?

lotherius

New Member
BSODs with StorPort.sys AND Hal.dll... updated with diags

I've been struggling with a BSOD that happens while my computer is idle.

It has triggered both a HAL error and two storport.sys errors... I think it's actually hit a few more times, because I've found my computer "off" when it shouldn't be, and only an "unexpected shutdown" is recorded with no BSOD information. Have seen a few posts on here with BSOD related to storport.sys also, that don't seem to really find a cause.

EDIT---

I thought it was due to Renesas USB 3.0 drivers, but I uninstalled those and moved my external drives to different non-3.0 ports and it bluescreened again overnight. This time it was Hal.dll that bluescreened, it's been one or the other now 4 times in just a few days, always when the computer has been idle for a long time..

I installed Windows 8 fresh back in January, to get off of the preview now that full 8 is out. It ran fine and without issue until just the last few days.

I've attached the SF Diagnostic Tool logfiles.
 
Last edited:

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    Homebuilt
    CPU
    AMD Athlon II 440
    Motherboard
    MSI 880GMA-E45
    Memory
    8GB DDR3
    Graphics Card(s)
    HD6850
    Sound Card
    Onboard
    Monitor(s) Displays
    Acer P224w
    Screen Resolution
    1680x1050
    Hard Drives
    2x500GB WD5000AACS WD RAID
    3x1TB HD103UJ Samsung RAID
    1x2TB HD204UI Samsung
    2x500GB USB External
    PSU
    Dell XPS 730 1000 Watt
    Case
    Dell XPS 730

usasma

Mr. Cranky Pants
VIP Member
Guru

My Computer

System One

  • OS
    Win8.1Pro - Finally!!!
    Computer type
    Laptop
    System Manufacturer/Model
    Samsung/NP780
    CPU
    Came with the laptop (i7 of some sort)
    Motherboard
    Pretty sure that it has one, but haven't checked inside the case!
    Memory
    upgraded to 12 gB from 8 gB
    Graphics Card(s)
    has switchable - Intel/ATI - Used wrong drivers, now ATI card is inop :( Will have to fix it soon!
    Sound Card
    I'm nearly deaf, so this isn't used often
    Monitor(s) Displays
    Touchscreen on laptop/32" Toshiba on HDMI (laid the Sharp TV on a mouse and cracked the screen!)
    Screen Resolution
    800x600
    Hard Drives
    One Samsung 1tB drive - 5400 rpm. Gonna switch to a 7200/10000 rpm or an SSD (if I can find $500 for a 1tB SSD!)
    - Switched to 500 gB Samsung 840 series SSD - WOW!!!
    PSU
    Why do we ask this for laptops?
    Case
    Silver with a neat Samsung logo
    Cooling
    sub-par, gotta get around to working on it soon Worked on it - still sub-par! :(
    Keyboard
    Microsoft Natural - the same one I've used since it orignally came out around 1995
    Mouse
    no Mouse - Trackball!!!!
    Internet Speed
    too slow when I'm waiting for a download to finish
    Browser
    Yes, I use this (Firefox mostly, w/IE next most)
    Antivirus
    Windows Defender and Windows Firewall
    Other Info
    I'm handsome and a snappy dresser :0)

lotherius

New Member
OP Updated with attachment. Had another bluescreen last night/this morning some time. That's been 2 hal and 2 storport.sys errors.

My hard drive configuration is probably related....

I have 2 500GB drives on motherboard RAID as my system drive. 3 1TB drives as Windows Dynamic Disk "raid", 1 2TB standard drive, and 2 external USB drives... lots of opportunities for weirdness.

The Renesas drivers I had were updated for Windows 8, so apparently they were blameless based on that and the fact the last blue screen happened AFTER I removed those drivers.
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    Homebuilt
    CPU
    AMD Athlon II 440
    Motherboard
    MSI 880GMA-E45
    Memory
    8GB DDR3
    Graphics Card(s)
    HD6850
    Sound Card
    Onboard
    Monitor(s) Displays
    Acer P224w
    Screen Resolution
    1680x1050
    Hard Drives
    2x500GB WD5000AACS WD RAID
    3x1TB HD103UJ Samsung RAID
    1x2TB HD204UI Samsung
    2x500GB USB External
    PSU
    Dell XPS 730 1000 Watt
    Case
    Dell XPS 730

usasma

Mr. Cranky Pants
VIP Member
Guru
IME hal.dll errors are low-level errors, these include:
- borked (broken) hardware (several different procedures used to isolate the problem device)
- BIOS problems (check for updates at the motherboard manufacturer's website)
- overclocking - You'll know if you're overclocking or not. If uncertain we can suggest things to check.
- compatibility issues (3rd party hardware/drivers)
- low-level driver problems
- or even malware (scanned for when we ask for hardware diagnostics from Initial Hardware Diagnostics or Hardware Diagnostics ).

Your BIOS dates from 2011. Please check at the manufacturer's website to see if there are any BIOS updates available for your system. Also check the readme file to see if they apply to the problems that you are having. Please be advised that flashing the BIOS is a very unforgiving process - and one mistake can physically damage your motherboard.

This device is disabled. Is this deliberate? If so, why?
Please enable the device and then update it - then you can disable it again if you'd like.
VirtualBox Host-Only Ethernet Adapter ROOT\NET\0000 This device is disabled.

I'd suggest replacing your RAID drivers because of the storport errors (they call RAID functions in the memory dumps). But that's just a guess on my part.

AMD OverDrive (AODDriver2.sys) is either a stand-alone application, or a component of the AMD VISION Engine Control Center. This driver is known to cause BSOD's on some Windowns systems.
Please un-install all AMD/ATI video stuff from Control Panel...Programs...Un-install a program
Then, download (but DO NOT install) a fresh copy of the ATI drivers from Global Provider of Innovative Graphics, Processors and Media Solutions | AMD (in the upper right corner of the page)
Use this procedure to install the DRIVER ONLY: ATI video cards - DRIVER ONLY installation procedure

If the device (AODDriver or AODDriver4.01) remains a problem, open Device Manager, select the "View" item.
Then select "Show hidden devices" and scroll down to the Non-Plug and Play Drivers section.
Locate the AODDriver entry, right click on it and select "Un-install". Reboot for changes to take affect.
Sometimes the driver remains and continues to cause BSOD's. If this is the case for you, post back and we'll give further instructions for safely removing it.

If overclocking, please stop. Remove the overclock and return the system to stock/standard values while we're troubleshooting. Once the system is stable again, feel free to resume the overclocking.

I have seen issues with Virtual Box on one or two systems. While not a firm diagnostic, it's something to remember for later on.

Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :

ElbyCDIO.sys Thu Dec 16 17:58:13 2010 (4D0A9985)
CDRTools/ElbyCDIO/DVD Region Killer/VirtualCloneDrive (elby CloneDVD™ 2)/AnyDVD
http://www.carrona.org/drivers/driver.php?id=ElbyCDIO.sys

VClone.sys Sat Jan 15 11:21:04 2011 (4D31C970)
VirtualCloneCD Driver by Elaborate Bytes AG
http://www.carrona.org/drivers/driver.php?id=VClone.sys

If all of this doesn't stop the BSOD's, please run Driver Verifier according to these instructions: Driver Verifier Settings



Analysis:
The following is for informational purposes only.
Code:
[FONT=lucida console]**************************Fri Feb 15 08:37:28.368 2013 (UTC - 5:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\021513-48141-01.dmp]
Windows 8 Kernel Version 9200 MP (4 procs) Free x64
Built by: [B]9200[/B].16496.amd64fre.win8_gdr.130108-1504
System Uptime:[B]0 days 6:32:50.579[/B]
Probably caused by :[B]ntkrnlmp.exe ( nt!KiPageFault+260 )[/B]
BugCheck [B]A, {fffffbffffd0172c, d, 0, fffff803fc221e64}[/B]
BugCheck Info: [URL="http://www.carrona.org/bsodindx.html#0x0000000A"]IRQL_NOT_LESS_OR_EQUAL (a)[/URL]
Arguments: 
Arg1: fffffbffffd0172c, memory referenced
Arg2: 000000000000000d, IRQL
Arg3: 0000000000000000, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff803fc221e64, address which referenced memory
BUGCHECK_STR:  AV
DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
PROCESS_NAME:  dwm.exe
FAILURE_BUCKET_ID: [B]AV_nt!KiPageFault[/B]
  BIOS Version                  V17.10
  BIOS Release Date             02/28/2011
  Manufacturer                  MSI
  Product Name                  MS-7623
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Fri Feb 15 02:02:45.917 2013 (UTC - 5:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\021513-88795-01.dmp]
Windows 8 Kernel Version 9200 MP (4 procs) Free x64
Built by: [B]9200[/B].16496.amd64fre.win8_gdr.130108-1504
System Uptime:[B]0 days 12:15:35.616[/B]
Probably caused by :[B]storport.sys ( storport!RaidUnitReleaseIrp+22 )[/B]
BugCheck [B]D1, {2, 2, 0, fffff88001272422}[/B]
BugCheck Info: [URL="http://www.carrona.org/bsodindx.html#0x000000D1"]DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)[/URL]
Arguments: 
Arg1: 0000000000000002, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88001272422, address which referenced memory
BUGCHECK_STR:  AV
DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
PROCESS_NAME:  System
FAILURE_BUCKET_ID: [B]AV_storport!RaidUnitReleaseIrp[/B]
  BIOS Version                  V17.10
  BIOS Release Date             02/28/2011
  Manufacturer                  MSI
  Product Name                  MS-7623
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Thu Feb 14 13:45:20.079 2013 (UTC - 5:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\021413-58359-01.dmp]
Windows 8 Kernel Version 9200 MP (4 procs) Free x64
Built by: [B]9200[/B].16461.amd64fre.win8_gdr.121119-1606
System Uptime:[B]0 days 0:02:07.776[/B]
Probably caused by :[B]storport.sys ( storport!RaidUnitReleaseIrp+22 )[/B]
BugCheck [B]D1, {2, 2, 0, fffff8800140b422}[/B]
BugCheck Info: [URL="http://www.carrona.org/bsodindx.html#0x000000D1"]DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)[/URL]
Arguments: 
Arg1: 0000000000000002, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff8800140b422, address which referenced memory
BUGCHECK_STR:  AV
DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
PROCESS_NAME:  System
FAILURE_BUCKET_ID: [B]AV_storport!RaidUnitReleaseIrp[/B]
  BIOS Version                  V17.10
  BIOS Release Date             02/28/2011
  Manufacturer                  MSI
  Product Name                  MS-7623
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Thu Feb 14 13:40:58.755 2013 (UTC - 5:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\021413-65801-01.dmp]
Windows 8 Kernel Version 9200 MP (4 procs) Free x64
Built by: [B]9200[/B].16461.amd64fre.win8_gdr.121119-1606
System Uptime:[B]1 days 11:24:10.313[/B]
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by :[B]ntkrnlmp.exe ( nt!KiPageFault+260 )[/B]
BugCheck [B]A, {fffffbffffd0172c, d, 0, fffff800e2968e64}[/B]
BugCheck Info: [URL="http://www.carrona.org/bsodindx.html#0x0000000A"]IRQL_NOT_LESS_OR_EQUAL (a)[/URL]
Arguments: 
Arg1: fffffbffffd0172c, memory referenced
Arg2: 000000000000000d, IRQL
Arg3: 0000000000000000, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800e2968e64, address which referenced memory
BUGCHECK_STR:  AV
DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
PROCESS_NAME:  dwm.exe
FAILURE_BUCKET_ID: [B]AV_nt!KiPageFault[/B]
  BIOS Version                  V17.10
  BIOS Release Date             02/28/2011
  Manufacturer                  MSI
  Product Name                  MS-7623
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
[/FONT]

3rd Party Drivers:
The following is for information purposes only.
Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
Code:
[FONT=lucida console]**************************Fri Feb 15 08:37:28.368 2013 (UTC - 5:00)**************************
[COLOR=RED][B]ElbyCDIO.sys                Thu Dec 16 17:58:13 2010 (4D0A9985)[/B][/COLOR]
[COLOR=RED][B]VClone.sys                  Sat Jan 15 11:21:04 2011 (4D31C970)[/B][/COLOR]
amdsbs.sys                  Tue Feb 21 13:15:43 2012 (4F43DF4F)
[COLOR=RED][B]AODDriver2.sys              Thu Apr  5 05:23:37 2012 (4F7D6499)[/B][/COLOR]
netr28x.sys                 Wed Apr 11 04:25:34 2012 (4F853FFE)
Rt630x64.sys                Mon Jul 30 12:03:12 2012 (5016B040)
usbfilter.sys               Tue Aug 28 21:27:12 2012 (503D6FF0)
LHidFilt.Sys                Tue Sep 18 05:26:53 2012 (50583E5D)
LMouFilt.Sys                Tue Sep 18 05:26:58 2012 (50583E62)
VBoxNetFlt.sys              Fri Oct 26 12:59:41 2012 (508AC17D)
VBoxUSBMon.sys              Fri Oct 26 12:59:41 2012 (508AC17D)
VBoxDrv.sys                 Fri Oct 26 13:00:50 2012 (508AC1C2)
RTKVHD64.sys                Tue Dec  4 08:28:37 2012 (50BDFA85)
AtihdW86.sys                Tue Jan 15 15:41:28 2013 (50F5BEF8)
atikmpag.sys                Sat Feb  2 14:40:11 2013 (510D6B9B)
atikmdag.sys                Sat Feb  2 15:51:55 2013 (510D7C6B)
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Thu Feb 14 13:40:58.755 2013 (UTC - 5:00)**************************
PROCMON23.SYS               Tue Jun 19 15:24:55 2012 (4FE0D207)
VBoxNetAdp.sys              Fri Oct 26 12:59:42 2012 (508AC17E)
[/FONT]
http://www.carrona.org/drivers/driver.php?id=ElbyCDIO.sys
http://www.carrona.org/drivers/driver.php?id=VClone.sys
http://www.carrona.org/drivers/driver.php?id=amdsbs.sys
http://www.carrona.org/drivers/driver.php?id=AODDriver2.sys
http://www.carrona.org/drivers/driver.php?id=netr28x.sys
http://www.carrona.org/drivers/driver.php?id=Rt630x64.sys
http://www.carrona.org/drivers/driver.php?id=usbfilter.sys
http://www.carrona.org/drivers/driver.php?id=LHidFilt.Sys
http://www.carrona.org/drivers/driver.php?id=LMouFilt.Sys
http://www.carrona.org/drivers/driver.php?id=VBoxNetFlt.sys
http://www.carrona.org/drivers/driver.php?id=VBoxUSBMon.sys
http://www.carrona.org/drivers/driver.php?id=VBoxDrv.sys
http://www.carrona.org/drivers/driver.php?id=RTKVHD64.sys
http://www.carrona.org/drivers/driver.php?id=AtihdW86.sys
http://www.carrona.org/drivers/driver.php?id=atikmpag.sys
http://www.carrona.org/drivers/driver.php?id=atikmdag.sys
PROCMON23.SYS - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
http://www.carrona.org/drivers/driver.php?id=VBoxNetAdp.sys
 

My Computer

System One

  • OS
    Win8.1Pro - Finally!!!
    Computer type
    Laptop
    System Manufacturer/Model
    Samsung/NP780
    CPU
    Came with the laptop (i7 of some sort)
    Motherboard
    Pretty sure that it has one, but haven't checked inside the case!
    Memory
    upgraded to 12 gB from 8 gB
    Graphics Card(s)
    has switchable - Intel/ATI - Used wrong drivers, now ATI card is inop :( Will have to fix it soon!
    Sound Card
    I'm nearly deaf, so this isn't used often
    Monitor(s) Displays
    Touchscreen on laptop/32" Toshiba on HDMI (laid the Sharp TV on a mouse and cracked the screen!)
    Screen Resolution
    800x600
    Hard Drives
    One Samsung 1tB drive - 5400 rpm. Gonna switch to a 7200/10000 rpm or an SSD (if I can find $500 for a 1tB SSD!)
    - Switched to 500 gB Samsung 840 series SSD - WOW!!!
    PSU
    Why do we ask this for laptops?
    Case
    Silver with a neat Samsung logo
    Cooling
    sub-par, gotta get around to working on it soon Worked on it - still sub-par! :(
    Keyboard
    Microsoft Natural - the same one I've used since it orignally came out around 1995
    Mouse
    no Mouse - Trackball!!!!
    Internet Speed
    too slow when I'm waiting for a download to finish
    Browser
    Yes, I use this (Firefox mostly, w/IE next most)
    Antivirus
    Windows Defender and Windows Firewall
    Other Info
    I'm handsome and a snappy dresser :0)

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top