• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved BSOD 0x9F on shutdown (fast startup enabled)


Posts
2
#1
BSOD 0x9F on shutdown (fast startup enabled) ntoskrnl.exe

Hello,
I'm new to this forum and I hope I post things right! I have a problem with my notebook running Windows 8.1 x64. Since using this piece of **** software iobit driver booster, something went wrong. Im getting a BSOD, when I turn off my nb (even in hibernate mode), but only if fastboot is activated under energy options, if its deactivated its shutting down the normal way without BSOD. That would be okay, but the battery of the notebook is dead so I leave it often in hibernate state so I can unplug the powersupply and take it with me.
I already removed nearly every driver and installed a new one using safe mode, but I keep getting this error.
As of BlueScreenViewer, ntoskrnl.exe is causing the BSOD, but I think it has an other origin. I hope someone can help me, and sry for my english!

I also used sfc /scannow (nothing found) and dism restorehealth (Everytime I run it says something has been repaired but I ran that about 20 times so I think it hangs up anywhere).

This is what the BSOD says:
DRIVER_POWER_STATE_FAILURE, Bug Check: 0x0000009f
00000000`00000003, ffffe001`21e67e50, fffff800`ef649aa0, ffffe001`26e41010

I really dont want to reinstall win because of this. I souldnt have used this *incredible* software..
 
Last edited:

My Computer

System One

  • OS
    Win8.1x64

blueelvis

OMG Debugger!
VIP Member
Pro User
India

Posts
2,097
#2
Hi huabersepp & welcome to the forums ^_^,

I have analysed your dump files and below has been provided an analysis of the same for informative purposes -
[HR][/HR]DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time.
Arguments:
Code:
Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
Arg2: ffffe00121e67e50, Physical Device Object of the stack
Arg3: fffff800ef649aa0, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the Functional Device Object of the stack
Arg4: [COLOR=#FF0000][B]ffffe00126e41010[/B][/COLOR], The blocked IRP
Let's check the 4th parameter highlighted in red -
Code:
0: kd> !irp ffffe00126e41010
Irp is active with 3 stacks 2 is current (= 0xffffe00126e41128)
 No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
     cmd  flg cl Device   File     Completion-Context
 [  0, 0]   0  0 00000000 00000000 00000000-00000000    
   Args: 00000000 00000000 00000000 00000000
>[ 16, 2]   0 e1 ffffe001243d8050 00000000 fffff800edff9b3c-ffffe0012380ca40 Success Error Cancel pending
        \Driver\[COLOR=#0000FF][U][B]RasSstp[/B][/U][/COLOR] nt!PopSystemIrpCompletion
   Args: 00014400 00000000 00000004 00000002
 [  0, 0]   0  0 00000000 00000000 00000000-ffffe0012380ca40    
   Args: 00000000 00000000 00000000 00000000
So, the driver which caused this crash is the Rassstp.sys which is the RRAS Secure Socket Tunneling Protocol Miniport Driver. It is strongly advised not to use the software like Driver Booster (Not so incredible, now eh?) because you never know when they update with a malicious driver or with a driver which is instable. Hence, I would advise you to get your drivers from the manufacturers or Windows Update only.

Below is a list of 3rd party drivers present on your system -
Code:
**************************Sun Apr 12 14:37:31.177 2015 (UTC + 5:30)**************************
[COLOR=#FF0000][B][U]SmSerl64.sys                Fri Sep 26 14:15:56 2008 (48DCA144)
GEARAspiWDM.sys             Mon May 18 17:47:04 2009 (4A1151C0)
fspad_wlh64.sys             Wed Aug 26 14:48:54 2009 (4A94FDFE)
itecir.sys                  Thu Apr 28 15:41:05 2011 (4DB93D39)
[/U][/B][/COLOR]ElbyCDIO.sys                Mon Mar  4 14:51:51 2013 (513467AF)
VClone.sys                  Wed Jul 24 20:32:55 2013 (51EFEC9F)
intelppm.sys                Thu Aug 22 14:16:35 2013 (5215CFEB)
tap0901.sys                 Thu Aug 22 18:10:01 2013 (521606A1)
ITECIRfilter.sys            Wed May 14 13:15:04 2014 (53731F00)
nvhda64v.sys                Thu Oct  9 22:32:27 2014 (5436BFA3)
nvvad64v.sys                Thu Nov 20 21:03:54 2014 (546E09E2)
HWiNFO64A.SYS               Sun Nov 23 21:54:07 2014 (54720A27)
NETwsw01.sys                Fri Dec 19 03:37:33 2014 (54935025)
SbieDrv.sys                 Wed Feb 18 05:49:49 2015 (54E3DAA5)
RTKVHD64.sys                Wed Mar  4 16:06:05 2015 (54F6E015)
nvlddmkm.sys                Fri Mar 13 21:09:56 2015 (550304CC)
http://www.carrona.org/drivers/driver.php?id=SmSerl64.sys
http://www.carrona.org/drivers/driver.php?id=GEARAspiWDM.sys
http://www.carrona.org/drivers/driver.php?id=fspad_wlh64.sys
http://www.carrona.org/drivers/driver.php?id=itecir.sys
http://www.carrona.org/drivers/driver.php?id=ElbyCDIO.sys
http://www.carrona.org/drivers/driver.php?id=VClone.sys
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=tap0901.sys
http://www.carrona.org/drivers/driver.php?id=ITECIRfilter.sys
http://www.carrona.org/drivers/driver.php?id=nvhda64v.sys
http://www.carrona.org/drivers/driver.php?id=nvvad64v.sys
http://www.carrona.org/drivers/driver.php?id=HWiNFO64A.SYS
NETwsw01.sys - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
http://www.carrona.org/drivers/driver.php?id=SbieDrv.sys
http://www.carrona.org/drivers/driver.php?id=RTKVHD64.sys
http://www.carrona.org/drivers/driver.php?id=nvlddmkm.sys

Kindly follow the below steps -

  1. Kindly update the drivers highlighted in RED. I have provided links above for further information.
  2. Kindly remove OpenVPN as it is known to cause problems.


Let me know how it goes ^_^

-Pranav
 

My Computer

System One

  • OS
    Windows 8.1 Industry Pro B-)
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba
    CPU
    Core I5 2430M @ 2.4GHz
    Memory
    8 GB DDR3 @ 1600MHz Dual Channel ^_^
    Graphics Card(s)
    Intel HD 3000 B-)
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500 GB
    Browser
    Google Chrome
    Antivirus
    Windows Defender & Common Sense!
Posts
2
#3
Hey,
well what should I say, its working! I deleted and installed the suggested drivers you said, also deleted the vpn connection and all MS WAN Drivers (theres a tut with registry and device manager). Now it works again like a charm, fast boot works and hibernate also, Im very happy!!
Thank you very much for assistance and help!!
 

My Computer

System One

  • OS
    Win8.1x64

blueelvis

OMG Debugger!
VIP Member
Pro User
India

Posts
2,097
#4
Hey,
well what should I say, its working! I deleted and installed the suggested drivers you said, also deleted the vpn connection and all MS WAN Drivers (theres a tut with registry and device manager). Now it works again like a charm, fast boot works and hibernate also, Im very happy!!
Thank you very much for assistance and help!!
Hi huabersepp ^_^,

Glad to hear that the issue has been solved and thanks for the rep. ^_^

-Pranav
 

My Computer

System One

  • OS
    Windows 8.1 Industry Pro B-)
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba
    CPU
    Core I5 2430M @ 2.4GHz
    Memory
    8 GB DDR3 @ 1600MHz Dual Channel ^_^
    Graphics Card(s)
    Intel HD 3000 B-)
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500 GB
    Browser
    Google Chrome
    Antivirus
    Windows Defender & Common Sense!

Users Who Are Viewing This Thread (Users: 0, Guests: 1)