• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Bluetooth devices not detecting?!?!


squibly

New Member
Posts
2
#1
I've got an Acer Aspire S3-951, just installed Windows 8 Release Preview Build 8400.

All devices have installed, the bluetooth module shows up in the device manager. I've downloaded and installed the Atheros Bluetooth driver from the Acer website. However when I try to add a bluetooth device it doesn't find anything - it just says "Searching for devices" and eventually says "No devices found". I've placed two mice in pairing mode but neither show up (Logitech M555b and Kliq KL-TSMBT3), it doesn't even detect my iPhone.

Anyone got any ideas or fixes??
 

My Computer

System One

  • OS
    Windows 8 Release Preview (Build 8400)
    System Manufacturer/Model
    Acer Aspire S3
    Memory
    4GB
Posts
2
#2
Right now, I'm having the exact same problem. I have that model too. I ran a Windows Troubleshooter, and it came up with lots of bluetooth problems. It told me to reinstall the drivers for it, so I'm trying to do so right now...
 

My Computer

System One

  • OS
    Windows 8 Build 8400
    System Manufacturer/Model
    Acer
    CPU
    Intel Core i5
    Memory
    4gb

squibly

New Member
Posts
2
#3
I was able to resolve the issue.

Although the bluetooth drivers seem to install ok the software never actually ran. I had to change the setup file to run in compatibility mode (think it was set to XP SP3) and just to be safe I ticked run as administrator. When the setup file ran it changed the screen resolution, everything looked huge, it installed properly and changed automatically back to normal res and after that I could add my bluetooth mouse :)

Hope this helps.
 

My Computer

System One

  • OS
    Windows 8 Release Preview (Build 8400)
    System Manufacturer/Model
    Acer Aspire S3
    Memory
    4GB

Users Who Are Viewing This Thread (Users: 0, Guests: 1)