• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Bluetooth Device Missing, Unknown USB Device


roboticj

New Member
Posts
3
#1
Recently I attempted to connect to an existing paired connection to my phone via bluetooth. I have never had this problem before, yet suddenly Bluetooth is missing. There is no longer an icon in the taskbar, the setting in "PC and Devices" is missing, and there appears to not be a driver installed, rather, an ""Unknown USB Device (Device Descriptor Request Failed)" appears in my devices instead. I have taken many steps to attempt and fix this, such as:


  • manually starting Bluetooth services from services.msc
  • uninstalling the "Unknown Device" driver, then attempting to let Windows reinstall
  • downloaded the driver software from Lenovo for the Bluetooth adapter, installed it manually restarted
  • take a system restore created yesterday and revert back to it

Everything else in the PC functions perfectly. Any help is appreciated
 

My Computer

System One

  • OS
    Windows 8.1 Professional
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Y510p
    CPU
    Intel i7-4700MQ @ 2.40GHz
    Memory
    16 GB
    Graphics Card(s)
    Dual GTX 755M SLI

pdubs

New Member
Posts
9
#2
I had a similar problem recently where my bluetooth seemed to have just disappeared.
I ran the Find and Fix problems with devices (Just typed it into the start screen). It found one thing which by memory said something about a usb device being disabled. Clicked for it to fix the problem and enable it. Sure enough my bluetooth was right back.
Not sure if it will work for you, but its worth a try.
Good Luck
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    MSI GT70 2OD 058AU
    CPU
    i7 4700mq
    Memory
    32gb
    Graphics Card(s)
    Nvidia GTX780m

roboticj

New Member
Posts
3
#3
Ok, I finally solved this. I ran CCleaner today to remove unused temp files and registry errors and restarted. Suddenly the driver started installing and works perfectly. Must have been a weird registry error.
 

My Computer

System One

  • OS
    Windows 8.1 Professional
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Y510p
    CPU
    Intel i7-4700MQ @ 2.40GHz
    Memory
    16 GB
    Graphics Card(s)
    Dual GTX 755M SLI