• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Black screen while video playback (Audio only)


Haikgh

New Member
Posts
36
#1
Hey guys.
I discovered that besides VLC player on my laptop all the other video player are not able to work properly (meaning,, Windows Media Player 12, Cyberlink PowerDVD12 and WMPC are able to play only the audio, but not the video, it's just black screen),, BUT with VLC is no problem playing any video format!! The thing is that I didn't have this problem previously,, all my video players were able to play all the same video files, which they can't now!
I have the latest AMD Radeon HD video drivers installed. As I mentioned I didn't have this problem before,, with a previous versions of the AMD graphics card driver. This happened to my laptop a while ago already,, since I have this problem I updated my video drivers 5 or 6 times at least, and no change so far !!!

As I mentioned I have the problem for some time already, during this time I re-installed my Windows couple of time, plus I even changed the version of the windows (7to8), for the moment I have the last version of video driver installed, I haven't installed ANY codecs
Can anyone help me with this pleas?
Thanks and have a nice day, hope we can solve this. ))
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#2
Can you simply give us an example of a video extension that will not play anymore in WMP, now that you have upgraded to Winn 8 and done several graphic driver updates in an attempt to fix your issue (eg, .avi files, .mpg files, etc)? It could very well be that the original codec is no longer supported in WMP but the fact that VLC works Ok tells me that your graphics' driver should not be the issue.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

Haikgh

New Member
Posts
36
#3
well this is all I want it to play avi, mp4, mkv lately I had a chance of playing some m4v as well, which also didn't play.
I am assuming that this has something to do with the graphic driver, because previously when I had Windows 7 and I just started to get this problem,, I won't have it right I after I clean re install the windows, meaning while I had the generic drivers from Windows 7, right after I install the graphic card driver from the AMD I would get the black screen. (I have to install the AMD drivers coz otherwise I can not run any game).
Thanks for response, hope we will figure something out. :)
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#4
Hi Haikgh,

You first identified an issue with playing video files using WMP (and other players)
You then confirmed that VLC works OK
You then stated that it might be a driver issue
I disagreed because you stated that VLC works OK
I then asked for specific files that didn't work
You provided me with a list of files that you want to work
Some of those file extension will not play on WMP (and never could)

Unfortunately, I can't get a handle on your issue so hang in their for additional assistance. Good luck.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#5

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

Haikgh

New Member
Posts
36
#6
I have never used ANY codec pack ever, but yet I was able to play all those mentioned common video formats with Windows media player, Cyberlink PowerDVD and all the other players I ever had, besides VLC of course, which dose not have a problem even now (due to it's integrated codecs). Plus all THOSE mention video files are playing on others laptops just fine, with NO codecs installed!!!
Thanks for reply, hope there will be other suggestions .
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6
#7
well this is all I want it to play avi, mp4, mkv lately I had a chance of playing some m4v as well, which also didn't play.
I am assuming that this has something to do with the graphic driver, because previously when I had Windows 7 and I just started to get this problem,, I won't have it right I after I clean re install the windows, meaning while I had the generic drivers from Windows 7, right after I install the graphic card driver from the AMD I would get the black screen. (I have to install the AMD drivers coz otherwise I can not run any game).
Thanks for response, hope we will figure something out. :)
Have you tried RealPlayer ?

Play Any Video Format ? RealPlayer

http://www.real.com

It should play all the files you mentioned.
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security

Haikgh

New Member
Posts
36
#8
Thanks for suggestion David Bailey,, but honestly I'd love to be able to make "Media Player Classic" work again!
My problem is that I am able to play the video file, BUT it's just playing the audio of that video file and instead of image it shows me a black screen.
Thanks
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6
#9
Thanks for suggestion David Bailey,, but honestly I'd love to be able to make "Media Player Classic" work again!
My problem is that I am able to play the video file, BUT it's just playing the audio of that video file and instead of image it shows me a black screen.
Thanks
OK.
Good luck. :)
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
Posts
1
#10
I'm happy to finally see someone else with the same problem, but disappointed not to see a solution.

I recently installed Windows 8.1 Pro 64-bit to a clean hard drive on a Sony Vaio with an AMD Mobility Radeon HD 5000 video card. Everything runs fine with Windows finding up-to-date drivers from AMD even after uninstalling the adapter. But video has never played for me correctly.

The Media Player window sizes appropriately for the video I play, and I hear the audio, but the video is always just black. The Metro-style "Videos" app also plays black, but it's full-screen so I can't tell whether it detects the video size. My first attempt was to install the CCCP codec pack since it has always played everything I've thrown at it. It installed and gave me the Media Player Classic, but even it played with a black screen. And I'm certain it has the codecs for the mp4 and wmv files I've thrown at it. I've also streamed video from my DLNA/uPnP server that has worked on phones, tablets, PCs, SmartTV, Playstation. But Windows 8.1 can't draw the picture. These are videos I used to play on Windows 7 without issue in any player I chose.

After reading this post, I installed VNC. It plays the videos just fine. Full video and audio from VNC.

I wish I had a solution to share. If I find one, I'll post it. I hope this additional detail might help someone think through what might be broken.
 

My Computer

System One

  • OS
    Windows 8.1 Pro

Haikgh

New Member
Posts
36
#11
Now this is strange ! Apparently another person who has exact same problem as me, is also encountering the issue on Sony VAIO o_O
So here again my problem:
Originally I had a Windows 7 pre-installed on my Sony VAIO and for very long time I had no problem with a playback of video formats like MP4 and AVI! Then after a while (didn't change the Windows version but I did regularly updated my graphic card drivers) I started to experience the issue described above (was not able to successfully play MP4 and AVI formats on anything BUT VLC and buy successfully I mean I had audio only with black screen).
What I did I try ?!
I re-installed my Windows 7 (fresh),
I fresh installed Windows 8 (as soon as it was released),
I fresh installed Windows 8.1 (as soon as it was released), and trough out all this period I was keeping my graphic card up to date.
After all this Windows installations I didn't have the problem solved, but as I mentioned above some of my friends had the exact same versions of Windows installed and they were able to play those exact MP4 and AVI files that I had, on their laptops!!
Deduction:
The problem is not the OS or the way it is installed (coz I always install fresh, as well as I am the one installing for my friends on their machines) !
So what is my problem ? I have no idea, I have this issue posted on all possible treads and forums and had no success :(
Pleas ask me some additional information you need to help me solve this problem.
p.s.​
mightypile
i am [FONT=verdana, Tahoma, Calibri, Verdana, Geneva, sans-serif]surprised[/FONT] that VLC wasn't your 1st option to try :))
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6
Posts
1
#12
I also have Sony Vaio, and the same problem after installing Win. 8.1.
It's relief that video works in VLC player, thanks for that. I hope someone find the solution for our problem.
 

My Computer

System One

  • OS
    8.1

Haikgh

New Member
Posts
36
#13
Woow I am very surprised that so far no one has come up with a fix for this,, or maybe it's not so common problem ?! It seams that most of the pp; who has this problem, they all have Sony VAIO o_O.
 

My Computer

System One

  • OS
    Windows 8 Pro-64 bit
    CPU
    Intel Core i5 M430
    Memory
    4 Gb
    Graphics Card(s)
    Mobility Radeon HD 5650 1024MB
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500Gb
    Antivirus
    Eset Smart Security 6

BrianAllen

New Member
Posts
1
#14
Same Problem Too!

I've been having the same problem for months on my Sony! Not at home to give my exact specs but been having so frustrating! I have 2 partitions. One with win7 and one with win8.1. After I updated from win8 to 8.1 on my 2nd partition, I can't get any video to playback correctly with any video program. It's exactly what you describe... It plays the sound, but no visual on all formats. Now, I can play videos through we browsers though, no problem. I have pretty much given up and reverted back to win7. Still have the 2nd partition with win8.1 but find it useless since I cannot playback video correctly and I need play videos a lot for training. Please someone help! Will post exact specs at later time. Does not seem like a driver issue.
 

My Computer

System One

  • OS
    8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Sony
    Browser
    Chrome
Posts
1
#15
I've been having the same problem too, and it is in a Sony VAIO. If you change the drive of the Video Card to the Windows adapter video, the windows Media Player will back to work again. It not affect only the WMP, but the video app, every app with video things, IE videos and Power Point videos. So, looks like a driver issue to me. Someone solved this? The newst drives dont work.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    Memory
    6 GB
    Graphics Card(s)
    AMD Radeon HD 5000
    Browser
    Mozzilla Firefox

Attila

New Member
Posts
1
#16
Hi All,
It seems it not depends on windows version. I still have windows 7. And by the istalling new radeon (catalyst) driver i got the same problem.
After removing the catalyst the videos worked properly. But i need the radeon driver because i can't use the HDMI output with the basic windows driver.
I have an idea: i try to find an old radeon driver and i don't let it to refresh itseves if it works.
 

My Computer

System One

  • OS
    Windows 7 professional
    Computer type
    Laptop
    System Manufacturer/Model
    Sony Vaio
    CPU
    Intel i3
    Graphics Card(s)
    AMD radeon HD 5xxx
Posts
1
#17
Yes, the same set and the same problem: ATI Mobility Radeon series 5000, Sony Vaio and Windows 8.1 or Windows 10. Yes with Microsoft Basic Display Adapter; everything seems ok except the resolutions (i need them :( )... It seems to me that the curse has not been solved yet and its 2018!.. Thanks to all, Sony, ATI and off course to MS at the same time!.. (Any idea?..)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    SONY VAIO
    CPU
    i5
    Memory
    4
    Antivirus
    -

Users Who Are Viewing This Thread (Users: 0, Guests: 1)