• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

AutoPlay - Turn On or Off in Windows 8


Brink

Administrator
Administrator
mvp
Posts
23,376
AutoPlay - Turn On or Off in Windows 8
This tutorial will show you how to turn AutoPlay on or off for your user account in Windows 8, Windows RT, Windows 8.1, and Windows RT 8.1.
Published by Brink
#1
Category:
ByLine
How to Turn AutoPlay On or Off in Windows 8 and 8.1
Synopsis
This tutorial will show you how to turn AutoPlay on or off for your user account in Windows 8, Windows RT, Windows 8.1, and Windows RT 8.1.
How to Turn AutoPlay On or Off in Windows 8 and 8.1


information   Information
AutoPlay lets you choose an action for different kinds of media when you plug in a device, insert media, or receive content from another person using Tap and Send. You can set AutoPlay to open different kinds of content, such as photos, music, and video on different kinds of media, such as drives, CDs, or DVDs. For example, you can use AutoPlay to select an app that will automatically open photos on a removable drive when you plug it into your PC. With AutoPlay, you don't have to open the same app or reselect preferences every time you plug in a certain device.

This tutorial will show you how to turn AutoPlay on or off for your user account in Windows 8, Windows RT, Windows 8.1, and Windows RT 8.1.

Note   Note

  • You will only see AutoPlay open with a notification when you have AutoPlay turned on and plug in a device, media, or content that already has it's action set to either "Choose a default" (default) or "Ask me every time".

  • You can completely turn off AutoPlay or just turn off AutoPlay for only one type of media or content.

  • If your PC doesn't support the Tap and Send technology, then you won't see this option in AutoPlay.

  • If you connect a storage device to your PC (for example, a USB flash drive or other external drive), that device won't appear under Devices in AutoPlay. AutoPlay only shows non-storage devices, such as some digital cameras, video cameras, and phones. You can view storage devices in the This PC window in File Explorer.

  • You can press and hold the Shift key when you insert devices or media into your PC to open an AutoPlay notification, regardless of the default setting.

EXAMPLE: AutoPlay Notification
NOTE: This is an example of an AutoPlay notification when plugging in a camera and USB flash drive asking you to choose what action you want to use. The AutoPlay notification will open at the top right corner of your main display.
AutoPlay_Notification_Camera.jpg
AutoPlay_Notification-USB.jpg






OPTION ONE
Turn On or Off AutoPlay in Control Panel

1. Open the Control Panel (icons view), and click/tap on the AutoPlay icon.​
2. Do step 3, 4, or 5 below for what you would like to do.​
3. To Completely Turn Off AutoPlay
A) At the top, uncheck the Use AutoPlay for all media and devices box, and go to step 6 below. (see screenshot below step 6)​
4. To Turn Off AutoPlay for Only One Device, Media, or Content
A) If not already, check the Use AutoPlay for all media and devices box at the top. (see screenshot below step 6)​
B) In the drop-down list next to the device, type of media, or content that you don't want to be asked about, click/tap on the Take no action option. (see screenshot below)​
Take_no_action.jpg
C) When finished, go to step 6 below.​
5. To Turn On AutoPlay
NOTE: This is the default setting. When turned on, this does not affect any actions you already have set.​
A) At the top, check the Use AutoPlay for all media and devices box. (see screenshot below step 6)​
B) In the drop-down list next to the device, type of media, or content choose the new default AutoPlay action you want.​
C) When finished, go to step 6 below.​
6. Click/tap on the Save button to apply.​
Auto_Play_Control_Panel.jpg





OPTION TWO
Turn On or Off AutoPlay in PC settings

NOTE: This option is only available in Windows 8.1 and Windows RT 8.1.
1. Open PC settings, and click/tap on PC & devices on the left side. (see screenshot below)​
AutoPlay_PC_settings-1.jpg
2. Click/tap on AutoPlay on the left side, and do step 3, 4, or 5 below for what you would like to do. (see screenshot below)​
AutoPlay_PC_settings-2.jpg
3. To Completely Turn Off AutoPlay
A) On the right side under AutoPlay, move the slider to the left to turn it off, and go to step 6 below. (see screenshot below step 2)​
4. To Turn Off AutoPlay for Only One Device, Media, or Content
A) If not already, on the right side under AutoPlay, move the slider to the right to turn it on. (see screenshot below step 2)​
B) In the drop-down list next to the device, type of media, or content that you don't want to be asked about, click/tap on the Take no action option. (see screenshot below)​
PC_settings_Take_no_action.jpg
C) When finished, go to step 6 below.​
5. To Turn On AutoPlay
NOTE: This is the default setting. When turned on, this does not affect any actions you already have set.​
A) On the right side under AutoPlay, move the slider to the right to turn it on. (see screenshot below step 2)​
B) In the drop-down list next to the device, type of media, or content choose the new default AutoPlay action you want.​
C) When finished, go to step 6 below.​
6. When finished, you can close PC settings if you like.​





OPTION THREE
Turn On or Off AutoPlay using a REG File


Note   Note
The .reg files below are for the registry key and value below.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers

DisableAutoplay DWORD

0 = Turn On AutoPlay
1 = Turn Off AutoPlay


1. Do Step 2 or 3 below for what you would like to do.​
2. To Turn On AutoPlay
NOTE: This is the default setting.​
A) Click/tap on the Download button below to download the file below, and go to step 4 below.​
Turn_On_AutoPlay.reg
download


3. To Completely Turn Off AutoPlay
A) Click/tap on the Download button below to download the file below, and go to step 4 below.​
Turn_Off_AutoPlay.reg
download


4. Save the .reg file to your desktop.​
5. Double click/tap on the downloaded .reg file to merge it.​
6. When prompted, click/tap on Run, Yes (UAC), Yes, and OK to approve merging the .reg file.​
7. You can now delete the downloaded .reg file if you like.​



That's it,
Shawn


 
Last edited by a moderator:

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
3
#2
In Windows 8.1, I configured all the settings to autoplay audio CDs and after a reboot, inserting a CD will autoplay the first time but the first time only. After that, it will not start. I put a Windows Media player tile on the Metro interface and a cd will play if you click that but the 2nd one will not autoplay. First one after a reboot works every time. Ideas?
 

My Computer

System One

  • OS
    8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell
    Browser
    Chrome
    Antivirus
    AVG

Brink

Administrator
Administrator
mvp
Posts
23,376
#3
Hello Tom, and welcome to Eight Forums.

Just to make sure, if you remove the CD and insert it again, it doesn't autoplay?
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
3
#4
Yes, the first time after a reboot it works like one would expect. Just insert the audio CD, windows media player pops up and plays but if you eject the first one after a while and insert another, nothing happens. This is after looking at all the usual autoplay (from control panel) settings, etc. Clicking on the Windows Media Player I put on the Tiles, works fine any time. Hoping there is some other place to change. This is actually on a friends new machines. I warned him not to get Windows 8 but he did anyway. At least he can play CDs but I'd like to know why it does this. I coudn't find it after several searches in the forums. Thanks.
 

My Computer

System One

  • OS
    8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell
    Browser
    Chrome
    Antivirus
    AVG

Brink

Administrator
Administrator
mvp
Posts
23,376
#5
I must admit that I'm not sure why it's doing that. :(
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
3
#6
There must be some other Win 8.1 setting that is not obvious. MS really made this more obtuse than it had to be. Maybe someone will see this and respond.
 

My Computer

System One

  • OS
    8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell
    Browser
    Chrome
    Antivirus
    AVG