• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

ASUS Sonicmaster Subwoofer not working (not detected ?)


yoyoloto

New Member
Posts
1
#1
Hi, I just bought a brand new ASUS N series today, and it came with a sonicmaster subwoofer, which unfortunately doesn't work. Whatever I play it comes out of the regular computer speakers, and I've made sure all the time that the sub was plugged correctly and at the right place (subwoofer jack, just like it says in the manual).

So what can I do here ?

Thanks for the help
 

My Computer

System One

  • OS
    Windows 8
#2
I'm having the same trouble in Windows 8 but it works lovely under 7 (I'm dual booting) I think there is a bit of software missing for 8 which I may have just found - will update shortly.
 

My Computer

System One

  • OS
    Win 7 & Win 8pro 64 bit
    System Manufacturer/Model Number
    ASUS N55SL-S1188V
    CPU
    i7-2670QM 2.2ghz
    Memory
    6gb
    Graphics Card(s)
    Nvidia GT635M
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Full HD
    Screen Resolution
    1920 x 1080
    Hard Drives
    Hitachi 750GB
    Internet Speed
    crap - rural!
#3
I received an ASUS driver disk with my laptop - I ran this under win 8 and it immediately didn't want to use it telling me it was for 7 only (which is why I had not tried it earlier). I ran it again under compatibility settings - BE VERY CAREFUL - only select the Audio driver + Sonic Master + Sonic Blast and of course anything you are SURE you want or you will overwrite all your drivers (which in 8 would be a bad idea).

It works!! and by golly do it sounds grrrrrreeeaaat!! Good luck!
 

My Computer

System One

  • OS
    Win 7 & Win 8pro 64 bit
    System Manufacturer/Model Number
    ASUS N55SL-S1188V
    CPU
    i7-2670QM 2.2ghz
    Memory
    6gb
    Graphics Card(s)
    Nvidia GT635M
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Full HD
    Screen Resolution
    1920 x 1080
    Hard Drives
    Hitachi 750GB
    Internet Speed
    crap - rural!
Posts
2
#4
Hi, I just bought a brand new ASUS N series today, and it came with a sonicmaster subwoofer, which unfortunately doesn't work. Whatever I play it comes out of the regular computer speakers, and I've made sure all the time that the sub was plugged correctly and at the right place (subwoofer jack, just like it says in the manual).

So what can I do here ?

Thanks for the help
From 2018 here , I struggle with this problem for weeks,and this is the solution :

1-In the taskbar (bottom left of screen next to the clock) right click on the "Speaker icon" and select "troubleshoot sound problems"

2-From there is easy,It may show you your sound cards or drivers,select "realtek hd"

3-Then select "yes,open audio enhancement"

4-It will pop up a screen while the main screen is loading something,wait till it ends (dont touch anything!)
then select "apply this fix" and restart your laptop!

It will detect the bang and olufsen external subwoofer ,enjoy the sweet taste of high quality music ;)

p.s : All this fix was done in windows 10 pro,it may be a similar route for fix in windows 8/8.1
 

Attachments

My Computer

System One

  • OS
    windows 10
Posts
2
#5
UPDATE July 2018 :

Guys I found the ultimate fix for this problem without restarting after the troubleshoot.

In the start menu type "sound" and click on it.
In the popup window find "Speakers.realtek high definition audio" .Right click on it and select "properties".
Now go to "advanced" tab and in the middle of the window you see a botton called " restore defaults".

Click on it and then click ok,and again ok.

Your asus subwoofer should work flawlessly by now.

#asusn56 #subwoofer
 

My Computer

System One

  • OS
    windows 10