• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

AMD Vid drivers don't seem to be working - no CCC?


West

New Member
Posts
6
#1
I installed Consumer Preview yesterday and downloaded the beta AMD GPU drivers. They installed fine and I thought everything was properly working, however Minecraft says there's a video driver issue and CCC seems to be missing from my system entirely. I then uninstalled the Win 8 beta drivers and installed the 12.2 Beta drivers with the same result. I need CCC to be able to turn my TV (2nd monitor) on and off.

Any ideas? Should I use a driver uninstall program and try again? This is frustrating :(

Thanks in advance
 

My Computer

System One

  • OS
    Windows 8 x64
USA

Posts
118
#2
I'm having the same problem as well for my 4800 series card. I haven't confirmed this for myself...but I've heard tell that the older CCC versions worked....11.11, 11.12. That is a few have said it worked for them.

There is this mod version from the Guru3D forum that's supposed to work as well....

[email protected]
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5

West

New Member
Posts
6
#3
Yeah I have a 4870 too.

I think I'm going to give these modded Win 8 drivers or 11.12 drivers a try. From reading on Guru3D those seem to have the greatest likelihood to work properly.

-----
EDIT
-----

OK so I tried the modded Win 8 driver, 12.2 and now 12.1. Using 'install from file on comp' through device manager I was able to install 12.1 successfully and then I installed it the normal way with the exe setup. This combo seemed to work to install everything correctly. However CCC is still broken, it seems that it installed correctly but it gives me this error when I try to open:

 
Last edited:

My Computer

System One

  • OS
    Windows 8 x64
USA

Posts
118
#4
Yep...the same for me. I've had no luck getting any driver to work.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5

fma965

New Member
Posts
6
#5

My Computer

System One

  • OS
    Win 8 CP and 7 x64
    CPU
    AMD FX-6 6100 Black Edition 6 Core 3.3Ghz Socket AM3+
    Motherboard
    Asus M5A78L-M/USB3 AMD Socket AM3+ 8 Channel HD Audio mATX
    Memory
    Corsair 4GB DDR3 1600mhz Vengeance Memory Module CL9 1.5V Non-ECC Unbuffered
    Graphics Card(s)
    Saphire HD6770
    Sound Card
    Onboard (VIA Vinyl VT1708s)
    Monitor(s) Displays
    Acer AL 1717 LCD Monitor, LG 32lh3200
    Screen Resolution
    1280 * 1024 , 1360 * 768
    Hard Drives
    WD 2TB 3.5" SATA-III 6GB/s Caviar Green Hard Drive
    PSU
    CIT 750W Dual 12V Rail 12cm Fan PSU - 4x SATA 1x PCI-E
    Case
    Standard Old Case
    Cooling
    Stock + 2 Case Fans
    Keyboard
    Standard DELL
    Mouse
    logitech wireless laptop mouse
    Internet Speed
    8-16mbp/s Download | 1-2mbp/s Upload
USA

Posts
118
#6

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5

Kevin Ismail

Revived
VIP Member
Power User
Solo.

Posts
2,161
#7
Hi.
Latest driver of AMD/ATI is quite an issue with WDP and WCP though it works perfectly with Win 7.

You may have to stick to Version 11.9 or 11.12 if you want the CCC work for you.
Or you may try this trick see #1648. you can do as it said or versa. Old CCC over new driver.
It's a bit tricky but sure you can do it.

Catoer
 

My Computer

System One

  • OS
    Windows 10 Pro 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Built system
    CPU
    Core i5
    Motherboard
    Intel DH55PJ
    Memory
    4 GB
    Graphics Card(s)
    ATI 4650
    Sound Card
    Realtek HD Integrated
    Monitor(s) Displays
    LG Flatron L1742S; LG Flatron 19"; Samsung TV 48"
    Screen Resolution
    1280:1024; 1366:768;1920:1080
    Hard Drives
    SSD 256 GB
    Seagate Barracuda 500 GB
    WDC 1 TB
    PSU
    Power
    Case
    Simbadda
    Cooling
    Conventional
    Keyboard
    Logitech Wireless
    Mouse
    Logitech Wireless
    Internet Speed
    1.4 MBPS
    Other Info
    External HDD WDC 2 TB
    Dial Up Modem Huawei
    Home-made Home Theater

Corpsecrank

NSFW
Member
Posts
48
#8
Uninstall all amd software and start clean. If you don't things don't work for whatever reason. Also it is going to say there were warnings but if you take a look at the log there really weren't any problems. Make sure you have the latest set for the consumer preview also. The first set just didn't work.
 

My Computer

System One

  • OS
    Win7 Ultimate x64 SP1
    System Manufacturer/Model
    Custom Build (What Else Would It Be?)
    CPU
    AMD Phenom II X6 1100T Black Edition Thuban 3.3GHz, 3.7GHz
    Motherboard
    Gigabyte GA-890FXA-UD5
    Memory
    CORSAIR DOMINATOR GT 8GB (2 x 4GB) 1866 DDR3
    Graphics Card(s)
    XFX HD-697A-CNDC Radeon HD6970 2GB 256-bit
    Sound Card
    Creative SoundBlaster X-Fi Platinum Fatal1ty Edition
    Monitor(s) Displays
    Dual 25 Inch Hanns-G HZ251
    Screen Resolution
    3840x1080 (1920x1080 x2)
    PSU
    Corsair 850W Single Rail
    Case
    Thermaltake V9 BlacX w/ Dual HDD Docking Station
    Cooling
    Air/Copper
    Keyboard
    Kensington (Low-Profile)
    Mouse
    Creative Fatal1ty
    Internet Speed
    Cable 15Gbit (15 Down 5 Up)
    Other Info
    XIGMATEK HDT-S1284F 120mm HYPRO Bearing CPU Cooler, LG Blu-Ray Burner.

West

New Member
Posts
6
#9
Well there are clearly issues with the drivers with Win 8 (at least for some) so I'm going to dual boot with Win 7.

I've tried 12.1, 12.2, and the Win 8 CP Beta Drivers. 12.1 is the only one that I can get CCC to install properly using a combo of force install through device manager and then a full install via the standard exe, but CCC fails to open at all (see error pic above). With all 3 driver versions the drivers themselves install but clearly seem to have issues. Minecraft won't recognize any of the drivers and says I have a bad OpenGL driver every time. I tried BF3 last night and it actually worked but the performance was weird. It ran about the same (seemed a little worse) on the ground but when I got in an aircraft it was like a slideshow and unplayable. And the odd thing is that usually I get the best performance up in the air. And every time I've installed a new driver version I've used Driver Sweeper to completely remove all traces of AMD drivers and start anew. I also double check every time that the drivers were fully removed with the analyze feature.

I've debated about trying 11.12 as well but it sounds to me like that might just fix my CCC problem and the drivers themselves will still not work as they should. So in the end I'm just going to take the less frustrating route and dual boot with Win 7. I was really hoping to use Win 8 as my primary OS, and if it weren't for the crappy drivers I probably would be able to :(

If I find out anything more or have any better luck I'll post in here to hopefully help other people with the similar issues.
 

My Computer

System One

  • OS
    Windows 8 x64

pazman2k

New Member
Posts
1
#10
Guys, installing 11-12_vista64_win7_64_dd_ccc_ocl.exe by right clicking and selecting Troubleshoot Compatability (which set it to Win XP SP3) has solved this for me.


CCC installs and runs fine, I can configure the overscan and my second monitor is finally back to normal.
 

My Computer

System One

  • OS
    Win 8 CP x64

Users Who Are Viewing This Thread (Users: 0, Guests: 1)