• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

AMD Drivers black screen, 3rd monitor doesnt work


tomha

New Member
Posts
8
#1
First off, I have done some research and found other similar posts around, but none of the solutions have helped me, and they don't directly line up with my problems.

I currently have Windows 7 installed, I am dual booting Windows 8 on a partition on my SSD because I am skeptical (though optimistic), and want to give it a go first. So I install Windows 8 professional 8.1 (It's from Microsoft's dreamspark program, if it makes a difference), and that works fine, then I install all the drivers.

I have 3 screens, on a fresh install, the two plugged into my card's mini displayport ports work as duplicate screens, and work fine. After a few minutes, Windows seems to find a version of the AMD drivers with Catalyst Control Center, which it installs, at which point I can use all 3 screens in a proper extended desktop. The problems arise when I try to install the latest AMD drivers myself. I am using the correct version, 64-bit for Windows 8.1. I have tried the latest stable release, 13.12, and beta release, 14.3.

In both cases, I begin installing the drivers, just as I would in Windows 7, about 2 thirds of the way through the installation one of the screens becomes inactive and the remaining two go black, not off, just black. I wait, nothing happens, the only thing to do is turn off the computer manually with the power button. When I turn it back on, the windows logo loads, but before the lock screen I get another black screen, this time with a cursor and the spinning loading logo. One time I got it to go to the desktop but furiously spamming the enter, escape, and space buttons, but the other times I have to reboot again. On the second reboot, windows loads fine, but now I can only use 2 screens. I can pick any 2 screens I want, and use them as a extended desktop, but if I right click the desktop, go to resolution, and try and activate the third screen, which is disabled, Windows won't let me apply. So long story short, with Windows provided drivers, all works fine, but when I try to install the latest proper AMD drivers, the whole multi monitors thing goes pear shaped.

Any ideas? I'm definitely using the right drivers, I have tried multiple versions. One post I found suggested going to Catalyst Control Center -> Video -> Color and changing the video colour to something other than the AMD preset - standard, but that didn't work. I've tried using AMD's complete uninstall utility to wipe all AMD video drivers, and start again, that didn't work. I'm lost.


Update:
I ran the windows updater, eventually it started updating a AMD microsystems something a rather...it was a graphics driver. Long story short it completely bricked the install. The screen, as with the updates I tried, went black, and there was nothing I could do. Restarting did nothing, it didn't even get to the UEFI boot option screen before the screen went black and all I got was a cursor. I tried using Windows repair, and it couldn't figure out what the problem was, so all thats left is for me to reformat the partition and try again.

Is this some sort of software thing to sort out? Or could my graphics card have some fundamental hardware incompatibility with Windows 8? I'll be honest, this is a huge pain in the ass...
 
Last edited:

My Computer

System One

  • OS
    Windows 7 Professional 64bit & Windows 8 Developer Preview
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel i7 2600k 3.4ghz
    Motherboard
    Gigabyte P-67A UD4-B3
    Memory
    Corsair 4gb XMS3 (2x2gb)
    Graphics Card(s)
    Asus EAH5450 Silent (512mb)
    Sound Card
    None
    Monitor(s) Displays
    AOC 23.6"
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 1TB - 64mb cache
    Western Digital Caviar Green 1TB - 32mb cache
    Seagate Barracuda 80Gb
    PSU
    Corsair HX-650W ATX
    Case
    Antec Three Hundred
    Cooling
    3x Antec 3speed fans
    Keyboard
    Logitech G110 gaming keyboard
    Mouse
    Logitech Internet Pro Black