What's new

Solved AMD/ATI Radeon HD 4650 driver

BoK

New Member
Hey.

I'm having trouble installing the driver for my Radeon HD 4650. Whenever I try to install a driver, vista or w7, it keeps saying that i have the propper driver, and fully updated. This leaves me with 'Microsoft Basic Display driver' as my only driver. Any help on resolving this? I have seen different solutions, but most don't work, and the rest i don't understand.

I also get the same message when I am installing drivers through DEvice Manager. What can I do?

Thanks.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

GMan

Banned

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

BoK

New Member
Hi,

Right click Basic Display in Device Manager, Update driver software, Browse My Computer, Let Me Pick, Have Disk, Browse...

Double click on .inf. Click ok then click next and it will install:

AMD Catalyst 12.4 WHQL 32-bit download from Guru3D.com

AMD Catalyst 12.4 WHQL 64-bit download from Guru3D.com


Reboot when done. When back to desktop, run setup.exe if you want CCC.
Allready tried this couple times with error, but when i tried again now for the gags, it kinda worked. got one step closer. Now it says it's not compatible with the current version of windows. tried it with both files included, still does not work.

EDIT: both files in the 32-bit of course, not both installation files.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

GMan

Banned
You're choosing the wrong .inf file. It should be top most one while in alphabetical order.

This one: C:\AMD\Support\12-4_vista_win7_32_dd_ccc\Packages\Drivers\Display\W7_INF\CL137813.inf
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

GMan

Banned
That really should work well ^^^^^

But if you really can't get it going, extract this over the file you have there now, then install with device manager as I've shown in first post. I made it compatible for 6.2 Windows:
 

Attachments

  • CL137813.zip
    17.4 KB · Views: 1,236

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

BoK

New Member
You're choosing the wrong .inf file. It should be top most one while in alphabetical order.

This one: C:\AMD\Support\12-4_vista_win7_32_dd_ccc\Packages\Drivers\Display\W7_INF\CL137813.inf

Tried that one. does not work. "The driver does not support this version of windows".
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

GMan

Banned
Hit Windows key + Pause/Break key to check.

You probably have 64 bit Windows installed, instead.

But if not, try my inf above.
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

BoK

New Member
That really should work well ^^^^^

But if you really can't get it going, extract this over the file you have there now, then install with device manager as I've shown in first post. I made it compatible for 6.2 Windows:
still got the same error as last file. :/

EDIT: checked, it's 32-bit.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

GMan

Banned
If you still need help after checking if you have 64 bit Windows or not, do this:

Type msinfo32 in the Start menu then press enter. File | save on the opened screen. Right click the saved file then choose Send To>>>Compressed (Zip) Folder.

Attach that zip to a new post. I'll have a look to see if your card is included in the .inf.

-------

If your card is an AGP card, install from here instead:

http://www.eightforums.com/graphic-cards/5921-ati-amd-catalyst-12-4-whql.html#post87780
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

BoK

New Member
Here you go. I believe it is not there though.

---

It's AGP, downloading now :)
 

Attachments

  • system-info.zip
    46.6 KB · Views: 728

My Computer

System One

  • OS
    Windows 8 Consumer Preview

GMan

Banned

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

GMan

Banned
lol I'll humbly accept that as the European way to say thanks...

You're very welcome. BTW, AMD just now made 12.4 available on their own site.

In the future, to update the driver, check the Hotfix AGP link here every month: ATI

(You have to click on Latest Catalyst Hotfixes.)
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

azoris79

New Member
Hello BoK,

May I kindly ask you the model of your motherboard and if your Ati is an AGP or PCI-e version.

Thanks in advance.
 

My Computer

System One

  • OS
    Windows XP Professional 32bit SP3
    CPU
    AMD Athlon II x3 455 3.3GHz
    Motherboard
    ASRock AM2NF3-VSTA
    Memory
    Kingston Hyper-X 2x2GB DDR2 1066MHz
    Graphics Card(s)
    Gigabyte HD4650 1GB AGP

rainsomnia

New Member
hey guys
how about the driver for 64 bit windows 8
iv got the same prob
 

My Computer

System One

  • OS
    window 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    vaio
    CPU
    Intel Core2Due 2.53 GHz
    Memory
    4GB
    Graphics Card(s)
    ATI Radeo 4650
    Browser
    IE 11

bobkn

New Member
Member
thanks... i have a ATI Mobility Radeon HD 4650 that does not work with win 8.1... think this will do the trick? i have a HP PAVILION dv7-2080ep Laptop... thanks

(snip)

I don't think so. Your notebook Mobility 4650 probably isn't AGP.

See here:

AMD graphics driver support for Windows® 8

(Basically, a Mobility 4650 is a DX10 card. Windows 8.1 wants DX11, but DX10 cards are supported.)

32 bit drivers:

Legacy

64 bit drivers:

Legacy

Haven't tried them myself. Good luck.
 

My Computer

System One

  • OS
    Window 8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    homebuilt
    CPU
    I7-3930k
    Motherboard
    Asus P9X79 Pro
    Memory
    16 GB Gskill DDR3-2133
    Graphics Card(s)
    eVGA GTX 680
    Sound Card
    Soundblaster Zx
    Monitor(s) Displays
    Asus PA246Q
    Screen Resolution
    1920X1200
    Hard Drives
    Corsair Force GT 120GB
    WD Cavair Black 1.5TB
    PSU
    PC Power & cooling Silencer 750
    Case
    Silverstone FT02B-W
    Cooling
    Noctua NH-D14 w/ PWM fans
    Keyboard
    cheap Logitech USB wired
    Mouse
    old 5 button Microsoft USB optical
    Internet Speed
    6Mb cable
Top