All the problems I'm facing with my Windows 8.1 system..

hosa

New Member
Messages
4
Some basic information first:

- The laptop is an old Sony Vaio VPCEG25FX

- Windows 8.1 version 6.3.9600 Build 9600



Good day to all of you guys lurking here, I thought it would be too exhausting making a new post for every single problem, so I think its better to discuss my challenges in one single post..
I just installed this Windows because it had came with Windows 7 and I had tried Windows 10 and I hated it so decided i would go with 8.1.. (that I downloaded from here)
The first thing I did after installation is enable the true Administrator account because this is how I roll, I don't think this matters but I thought I should mention anyways..
Then I researched and hand picked all the updates I wanted (leaving out all the monthly rollups and Servicing Stack updates), Im basically in favor of most updates except; those known to cause problems, those that have to do with Telemetry, those that have to do with upgrading to Windows 10.




Problems:

-
First problem I noticed that the latest driver for the Intel CPU (Intel 6 Series C200 10.1.17833.8098) did not actually get installed.. I ran the setup, it went through, I clicked finish, restarted, but Device Manager is indicating that I still have the original old version...The Same thing happens when I install Conexant SmartAudio HD drivers, except what I currently have is Microsoft's default drivers.

- There is an unknown device in DM (SNY5001) which I found out to be the Sony Firmware Extension Parser driver (I think this is why my Fn +F5 shortcut for screen brightness is not working), So I downloaded it and ran it and nothing happens, seriously, nothing happens..

- I'm not sure where to install Synaptics SMBus driver ( a .cab file) and device manager keeps refusing the .inf files when I try under some suspect devices in DM. (The default Microsoft drivers has taken care of it, but Im determined to install the manufacturer's own drivers..)

- Before I installed the updates I was able to boot in safe mode, now I can't.. So I disabled "Fast Start-up", but pressing F8 or F10 still does not do anything at boot.. To make matters worse, the "Assist" button on my laptop now behaves like a regular power button..

- ITunes absolutely refuses to install on Windows 8 so I downloaded IMazing, It uses the Apple drivers, and it says on the website it'll work on Windows 8.1,
but when it gets to installing the Apple drivers, it simply tells me installation failed before closing.. I have no idea how to transfer files from my Iphone now..

- There are a few failed security updates, but I reckon they depend on other ones that Ive hidden, I dont really care much about this, but thought I should mention..
......
Thats It


Googling did not help with any of these problems.. And I want to know what am I doing wrong :/
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Vaio
    CPU
    Core i5
Top