What's new

Album art is not showing up in Windows Explorer Help! plz

icehammer

New Member
it is my hope that someone with experience editing the registry will read this thread and offer some feedback.

I am trying to get embedded album art to show in W.Explorer for m4a Mpeg4 files. I am not talking about the art on the folder but the art in the files itself. Mp3 shows up no problem but m4a is being difficult.

I have browsed many threads on this issue and have not found an easy solution aside from using a shell extension.

The only possible solution I found in another thread and will post it here:

"I fixed the problem as it was mainly due to corrupted registry for some strange reason.i imported the .mp3 dile extension key from registry and opened it using notepad and replaced all .mp3 extension with .m4a and saved it as .m4a.reg and run it and had to do a system restart after that thumbnails again started showing up in windows explorer as normal.such as in the below screenshot"

My questions

I don't have a corrupted registry as I just did a fresh install only a week ago. so.
is it possible for me to edit the registery as this person suggests? how would I go about doing so exactly? I have no experience messing with registry files so if someone could offer some guidance it would be a real help.
 

My Computer

System One

  • OS
    win8

Der Snoober

New Member
VIP Member
Pro User
Hi icehammer, welcome to Eightforums!

As far as I understand your question, you want to be able to see the artwork of your m4a music files when browsing with Windows Explorer.

I myself have most of my music in m4a format and I can see all the albumart in Windows Explorer.

The ONLY thing I did was installing K-Lite Codec Pack. I don't use other codec packs, K-Lite worked for me.

Here is the downloadlink ==> Download K-Lite Codec Pack

Just remember, if you run a x64 Windows you MUST install the x64 codecpack AFTER you install the NORMAL codecpack. If you have other codec packs installed please uninstall them first!

Goodluck trying and hopefully enjoying the albumart in Windows Explorer :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64 Media Center Edition
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom Made
    CPU
    Intel Core i5 750
    Memory
    6 GB
    Graphics Card(s)
    AMD HD 7750
    Monitor(s) Displays
    Iiyama ProLite B2481HS-B1
    Screen Resolution
    1920x1080
    Hard Drives
    1x 120 GB SSD Samsung 830;
    1x 1.5 TB HDD Seagate;
    1x 2 TB HDD Western Digital;
    1x 3 TB HDD Seagate
    1x 80 GB SSD Vertex 2
    PSU
    Corsair CX 600
    Case
    Corsair Carbide 300R with Side Window
    Cooling
    Intel RTS2011 LC
    Keyboard
    DasKeyboard (blue switches)
    Mouse
    Wacom Baboo Tablet Pen & Touch
    Internet Speed
    50 Mbit FullDuplex Fiberglass
    Browser
    IE11
    Antivirus
    Windows Defender
    Other Info
    I also own the following Microsoft devices:
    * Surface Pro 2 128 GB
    * Windows Phone HTC 8X

Malickfan86

Member
Member
Hi Der Snoober,

I followed your advice. While this was what I was getting before:

Album-1.jpg Album-2.jpg Album-3.jpg
Art appears in folder view but not artist or album view.

After installing K-Lite Codec Pack Basic and x64, it seems that Windows is refreshing my library, one album at a time, but there is still no album art attached to what is coming up and it looks just like before.
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Soham

New Member
Hello there,

I faced the problem myself and figured out the solution myself. I think the problem your is solved by now. If it's not then I'll post with with pictures.:winkey:.
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit PC & 64bit Convertible
    Computer type
    PC/Desktop
    Memory
    4 GB
    Monitor(s) Displays
    LG Flatron, 17 inch
    Screen Resolution
    1024x768
    Hard Drives
    3 HDD's - 48, 256 & 128 GB. 1 External HDD, 1 TB. Convertible - 128GB SSD.
    Keyboard
    Logitech Wireless
    Mouse
    Logitech Wireless
    Internet Speed
    100kBps download, 10 kBps Upload
    Browser
    Chrome
    Antivirus
    Quick Heal 2014 on PC, McAfee on Convertibble

Malickfan86

Member
Member
Hi Soham,

No, the problem has not been solved yet. Since no one had a solution I assumed it was an overlooked bug in Windows 8 so I have resorted to using folder view.

If you have a solution that I have not tried, I would appreciate it if you were able to post it here.
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Soham

New Member
Hello there my friend,

You have set my eyes ablaze, I think I do have the solution.

First a few questions -

1. Do you use Mp3Tag to set album arts?
Answer - If Yes the try other programs, just google mp3 (in your case m4a) tag editor.

2. If the problem still persist open the folder where you keep your files

a. Press Alt+Enter after selecting the file, properties tab should open up.
b. Go to details blank out the year section and Refill it.
c. Click OK and Apply.

details-tab-mp3.jpeg


That ought to do it.

If the problem still persists I have a more complex solution to it which you may want to avoid.

Regards
SBJ
 
Last edited:

My Computer

System One

  • OS
    Windows 8 Pro 32bit PC & 64bit Convertible
    Computer type
    PC/Desktop
    Memory
    4 GB
    Monitor(s) Displays
    LG Flatron, 17 inch
    Screen Resolution
    1024x768
    Hard Drives
    3 HDD's - 48, 256 & 128 GB. 1 External HDD, 1 TB. Convertible - 128GB SSD.
    Keyboard
    Logitech Wireless
    Mouse
    Logitech Wireless
    Internet Speed
    100kBps download, 10 kBps Upload
    Browser
    Chrome
    Antivirus
    Quick Heal 2014 on PC, McAfee on Convertibble

Soham

New Member
Background Story

I faced the same problem 7 months ago in Windows 7 but couldn't figure it out back then and forgot about it after installing Windows 8.

Cut to 3 weeks ago,

My Music collection is Divided into two parts in 2 respective folders-

  1. English Songs
  2. Hindi Songs (Our country's film industry called Bollywood's OST, soundtracks, search Wikipedia for filmi.

One day after returning home from school found that these two folders were deleted. Got Hindi Songs from Recycle bin and used Recuva (brilliant software) to recover the rest.

Cut to 2 weeks ago,
While searching for a song found that its artists name was changed to Dilip Kumar Roy Thats when I realised someone hacked into my system using some rootkit. Scanned for viruses with MBAM, Kaspersky TDSKiller found none. Thought that I was away from harms way.

Cut to Today,
While I was surfing the net in the morning, my mouse became erratic, screen blanked. I Immediately understood the cause and pulled the network plug out. As I knew hacker was jealous of my music collection so I checked it and found that all the album arts were going out, one by one and I watched it helplessly. I slogged for four hours without blinking my eyes and came up with the complex method that I talked about earlier.

As everyone knows rootkits get entangled with the kernel itself thereby Hackers can corrupt the system, registry etc. In one-word wreak-havoc. So I am formatting my 3 HDD's right now as I'm writing this post. Afterwards do a clean install of the OS.

Regards
SBJ
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit PC & 64bit Convertible
    Computer type
    PC/Desktop
    Memory
    4 GB
    Monitor(s) Displays
    LG Flatron, 17 inch
    Screen Resolution
    1024x768
    Hard Drives
    3 HDD's - 48, 256 & 128 GB. 1 External HDD, 1 TB. Convertible - 128GB SSD.
    Keyboard
    Logitech Wireless
    Mouse
    Logitech Wireless
    Internet Speed
    100kBps download, 10 kBps Upload
    Browser
    Chrome
    Antivirus
    Quick Heal 2014 on PC, McAfee on Convertibble

Malickfan86

Member
Member
Thanks for trying to help. I tried MP3 Tag and found that some of my collection has assigned album art and some does not. However none of it appears when I arrange my music library by album. It seems our issues are unrelated.
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Wullail

Active Member
Pro User
it may be a corrupted registry entry under HKEY_CLASSES_ROOT for m4a.


you could try exporting your M4A registry key from there as a backup , removing it from the registry then letting windows re-create it by clicking on any of your M4A files to see if that works , at the very least you will have the old values in the .reg file incase it doesn't help.

 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Soham

New Member
I agree with Wullail, it may be a case of corrupted registry.

Now coming back, first of all our cases are similar. One question - Do you use a pirated copy of Windows and use KMS server or something like that since these remove WAT and in course corrupt registries.
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit PC & 64bit Convertible
    Computer type
    PC/Desktop
    Memory
    4 GB
    Monitor(s) Displays
    LG Flatron, 17 inch
    Screen Resolution
    1024x768
    Hard Drives
    3 HDD's - 48, 256 & 128 GB. 1 External HDD, 1 TB. Convertible - 128GB SSD.
    Keyboard
    Logitech Wireless
    Mouse
    Logitech Wireless
    Internet Speed
    100kBps download, 10 kBps Upload
    Browser
    Chrome
    Antivirus
    Quick Heal 2014 on PC, McAfee on Convertibble

Malickfan86

Member
Member
No, the registry hack made no difference, though I did it for MP3s since that was my problem. The files appear exactly the same, without a thumbnail. I guess I'll continue to use folder arrangement. I don't really mind it, I just prefer the artist arrangement. I'm fairly confident now that this was an overlooked bug in Windows 8.
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Malickfan86

Member
Member

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Malickfan86

Member
Member
I can go through my 100GB music collection and add missing artwork with Mp3tag (which is not a very user-friendly program, by the way), but even if I do, it's probably not going to add them back to Windows Explorer. I just tested it on one album: I replaced the artwork that was already there with artwork from Amazon. Then I applied it, discarded the old cover, and refreshed Windows Explorer. Of course it made no difference.

What else can I try?
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

Malickfan86

Member
Member
I played around with Mp3tag (meaning I did nothing significant), opened WMP, refreshed my library a few times, changed the arrangement to artist, to discover that 10 of my 981 albums now had art, so I went to an album without art, clicked properties, changed the default program to Windows Media Player, and watched in amazement as all of my art for all of my albums began to appear. This problem is solved. Thanks for your help!
 

My Computer

System One

  • OS
    Windows 8.1 Pro Pack x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP m6-1158ca
    CPU
    Intel i7-3632QM
    Motherboard
    HP 18A5
    Memory
    2 x 4096 DDR3-SDRAM
    Graphics Card(s)
    Intel HD Graphics 4000 / Radeon HD 7670M
    Sound Card
    IDT High Definition Audio
    Monitor(s) Displays
    15.6-inch HD BrightView LED-backlit display
    Screen Resolution
    1366 x 768
    Hard Drives
    Internal: Hitachi 1TB 5400RPM hard drive with HP ProtectSmart

    External: WD Passport 1TB with USB 3.0 / Seagate Barracuda 1TB 5400RPM with ULTRA Enclosure / Seagate Momentus 320GB 5400RPM with Sabrent Enclosure
    Cooling
    Cooler Master NotePal X-Slim Ultra-Slim Laptop Cooling Pad with 160mm Fan
    Mouse
    Logitech M560
    Internet Speed
    DSL 25/10
    Browser
    Mozilla Firefox 33.0.2
    Antivirus
    Windows Defender / Malwarebytes Anti-Malware

dwsiddall

New Member
I like Soham's solution....but my problem is that when I open the Details Tab....the fields are not editable. I click and nothing happens.

Anyone know why Windows is not allowing me to edit these fields?
 

My Computer

System One

  • OS
    Windows 8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top