What's new

Solved 8.1 change nework profile from public to private

AmpedPotato

New Member
Hello,

I am trying to change my wireless network profile from public to private, but cannot for the life of me figure out how...

http://www.eightforums.com/tutorials/9837-network-location-set-private-public-windows-8-a.html

^^ Those instructions no longer work on 8.1, and when I go into PC Settings > Network > Tap my network I see no options to enable sharing. I don't have Pro on this particular tablet so I have no access to gpedit.msc nor secpol.msc. What the hell do I have to do to change it? Other than this one ridiculous fault, I think 8.1 is far better than 8 (so far anyway.)
 

My Computer

System One

  • OS
    8.1

Brink

Administrator
Administrator
mvp

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

AmpedPotato

New Member
Thanks for the update. I noticed you said the option won't be available on Ethernet connections but on my tablet it's not available on my WiFi connection either. It's stuck on Public :( .

I was thinking I need to make 8.1 forget my WiFi network and I need to set it up again but yet again it seems impossible to make 8.1 forget a network...

BTW I just upgraded from 8 to 8.1 yesterday
 

My Computer

System One

  • OS
    8.1

chev65

Closed
Thanks for the update. I noticed you said the option won't be available on Ethernet connections but on my tablet it's not available on my WiFi connection either. It's stuck on Public :( .

I was thinking I need to make 8.1 forget my WiFi network and I need to set it up again but yet again it seems impossible to make 8.1 forget a network...

BTW I just upgraded from 8 to 8.1 yesterday

Perhaps this brief tutorial which addresses the problem may help, you aren't alone in your complaints here. :sarc:
How to change a network from public to private in Windows 8.1 « Tim Anderson's ITWriting

Read about the update: further down the page to access the charms bar, Settings>Change PC Settings>Network, for this rather than having to make changes in the registry. He made a mistake there as have others.

From what I can tell you just go to network section through the charms bar, Settings>Change PC Settings>Network, then click on the network you need to change "first picture".

Then just turn off or on the sharing option switch at the top of the page which should change from Public to Private network "second picture". This seems to be a completely different procedure compared to Windows 8.

How to change a network from public to private in Windows 8.1 « Tim Anderson's ITWriting
 

Attachments

  • Screenshot (2).png
    Screenshot (2).png
    10.9 KB · Views: 629
  • Screenshot (3).png
    Screenshot (3).png
    17.8 KB · Views: 612
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

AmpedPotato

New Member
Perhaps this brief tutorial which addresses the problem may help, you aren't alone in your complaints here. :sarc:

Read about the update: further down the page to access the charms bar, Settings>Change PC Settings>Network, for this rather than having to make changes in the registry.

From what I can tell you just go to network section through the charms bar then click on the network you need to change "first picture".

Then just turn off or on the sharing option switch at the top of the page which should change from Public to Private network "second picture". This seems to be a completely different procedure compared to Windows 8.

How to change a network from public to private in Windows 8.1 « Tim Anderson's ITWriting

Thank you. My problem is just like in the article you linked to. I will try the registry fix and report back. Why must Microsoft screw up one of the few things that actually worked "right" in Windows 8? Or better yet why didn't they just leave the Network and Sharing Center alone since it worked just fine in 7? They could've just added the ability to change it in the Modern UI as well as Network and Sharing Center...
 

My Computer

System One

  • OS
    8.1

chev65

Closed
Perhaps this brief tutorial which addresses the problem may help, you aren't alone in your complaints here. :sarc:

Read about the update: further down the page to access the charms bar, Settings>Change PC Settings>Network, for this rather than having to make changes in the registry.

From what I can tell you just go to network section through the charms bar then click on the network you need to change "first picture".

Then just turn off or on the sharing option switch at the top of the page which should change from Public to Private network "second picture". This seems to be a completely different procedure compared to Windows 8.

How to change a network from public to private in Windows 8.1 « Tim Anderson's ITWriting

Thank you. My problem is just like in the article you linked to. I will try the registry fix and report back. Why must Microsoft screw up one of the few things that actually worked "right" in Windows 8? Or better yet why didn't they just leave the Network and Sharing Center alone since it worked just fine in 7? They could've just added the ability to change it in the Modern UI as well as Network and Sharing Center...

If you read the Update part of that link he mentioned that it's meant to be done through the charms bar as I described with the pictures etc. although it looks like Shawn already posted a tutorial for this.

I assume it's not working for some reason so the registry may work although this shouldn't have to be done.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

BFG

Betta Fish
Member
ugh Microsoft dumbed downed the wireless settings again. Can't even right click on the network any more to change the settings. Thanks for this thread though to see where it got buried to.
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    HP DV7-4269WM
    CPU
    i5-480M
    Memory
    4GB
    Graphics Card(s)
    ATI Mobility Radeon HD 6370
    Sound Card
    Beats Audio
    Monitor(s) Displays
    17.3"
    Screen Resolution
    1600x900
    Hard Drives
    750GB (5400RPM)
    Internet Speed
    1500

chev65

Closed
ugh Microsoft dumbed downed the wireless settings again. Can't even right click on the network any more to change the settings. Thanks for this thread though to see where it got buried to.

Yes I don't know why they keep changing it, I was a fan of "Manage Wireless Connections" as it was in Windows 7, now they changed it again but apparently it's problematic for some people, not sure why yet but maybe Amped Potato will enlighten us with the registry adjustment although that shouldn't be required, it could be a bug or something with Windows not being able to "forget" a network.

This setting works fine for me so I'm not sure why this setting can't be changed through the charms bar.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

AmpedPotato

New Member
Yes I don't know why they keep changing it, I was a fan of "Manage Wireless Connections" as it was in Windows 7, now they changed it again but apparently it's problematic for some people, not sure why yet but maybe Amped Potato will enlighten us with the registry adjustment although that shouldn't be required, it could be a bug or something with Windows not being able to "forget" a network.

This setting works fine for me so I'm not sure why this setting can't be changed through the charms bar.

It's definitely broken on my end but next chance I get I'll report whether the registry fix works or not.
 

My Computer

System One

  • OS
    8.1

Brink

Administrator
Administrator
mvp

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

BFG

Betta Fish
Member
Looks there is also no longer an easy ability to forget this network option as well. They would've been an easy way to disconnect and then pick whether to allow sharing on re-connect. Now it seems you will have to delete networks via netsh and/or registry xml files
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    HP DV7-4269WM
    CPU
    i5-480M
    Memory
    4GB
    Graphics Card(s)
    ATI Mobility Radeon HD 6370
    Sound Card
    Beats Audio
    Monitor(s) Displays
    17.3"
    Screen Resolution
    1600x900
    Hard Drives
    750GB (5400RPM)
    Internet Speed
    1500

Brink

Administrator
Administrator
mvp
Last edited:

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top