• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved 2nd internal data HDD shows with Optical Drive icon


antares

New Member
Member
Posts
241
#1
Hi, in "This PC" my 2nd internal data HDD shows an Optical Drive icon instead of the usual HDD icon. How can I fix this? Thanks
 

My Computer

System One

  • OS
    Windows 8.1x64 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    self made
    CPU
    Intel Core i7 6700K
    Motherboard
    Asus Z170-A
    Memory
    Corsair Vengeance LPX 32GB (4 x 8GB) DDR4 2400MHz
    Graphics Card(s)
    Intel HD Graphics 530
    Sound Card
    Onboard Realtek HD
    Monitor(s) Displays
    LG 23EA53 23" LED IPS
    Screen Resolution
    1920x1080 32bit
    Hard Drives
    Samsung 256GB 830 Series SSD main+HGST 4TB 7200RPM as 2nd internal
    PSU
    Thermaltake Toughpower Grand 850W TPG-850M
    Case
    Corsair Obsidian 650DW-1 Midtower
    Cooling
    Noctua NH-D14
    Keyboard
    Logitech K800
    Mouse
    Logitech M510
    Antivirus
    NIS2014

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#2
Set your folder options to "show hidden files" & Uncheck "Hide protected operating system files" then look in the root of the drive. Is there an autorun.inf file there ? If so, delete it.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

antares

New Member
Member
Posts
241
#3
Hi topgun, no, there's no "autorun.inf" file in the root directory of my 2nd drive
 

My Computer

System One

  • OS
    Windows 8.1x64 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    self made
    CPU
    Intel Core i7 6700K
    Motherboard
    Asus Z170-A
    Memory
    Corsair Vengeance LPX 32GB (4 x 8GB) DDR4 2400MHz
    Graphics Card(s)
    Intel HD Graphics 530
    Sound Card
    Onboard Realtek HD
    Monitor(s) Displays
    LG 23EA53 23" LED IPS
    Screen Resolution
    1920x1080 32bit
    Hard Drives
    Samsung 256GB 830 Series SSD main+HGST 4TB 7200RPM as 2nd internal
    PSU
    Thermaltake Toughpower Grand 850W TPG-850M
    Case
    Corsair Obsidian 650DW-1 Midtower
    Cooling
    Noctua NH-D14
    Keyboard
    Logitech K800
    Mouse
    Logitech M510
    Antivirus
    NIS2014

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
OK, you might want to try this:
1. Win+X -> regedit and go to the key below:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer
2. Under this key, you'll see a key "DriveIcons". Delete it and log off or restart your Windows.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

antares

New Member
Member
Posts
241
#5
I went to that registry key and under "Drive Icons" the "E" drive was listed (the 2nd internal drive) and the Icon value was set to PowerISO (a 3rd party tool for mounting images, etc). I deleted that subkey and there was no need to log off or restart, the E drive icon was restored to the Windows default for a HDD. Thanks!
 

My Computer

System One

  • OS
    Windows 8.1x64 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    self made
    CPU
    Intel Core i7 6700K
    Motherboard
    Asus Z170-A
    Memory
    Corsair Vengeance LPX 32GB (4 x 8GB) DDR4 2400MHz
    Graphics Card(s)
    Intel HD Graphics 530
    Sound Card
    Onboard Realtek HD
    Monitor(s) Displays
    LG 23EA53 23" LED IPS
    Screen Resolution
    1920x1080 32bit
    Hard Drives
    Samsung 256GB 830 Series SSD main+HGST 4TB 7200RPM as 2nd internal
    PSU
    Thermaltake Toughpower Grand 850W TPG-850M
    Case
    Corsair Obsidian 650DW-1 Midtower
    Cooling
    Noctua NH-D14
    Keyboard
    Logitech K800
    Mouse
    Logitech M510
    Antivirus
    NIS2014

Users Who Are Viewing This Thread (Users: 0, Guests: 1)