Windows 8 and 8.1 Forums


Win8.1 firewall: the system cannot find the file specified

  1. #1


    Posts : 3
    Windows 8.1

    Win8.1 firewall: the system cannot find the file specified


    I'm having trouble with a computer at work; I believe it was infected with malware at some point as the registry entries for mpssvc (the windows firewall service) and wscsvc (windows security centre service) had been removed (ie. in HKLM > SYSTEM > CCS > services). I've reinstated those registry entries from a working Win8.1 machine (both the 64-bit version). Windows Security Centre is up and running again but the Windows Firewall service fails to start, error code 2, "the system cannot find the file specified". Other services like mpsdrv and bfe are fine. Windows Update is also working.

    After multiple reboots, the registry entries for the mpssvc service remain as expected (the main thing I've been checking is the file name run by the service). So far I've tried:

    dism /online /cleanup-image /restorehealth
    sfc /scannow
    chkdsk /f /v /r (the disk has some slightly iffy SMART readings, some successfully reallocated sectors)
    TDSSkiller (it was mentioned when I was googling for the problem in a similar-ish context)

    All of these ended on a positive note. I might try running the dism command again as I think it said it found some things wrong and corrected them. Chkdsk's results only fixed minor file system issues, no further bad sectors found or read failures. TDSSkiller didn't find anything.

    I'm running a scan with malwarebytes, but it's already past the file scanning, rootkit check, and registry scanning stages so I doubt that's going to turn up anything relevant. The computer is running Windows Defender for antivirus (always has done).

    The machine isn't currently showing any active signs of infection (eg. dodgy processes running, pop-ups, other odd things happening during browsing), just this. I wonder whether Defender found an infection at some point after the fact and dealt with it already, but the damage was already done.

      My System SpecsSystem Spec

  2. #2


    Posts : 3
    Windows 8.1


    A second crack at monitoring system activity (Process Monitor, sysinternals) while attempting to start the service did the trick: There was a missing registry key in MpsSvc > Parameters: The key name was 'AppCs' (once I created it, the error code when starting the service changed to error 5, which is access denied), and it requires 'NT SERVICE\MpsSvc' to have privs to it (I gave it full privs).
      My System SpecsSystem Spec

Win8.1 firewall: the system cannot find the file specified
Related Threads
I had a problem with my windows 8.1 password. I forgot it BUT I solved the issue by following the instructions in this tutorial. I have reached step number 32 which comes after the changes I made for Utilman.exe and cmd.exe. I got this message "The system cannot find the file specified" when I was...
I had to uninstall McAfee control over Win8.1 firewall, because the Apple Mobile Device Support program kept rolling back !!
New laptop running win8. Can't export files to external drives, dropbox, anywhere off the computer unless I disable the firewall. What to do? Getting desperate!
Hi, anyone noticed how crappy the smart search has become in the change to 8.1? Before, I could smartsearch for "audio devices" or "device manager", and I would get a result that brought me straight to the requested system control panel. Now, those results at lower levels of the system controls...
I tried using a batch file to run ccleaner at log on. But it always takes forever when it cleans Firefox. So I made a batch file to just delete the Firefox temp folder. And I unchecked Firefox in ccleaner so ccleaner ignores Firefox. Here's the batch file. RMDIR 5bngz3ew.default /S /Q I put...
(Or how to remove Write Protection from Pendrive). Pendrive doesn't have any write protection lock key on it.
I run old app on Win8 and it prompt me to Download the .Net Framework 3.5. I press Download and intel this feature and work fine. I have another PC and i want copy the .Net Framework 3.5 setup file to install the .Net Framework 3.5. on it.(another PC and more PCs) But Where can i find the .Net...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook