Windows 8 and 8.1 Forums


Certificate error: navigation blocked.

  1. #1

    Certificate error: navigation blocked.


    Hello, I recently performed the upgrade to windows 10 and found it hopeless. I could not get internet connectivity and many programs would not work. I tried some troubleshooting but gave up and reverted to 8.1. That worked well except that IE 11 has an error that I cannot resolve. All sites that I try to access give me ; Certificate error: Navigation blocked, even the Microsoft site!
    I have tried each of the security settings under Internet options but no joy, system time is correct.
    I am currently using Firefox and there are no problems with it.
    Anyone experienced this, any suggestions?
    Alex.

      My System SpecsSystem Spec

  2. #2


    Resolved, updated PC (Lenovo helix) with latest drivers, reinstalled win10 and all is well.
      My System SpecsSystem Spec

Certificate error: navigation blocked.
Related Threads
Problems with Certificate in System Security
Once again I am getting Invalid Security Certificate. How do w validate? And Twitter doesn't download right in one browser, when I use another, I cannot post. Whats the deal?
Certificate ERROR in General Support
I keep getting a certificate error at facebook. I am using 8.1. Looked at the methods here and found no solution, sorry to say. Can anyone give me step by step directions to get rid of this. No windows popup. It just say Certificate Error. The screen is grey and a character person with a square...
Hi everyone, on every email message I am getting a Security Certificate pop-up window. It asks me if I wish to proceed - yes or no or do I wish to see the certificate. It's driving me nuts - this was never there when I started using Windows Live Mail and I would really like to get rid of it - can...
Hi, After recent update, on our webpage there is No select certificate pop-up (windows security) for user after recent windows update, resulting HTTP 403 Forbidden Error. This changes effect lots of our IE user when they try to access our webpage, but some are not effected by this...
I have several Windows 7 and 8.1 systems that can access the "Acronis Forum" web site without any problems. For some reason one system running W8.1 gives me the Security Certificate error when I try to access it. I can eventually log on but as soon as I try to enter a post it kicks me off again. ...
Driver Certificate ? in Drivers & Hardware
I tried to figure out how to turn off driver signing in 8. I had to because my wireless adapter's driver literally gets rejected by the OS. I dug around in the 7 forum and found this : bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS bcdedit -set TESTSIGNING ON The power shell didn't give...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook