ok so the story goes like this.

the AVG security 2014 had been asking to install an update for several days and I just ignored it.
when I finally decided to do it.... the pc restarted then when to windows logon screen but it didn't let me sign in, it said that the user was not found.... or something like that.

Then I rebooted but now it didn't even reached the logon screen, I kept getting this error 0xC0000034...
for like two days I was searching throught different forums about fixes of this. I took a while getting my hands on a repair media and recovery media but now I got both... then I started trying to fix it through cmd

obviously auto-repair never worked

a tried the bootrec routine and it didn't work
then a tried to rename bcd to bcd.old and replace it....

after a couple of shenanigans like these I was able to go back to the logon file only to find out that my user was still inoperable so I went to activate the administrator account through cmd and regedit, then to try to fix my user through regedit and then there it was... but empty

then through cmd I've been looking for all my files but with no luck.

maybe they're two different problems but my money is on the damn AVG update... I dunno what it did.

has someone ran into this issue before?

should I use something like recuva to look for my files... maybe is everything is recover the bcd issue is automatically fixed.

I need help with this since I am no IT guy or anything like that... just an average person that can follow instructions