Windows 8 and 8.1 Forums

Missing or corrupted Audio drivers after an OS update

  1. #1

    Posts : 6
    Win 8.1 64 bit

    Missing or corrupted Audio drivers after an OS update


    So my latest windows trauma happened right after the last windows 8.1 64 bit based update. Although I have to admit there may be some other software installations that may have something to do with all this...

    After the installation and reboot none of the drivers in 'sound, video and game controllers' were working! They were all there but they all had a yellow '?' sitting on them...
    Click image for larger version

    (I had more drivers than what the picture said. Two of my monitors had audio so they had drivers, plus I had a couple of virtual Midi cable programs which carry audio drivers.) Plus Realtek HD Audio driver...

    For my first attempt to trouble shooting sound problem suggested that I might be able to fix my problem by reinstalling the driver for High Definition Audio Devices.. (I presumed that this must be Realtec that came with my ASUS P9X79 WS)

    So I select 'apply this fix' knowing that this can't be that easy...
    The result was, HD Audio Device had a driver problem: 'NOT FIXED!'

    A further analyzing the device status came up with this:
    "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

    So I removed the Acer, Phillips and Virtual cable drivers and I uninstalled and reinstalled these drivers: the Realtek and RME.
    RME had no problem through out the installing process but had no effect on the problem what so ever...
    Realtek on the other hand came up with a new error code:
    Realtek HD driver could not be Installed !! Error Code: 0x000000FF
    Click image for larger version
    (Realtek HD Audio Driver Setup

    So now I have no audio driver listed in my Sound Tab
    I tried few stuff from googling like the error codes and no audio problems related stuff, but no dice!
    Click image for larger version

    Should I kill myself now or a little later?

    PS Google was NOT my friend what so ever... That's why I am here...

    Thank you
    Last edited by cemster; 27 Aug 2016 at 23:42.

      My System SpecsSystem Spec

  2. #2

    I have a recording studio (Sonar Platinum and an MOTU 896mk3 Hybrid).

    First thing I would do is reinstall the Intel Motherboard Chipset drivers. One of the things the chipset drivers do is identify all the devices on the motherboard. If the chipset drivers were corrupt devices such as the Realtek sound could not be installed.

    You should also disconnect the RME and any other sound device while you focus on getting the Realtek working.
      My System SpecsSystem Spec

  3. #3

    Posts : 6
    Win 8.1 64 bit

    Thanks for the hand fireberd...
    I have done all the preliminary work as a lay man can do. That involved pretty much reinstalling everything except bios & OS, which is updated to their neck... I suppose....
    And RME was off at all times.

    The failed Realtek reinstall was part of that adventure... Incidentally I forgot to mention that Realtek HD Audio Driver despite the failed message, appear to be installed in Programs and registry but after showing up Device Manager it disappears later on!

    I believe the problem is in ... Internal High definition Audio Bus which is a Microsoft driver... Hence the Code 19 error...
    That's why I can't install Realtek properly, and that's why all the other drivers stopped working! But I don't know how to get around those Windows Internal High definition Audio Bus drivers..... I did the 'Uninstall' and then 'scan for hardware changes' bit in Device Manager...
    But it doesn't go away! In Device Manager/ Details tab The Problem code is '00000013' But none of the remedies I found on web helped...
      My System SpecsSystem Spec

  4. #4

    The Microsoft/Windows "HIgh Definiton Audio" drivers install on compatible sound when the hardware drivers (e.g. Realtek) are not installed. Normally, when the correct driver is installed it takes the place of the High Definition drivers.

    Have you tried the High Definition drivers direct from Realtek? If not give that a shot. One of the causes of a 13 error is "type mismatch" which could be the driver. Download the R.279 High Definiton driver.

    When you uninstall, you need to restart the PC, not just scan for hardware changes, as the same problem can arise.
      My System SpecsSystem Spec

  5. #5

    Posts : 6
    Win 8.1 64 bit

    But I always had them in the Driver manager list together... Or at least I thought I always had tej together! Maybe they start to show up together after the problem arises I am not sure...
    I am in the process of doing just that. I was backed up before because the realtek site warns you about:

    "Audio drivers available for download from the Realtek website are general drivers for our audio ICs, and may not offer the customization made by your system/motherboard manufacturer. To be sure you obtain the full features/customization provided in your original audio product, please download the latest drivers from your system/motherboard manufacturer's website."

    But I am going to try to install those. And of course I always restart after an install or uninstall process..

    Thank you by the way..
      My System SpecsSystem Spec

  6. #6

    The drivers from Realtek are OK. I have them installed in my PC. That's just a general statement to cover themselves if it doesn't work.
    There are open links in this forum, the Win 7 forum and the Win 10 forum for these Realtek drivers.
      My System SpecsSystem Spec

  7. #7

    Posts : 6
    Win 8.1 64 bit

    I did uninstall reboot install Realtek (from the Realtek site) The different outcome was that the Realtek installed without an error like it did with ASUS version... But there is still no audio. Another difference is that
    All the other Microsoft items disappeared from the Device Manager Sound and game controllers... Unlike the first picture above, this one has two drivers. Realtek High Definition Audio and High definition Audio Device... Which is suppose to disappear after a third party Audio driver installed. In this case Realtek.

    Another difference was the version of the drivers.
    From ASUS the version reads: Realtek High Definition Audio Driver Setup (3.76) x64 Edition
    From Realtek site it reads: Realtek High Definition Audio Driver Setup (4.27) R2.79

    Although I manage the install Realtek without am error,

    I'm still getting the same code 19 error pointing Internal HD Audio Device...
    Last edited by cemster; 29 Aug 2016 at 11:12.
      My System SpecsSystem Spec

  8. #8

    I wonder if the Code 19 is for HDMI Audio?
    Also, make sure "Speakers" (Realtek) are set as default audio playback device (when the RME is not connected).
      My System SpecsSystem Spec

  9. #9

    Posts : 6
    Win 8.1 64 bit

    Code 19 comes when When I double click on both drivers. I get 'Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)'

    When you right click on speaker icon and select Troubleshoot Sound Problems and then when it says: "There is a problem with the driver 'High Definition Audio Device'. Reinstalling Audio Device might fix this problem." And of course it doesn't!

    and this is the picture of my Audio Playback Devices...
    Click image for larger version
    Nothing to select!
      My System SpecsSystem Spec

  10. #10

    If you feel up to it, there are several suggestions in this thread from the Microsoft forum. It involves the Registry and upper and/or lower filters for the Realtek.

    Bottom line, unfortunately it may take a complete new ("clean") install to get everything working.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Missing or corrupted Audio drivers after an OS update
Related Threads
Solved Audio Drivers Messed up!! in Sound & Audio
Hi, Unintentionally, the Realtek Audio driver was uninstalled -therefore, no sound. :sarc: When I did a search for the appropriate driver and finally was installin this one - An error pops up :mad:. I've...
Hi, I have Win 8.1 installed on my PC. I wan't to format the drive and do a clean install of Win 8.1 again. I've created a Win 8.1 Pro bootable USB using Rufus as described on this site. I am doing an install in UEFI mode as I wan't to use my SSD native encryption as it is Microsoft eDrive...
Basically, whenever I try to launch FFXIV DX11 benchmark I'm getting that error..sfc /scannow confirms that something is wrong with that dll but it says "Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log...
G/ Day’ I have Windows 8.1 on a Dell Desktop Inspiron 660 I wanted to know how I Can delete all My Profile Folders and Recreate a new one or Keep the correct Profile Folder and Delete the Rest at the Moment they are; DazzzlingDasha Local Admin > Local // DazzlingDasha Local Admin > ...
Solved BSOD possibly due to corrupted memory drivers in BSOD Crashes and Debugging
I asked my question on micorsoft community but they answered a few times then simply stopped answering, all I was told is that it maybe possibly due to corrupted memory drivers. I either get the BSOD with the DPC_Watchdog_Violation error or my laptop just freezes and a constant buzzing sound...
So, i as using windows 8 Rtm. I had installed the windows 7 drivers for my Sony Vaio VGN-AR730e, which has an Nvidia GeForce 8400m Gt graphics card. Everything was fine for a few days, and then it shut off. When I turned it back on, the opening splash screen before windows (i'm aware bios isn't...
Can't install audio drivers in Drivers & Hardware
My computer came with a disk with audio drivers for it, but when I try to install them, it saids that i need to be on win 7. I mean I can hear sound just fine, but without the drivers I can't use my mic. Any help would be nice, and thanks in advance.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook