I need some help, a few hours ago (about 4 from time of this post), my sound from my HyperX Cloud 2's stopped working.I got up to turn the light off, when I was doing that it cut. I started fiddling about the USB cable to try and make it work, but nothing changed. I started to switch to my front usb ports and still nothing unless held. I tried with my Trittons, apple earbuds, and speakers. All of which have a deep deep bass and barely any high notes. I tried just using my jack and skip the USB adapter, and it worked, only when sitting in a specific location. I am not sure if it is a case problem or motherboard problem or USB adapter or headphone problem in general. I am gearing towards the case since none of the audio outputs worked correctly but I would gladly appreciate if someone could help me out.
Also, whenever I plug in the USB to my headphones I get the message at the bottom right saying USB was unable to be recognized. I have had this build for a bit over a year now and I am trying to contact HyperX about the headphones, If it isn't the headphones then I have a case in my mind that I would switch to.