Windows 8 and 8.1 Forums


HDMI No Audio Without Restarting

  1. #1


    Posts : 4
    Windows 8.1 64-bit

    HDMI No Audio Without Restarting


    Hello. I have an ASUS X750JB laptop running Windows 8.1. When using a HDMI cable to connect to my television, the display works but there is no audio. The television doesn't show up in the playback devices.

    Restarting my laptop with the television connected fixes the issue, but I have to do it every single time I plug the HDMI cable in which is a huge pain. I've tried to update the Intel(R) Display Audio and Realtek High Definition Audio drivers as well as uninstalling them and restarting the computer so that they reinstall. Zero changes.

    I then found this blog post that suggests using devcon.exe to restart the audio and display drivers through command prompt. I did this and then the television showed up in the playback device list, but still no sound. I then tried changing the sampling rate in the properties under the advanced tab and it worked! Kind of! All of the sound that came through sounded odd, almost like it was sped up or the frequency had been shifted upwards. It was like this for all sampling rate except for two which had no sound at all. After restarting my computer I found that all rates worked just fine by the way.

    So that's where I am now. Still restarting my computer every time. Any help or suggestions would be very much appreciated.

      My System SpecsSystem Spec

  2. #2


    Marion
    Posts : 111
    Windows 8.1 Pro with Media Center


    If the television shows up in your devices, more than likely, there is no sound coming out from the TV due to the TV needs to be set as the default audio device.

    The HDMI doesn't use the Realtek. It is separate as it uses the Intel driver for HDMI sound. My buddy has a TV he occasionally connects to his computer and uses HDMI. His card is a GT 620 NVIDIA. When I plug it in, there is no sound from the TV, but when I go into the playback devices, I right click on the TV, click set as default, and boom, it works every time he plugs it in.

    Hope this helps
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    Windows 8.1 64-bit


    Quote Originally Posted by lmaneke View Post
    If the television shows up in your devices, more than likely, there is no sound coming out from the TV due to the TV needs to be set as the default audio device.
    Thanks for replying to this. :D

    The problem is that the television doesn't show up in the list of playback devices and therefore can't be set as the default device. It only shows up after restarting the computer and is even automatically set as the default playback device when I do. It also shows up in the device list after restarting the drivers with devcon.exe, but like I said that results in the sound being messed up for some reason.

    I figured that the Realtek had nothing to do with it. I was having an audio problem so I figured trying all the audio things might magically fix something.

    Any other ideas? Any and all help is appreciated.
      My System SpecsSystem Spec

HDMI No Audio Without Restarting
Related Threads
Basic Specs Brand New Toshiba Satellite C855 Win 8 64-bit 6 GB RAM Display Adapter: Intel(R) HD Graphics (2000) Driver: Intel 9.17.10.3040 Playback Devices
Hello, Basically, On my laptop, I run an HDMI cable to the TV. Using VLC Player I put a show on for my friends to watch. What I would like to do, is watch something else at the same time on my laptop and hear the sounds on my headphones that are plugged into the same laptop. I found one...
Hi there, I'd really appreciate if this could work, the details of my system are as follows: Dell XPS L502X Nvidia GT 525M I have downloaded the Realtek Drivers as mentioned here for the Windows 8 version, plug in the HDMI cable but still the output doesn't go to the TV but sound plays from...
Hi, I have Windows 8.1 x64 and the following: Radeon HD5450 Samsung TV connected via HDMI to graphics card AMD HDMI High Definition Audio Device Realtek HD audio I have a strange problem that has not always been there but just recently if I don't have any sounds for about 5 minutes the...
My friend connected an external monitor to his Sony laptop using an HDMI cable. The problem is that there is no audio from the external monitor speakers. The sound still comes out of the laptop speakers. When I look in Playback Devices, I see what appears to be the speakers as a device (can't...
Hi, before I state my problem I just want to clarify that this didn't occur before updating to windows 8.1. Before the update my sound would switch between the tv and the laptop speakers automatically when as I unplug and plug in my hdmi cable. Now, I put my laptop to sleep when not in use or when...
I just bought a new laptop and tried the HDMI, but there is no audio and the image is poor. It's an Asus X501A with Pentium 2020M Ivy Bridge and Intel HD Graphics. I tried changing the output resolution, to tweak the audio properties, etc. No success. Any idea?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook