Windows 8 and 8.1 Forums


My speakers only work when the headphones are plugged in

  1. #1

    My speakers only work when the headphones are plugged in


    Good morning.

    I am running Windows 8.1 with 8gb of ram, Time Warner internet at 50mbps (speed tested before I posted). 2gb video Nvidia card. Using on board sound (no extra sound card)

    Last night, I could only get sound on my speakers whenever I plugged in my headphones. Today, none of my videos will play (Netffix, YouTube, MP3's on Windows Media Player).

    When I check my sound settings , the headphones and speakers are constantly switching back and forth as the default device, even when the headphones are not plugged in.

    I updated Flash Player and ran virus scans from both of my anti virus programs (MalwareBytes and AVG 2015). I updated all of my drivers that I could (none needed updating).

    Any idea how I can fix this? I'm out of ideas.

    Thanks everyone!

      My System SpecsSystem Spec

  2. #2



    Trying to Sith things out
    Bamberg Germany
    Posts : 2,290
    Windows 10 Pro 64 bit


    Have you tried the Troubleshooter in Control Panel?
      My System SpecsSystem Spec

  3. #3


    Yes I did. It made my speakers default, but I still have the same problem with Nefflix, Youtube, etc.
      My System SpecsSystem Spec

  4. #4

    Update after I restarted


    Actually.

    After I ran the trouble shooter and it made my speakers default, it still would not work so I restarted my computer.

    After I restarted, my MP3 audio plays just fine and I no longer need to have my headphones plugged in to hear my speakers (thank you!). But my Netflix and my Youtube play incredibly choppy. Any other advice?
      My System SpecsSystem Spec

  5. #5



    Trying to Sith things out
    Bamberg Germany
    Posts : 2,290
    Windows 10 Pro 64 bit


    What media player are you using? Windows Media Player(WMP)? Or something else like Audacious, iTunes, VLC...etc. Maybe it's a codec problem and try a different player. Did this problem just start after an update, you could try uninstalling/rollback the update and see if the problem persist.
      My System SpecsSystem Spec

  6. #6


    I use Windows media player...but very rarely. I only used it today to test the sound when my Netflix went out. I use Chrome and Firefox. Netflix and YT run choppy on Chrome, but they now run perfectly on Firefox. So now it may be something Chrome related. I'll take a peek at my Chrome plug ins and version and see what's what. In the meantime, thanks so much for your help!
      My System SpecsSystem Spec

  7. #7



    Trying to Sith things out
    Bamberg Germany
    Posts : 2,290
    Windows 10 Pro 64 bit


    You're welcome. I hope you get the rest worked out. Also by the way welcome to EightForums
      My System SpecsSystem Spec

  8. #8


    Thanks
      My System SpecsSystem Spec

My speakers only work when the headphones are plugged in
Related Threads
Whenever i plug in my headphones, i hear a buzzing noise. its not the headphones problem, i tested them on other devices and there was no problem. I even changed speakers but i still have the prob, Please Help, ty. :(
The title pretty much says it all. I realize there are other threads out there similar to this, but their solutions either didn't work for me, or the problem wasn't quite the same. My issue is as follows: When I plug my headphones into my laptop (hp dv7t 6c000 quad) audio plays through both the...
Dear all, I've been facing an issue with my sound lately (potentially linked to the win 8.1 update - as seems to be the case of a lot of people); I'm unable to get my sound to work, and I'm getting the following error message: "No speakers or headphones are plugged in". I've been trying out a...
Hi friends, I am using Windows 8. I am facing an issue with my sound all on a sudden. The volume icon on the task bar has a red cross on it. When I hover on that it says 'No speakers or headphones plugged in' (attachment-1). When I click on the icon I get a screen like attachment-2 which...
Hi! Sorry if this topic already exist, but i think it is little different. I had this problem, i went to BIOS and enabled sound, but, when i turned on computer there was sound, but it was show as headphones, and speakers aren't plugged in. Actually is opposite, headphones aren't plugged in, but...
Windows is telling me my headphones are not plugged in BUT they ARE and I can use them with my wife's Windows 7 or my dual booted Linux Zorin 9 (Ubuntu 14.04) Both headphones and microphone do work in Linux so i know my sound card hardware does work and the headphones and microphone jack do work -...
I recently upgraded to windows 8 pro 32 bit. For a month there were no problems. But one sunday afternoon i was watching some movie on my laptop and suddenly the speakers stopped working. I restarted it, but to no avail. However my headphones still work, and so do external speakers work. I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook