Windows 8 and 8.1 Forums


New Headset, not detecting microphone.

  1. #1


    Posts : 10
    Windows 8

    New Headset, not detecting microphone.


    Hi, I recently bought a new headset due to one of the ears falling apart...

    My old one was USB with a 3.5mm cable and worked perfectly fine. The new one I got has no USB and uses the green and pink cables. I've plugged them in and it seemed as if they were working well but I realised they're not actually picking up the sound from the microphone, they're playing my computers sounds.

    I looked through other forums and found people saying that it may be a driver issue, so I updated and got the Realtek HD, which then showed the Stereo Mix in my devices. Basically what's happening is that Stereo Mix and Microphone are both playing volume at the same level and acting as if they're the same. I've tried disabling Stereo and keeping Mic but it still plays the computers sounds. I've tried vice-versa too. The "Speakers" device is also playing at the same level of volume.

    Click image for larger versionClick image for larger versionClick image for larger version

    And then obviously since it's doing that, it's playing my computer sounds through Skype.

    Click image for larger version

    Basically what I want to achieve is have the headset playing sound but also be able to speak through skype without it playing the sounds I have on.

    Also, there's a little switch on the cable to act as a "Mic Mute" switch, if the Mic is ON then the sound is fine, if I switch it to OFF the sound is very echo'd and distant.

      My System SpecsSystem Spec

  2. #2


    First, stereo mix should be set as the default recording device. Then any input device that is used will be heard.

    As Windows only allows one default audio playback device, separating sounds or what's heard may not be possible or is an option of the application program. I'm not familiar with Skype so I don't know what the options are or do.
      My System SpecsSystem Spec

  3. #3


    Posts : 10
    Windows 8


    Even setting the Stereo Mix as the default device and keeping Microphone as the Default Communications Device, the Microphone is still acting like the Stereo Mix and using the computers current sounds.
      My System SpecsSystem Spec

  4. #4


    The microphone is not a playback device. I don't know what you mean?
      My System SpecsSystem Spec

  5. #5


    Posts : 10
    Windows 8


    Basically, I have a new headset.

    When I speak, nothing is picked up on the microphone. Instead, if I'm on youtube or playing music, it comes through the microphone, so if I was in a call, people would hear all the sounds on my computer and not hear me.

    So, hearing things is not a problem. The problem is when I speak, no one can hear me but hear what I'm doing instead.

    See this;

    Click image for larger version

    I'm not speaking. That's music playing through the Microphone. Stereo Mix is silent apparently.
      My System SpecsSystem Spec

  6. #6


    That sounds like something is reversed. Try plugging into the rear Speaker and Mic jacks (if you haven't tried that). If its still reversed I would suspect something is wired wrong in the headset.
      My System SpecsSystem Spec

  7. #7


    Posts : 10
    Windows 8


    I've tried rear and front, both have the same outcome. I've also tried switching the green with the pink, surprisingly it works exactly the same.
      My System SpecsSystem Spec

  8. #8


    Can you try the headset in a different PC? A friend's if you don't have another to see how it works in a different PC.
      My System SpecsSystem Spec

  9. #9


    Posts : 10
    Windows 8


    I managed to find the problem. I just took a few minutes to properly look at the cables and swapped them around to see if anything changed. The cable that connects the headset to the jack cable was apparently labeled wrong, since swapping it to the opposite sides has made it work.
      My System SpecsSystem Spec

  10. #10


    Cool. Were they color coded wrong or just labeled wrong?
      My System SpecsSystem Spec

New Headset, not detecting microphone.
Related Threads
I currently have a Sennheiser PC 360 that I used on a previous build, which I paired with a ASUS Xonar D1 sound card on Windows 7. I recently put together a new build using Windows 8.1 and now the mic no longer works. I receive audio output through the headset speakers just fine, but the mic acts...
So the other day i bought a Logitech for 15 and i get home to recorded my voice but my laptop wont pick up my headset..Like it knows its been plugged in etc and will even play sound through the headset but can seem to get it to pop up on my microphone bit! Could someone help me please?
Hello Eightforums. Firstly, my problem is that my headset microphone is not working correctly. As my laptop (Lenovo g505s) only has 1 audio jack, but my headset has 2 cables (green and pink), i bought a 3.5mm headset splitter adapter that splits audio output to 3.5m headphone and 3.5 mic jack....
Hello, yesterday my PC stopped booting normally and now will rarely detect my SSD when booting leaving me with a blank screen with a blinking cursor in the top left until it reboots again. I have spent most of the day trying to troubleshoot this issue but I am baffled by this, it seems completely...
I have a Creative Fatal1ty Gaming Headset , the audio work's but I cannot get the mic to work. I have a Creative soundblaster 5.1 live soundcard and a abit fatal1ty fp-in9 sli m/b. Audio works on both soundcard and on-board sound on the m/b , but not the mic .... I know some basics to...
Hallo, The microphone on this non-brand headset isn't working due to the microphone not showing up under the recording devices. Audio is working for the headset (and anything else that I plug in ), but not the microphone. The green bars do not go up in the audio manager either when I test the...
CD-ROM not detecting disks. in Drivers & Hardware
Lately I've been having trouble trying to get any CD to work on my laptop. I can hear that the CD-ROM responds to the disk, but nothing happens, nothing loads. It only worked once, but for that one time I had to repeatedly put the disk in the CD-ROM. I have checked for posts on this, but...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook