Windows 8 and 8.1 Forums

Realtek ALC889 Win 8.1 - No digital coax output detected

  1. #1

    Posts : 3
    Windows 8.1 Pro, 64 bit

    Realtek ALC889 Win 8.1 - No digital coax output detected

    Hello everyone!

    First of all, I'd like to apologize if this issue's been solved in another topic already, but I couldn't find anything - if such a topic exists, please feel free to post the link .

    Now, onto the issue; first of all, the motherboard I am using is a Gigabyte GA-P67-UD5-B3. According to Gigabyte's website, it uses a Realtek ALC889 chip / codec. On the back of the motherboard are the usual 6x 3.5mm output / input jacks, as well as one TOSLINK digital output jack and a Coaxial digital output jack. I use the soundcard for:

    1. Headphones plugged into the 3.5mm output jack
    2. A/V Receiver plugged into the orange digital Coax output on the back of the motherboard (bolded as it's the source of my main issue)

    Up until recently, I was a Windows 7 user - I would always download the audio drivers from Gigabyte's website and everything worked just as it was supposed to. I've now switched to Windows 8.1 Pro 64-bit. And here's where the fun started.

    As usual, I downloaded the appropriate Windows 8.1 64-bit audio drivers for my motherboard straight from Gigabyte's website. The install went through without a problem, but after restarting the computer, I realised that my A/V receiver wasn't receiving any sound signal. I opened up the "Playback devices" Window, to see if the proper output was selected as default. I realised that even though I have checked "Show disabled / disconnected devices" the output option (digital coax) I was looking for wasn't listed there. However, the TOSLINK output option was there. In Windows 7, this was never a problem and they would both always show up and work as they should.

    I proceeded to check out all the options I could find in the Realtek HD Audio Manager app, to no avail. Nothing I could change seemed to fix my problem. Even the application itself only recognised the TOSLINK Digital output jack, but not the Coaxial one, as it would in Windows 7.

    I decided to try downloading a different set of drivers for my chip from a different website. It didn't help, the issue remained.

    But while uninstalling the old drivers and booting up the PC without any Realtek Drivers installed, I realised that at that point, the Coaxial Digital Output was recognized by Windows and it worked just as it should. I wouldn't mind not having the drivers installed at all, if it wasn't for the fact that I also use the headphones quite a lot and without changing the green 3.5mm output jack setting to "Headphones" instead of the default "Front speakers" in the Realtek HD Audio Manager application, the headphones just aren't loud enough.

    That means I'm now basically stuck with either:
    A) Not being able to use my Coaxial digital output or
    B) Listening to my headphones at a low volume level

    If my post isn't clear enough, here are pictures of what I am talking about:

    Picture 1: These are the options I get while the drivers are installed (the digital output seen here is the TOSLINK optical output which I have no use for)

    Click image for larger version

    Picture 2: These are the options I get while no official Realtek drivers are installed (both digital outputs have the same name here, but one of them is the TOSLINK Optical one and the other one is the Coaxial one)
    Click image for larger version

    So, that's about it. If anyone has any ideas on what I'm dealing with here, or how to resolve it, it would be greatly appreciated. I am also contacting Realtek's support on the issue as well, as I have no idea whether the fault is on Microsoft's side or Realtek's side. If anyone knows of a workaround to get more power to my headphones without the use of Realtek's HD Audio Manager application, that would pretty much solve my issue as well!

    Thank you .

      My System SpecsSystem Spec

  2. #2

    First, the High Definition Audio drivers are the generic, basic function, drivers that Windows installs. It can have most of the functions or not depending on the sound hardware.

    Have you tried the High Definition Audio Codecs (drivers) from the RealTek site? If not give them a try. The R2.75 drivers are what I'm using on my Win 7/Win 8.1/Win 10 installations. Everything that is available on the audio outputs show up. Realtek

    As far as what is available on the outputs, primarily is a function of what the motherboard vendor decides to allow/provide. Its not a Microsoft issue or possibly not a RealTek issue. However, I doubt that you will get any help from RealTek as they will only support the hardware vendors that use their chips. There are generic/general drivers (referenced above) that they have on their site, however many PC/motherboard manufacturers modify them for their own requirements. If something does not work right, as in your case, Gigabyte is the one that should resolve your problems (if the motherboard is certified for Windows 8.1).

    Power to the headphones is not a Windows issue, it again goes back to the hardware chip and drivers. With the generic High Definition Audio drivers, they do not specifically take advantage of everything the sound chip has to offer. You need the RealTek drivers.
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1 Pro, 64 bit

    Thank you for the reply!

    Indeed, the generic drivers from Windows work flawlessly as far as Coaxial digital output is concerned. However, they do not allow delivering more power to the headphones, which is why I'm desperate to get the Realtek drivers to work. The drivers I tried were the ones straight from Gigabyte's website (which I believe are not modified and are just a re-upload from Realtek's own website, but then again, who knows what actually came with the install package) and drivers I found on a different website I can not remember the name of. I did want to download them straight from Realtek's own website, but I actually couldn't find them on their website, so, thank you for the link! I will try those as soon as I get to my computer.

    You might be right about Realtek's support when you put it that way - I'll contact Gigabyte as well, if I don't manage to fix it on my own by the end of the day.
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8.1 Pro, 64 bit

    There we go - had a chance to try out the drivers from Realtek's own website.. And voila! The thing works at last! Thank you again for providing the link Fireberd, the Realtek site really had me confused, even though I usually find my way around computers very well.

    So, if anyone has the same issue as me, download the latest correct Realtek drivers from the following link;


    Thank you for all the help .
      My System SpecsSystem Spec

  5. #5

    Great, glad to hear you got it working. And thanks for the rep.
      My System SpecsSystem Spec

Realtek ALC889 Win 8.1 - No digital coax output detected
Related Threads
Hi guys, I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard. I have installed the latest realtek drivers; R2.73 from...
Hello all, I just got Windows 8.1 Pro as a gift from a friend and installed it just a few hours ago, and I noticed that I am having audio problems. Basically put, it's sort of random when this happens, but it seems to happen when sounds play rapidly, as letting a audio que play it's part will...
I don't know if any of this is related, but I wanted to provide as much information as I could for you gurus to deal with. So here's what happened: I left my ASUS K55A laptop in sleep mode. I opened the lid to wake it up, logged in, and then everything started to load really slowly. This hasn't...
My windows update, windows defender and lots of other programs including Vistart start menu refuse to work. I run the Windowsupdatediagnostic download and it tells me the SFC Output is corrupted or missing. Recently the BITS wasnt working but for some reason found the windows events log was...
Onboard Sound: ALC 888s external DAC/amp: Fiio E17 Connection: ALC 888s out----Optical digital cable-----Fiio e17 SPDIF in I do not get sound when I set Realtek Digital Output (Optical) as my playback device. I tested the cable and fiio e17 on my PS3 and it works fine. I tried on windows 8.1...
I installed Windows 8 Enterprise today for testing purposes, I did it for my father too, and I was happy seeing, how well it works. So I did the same on my PC too, but I have one serious problem. I can't install the audio driver at all! When I try to install it starts installing it, it copies...
I hae a dell m1710, installed win8 rtm on it. In win 7 i have 2 options of digital audio out: 1. Turtle Beach Audio Advantage Micro usb with optical S/PDIF out 2. Dell composite video adapter with digital coax out. Sigmatel high definition audio codec In win 8 i tried first the Audio...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook