Windows 8 and 8.1 Forums


Windows 8.1 Pro N "No audio devices are installed" Realtek

  1. #1


    Apartment
    Posts : 2
    Windows 8.1 Pro N

    Windows 8.1 Pro N "No audio devices are installed" Realtek


    I had this same issue with Win 8.1 Pro N about year ago as well and I somehow fixed it, but I can't recall what I did at all besides that it was big headache to figure out. Now yesterday since I got a SSD I installed Windows again and that problem is back.

    What I checked first:
    Click image for larger version

    Nothing to see here...

    Then I tried troubleshooter:
    Click image for larger version
    "Hardware changes might not have been detected"
    That's not very useful

    Let's check out Device Manager:
    Click image for larger version
    Shouldn't it be in sound devices category with some other entries? I have that category missing altogether.

    Properties:
    Click image for larger versionClick image for larger version
    "This device cannot start (Code 10)"
    I tried uninstalling drivers and restarting many times already

    Let's let Windows search for new drivers:
    Click image for larger version


    Outside of that I've tried to install two different versions of Realtek driver packages. Multiple times. One from Asus site that's latest for this particular laptop but officially has support only up to Win7. (I had that driver before so it works with 8.1) and other is from Realtek site that officially supports Win8.1 as well. No success.

    I even restored BIOS factory settings even though there aren't any sound related settings there.

    Windows Audio service is running. Checked that.

    I re-installed Windows 3 times. One of them was just old Win 8 Pro with no updates included, second was latest Win 10 preview, and finally I installed Win 8.1 Pro N back. None of them had working audio.

    Windows 7 didn't have that issue and I know that my hardware is fine because everything works under Ubuntu.

      My System SpecsSystem Spec

  2. #2


    Apartment
    Posts : 2
    Windows 8.1 Pro N


    Also I just discovered that when I installed either versions of Realtek drivers they removed all the files they copied to program files/realtek/driver folder just before finishing the installation. So they didn't even install properly.

    Probably due not finding actual audio hardware it can use? Then it's entirely Windows problem.
      My System SpecsSystem Spec

  3. #3


    Hi Sini..l have been stuck on this same problem for two weeks now.Did you ever find a solution.l have tried all the options you tried to no avail.
    Kindly help.Thanks in advance.
      My System SpecsSystem Spec

  4. #4


    Posts : 81
    Windows 8.1


    most likely a hardware problem, rather than a software/driver problem.

    also, the High Definition Audio Controller in the System devices section of Device Manager should NOT have a yellow exclamation mark. If it does, then it could be a sign of hardware malfunction.

    If this is happening on a laptop, send your laptop to an authorized repair shop to have it fixed. If this is happening on a desktop PC, replace the motherboard with one that has onboard realtek audio on it.
      My System SpecsSystem Spec

Windows 8.1 Pro N "No audio devices are installed" Realtek
Related Threads
I posted this on the Microsoft forums as well, but I have yet to find a solution on Google.... The title pretty much says it all. I am trying to use PS Media Server with Windows 8.1, but honestly whatever app I am using is irrelevant. The problem is, when I try to connect my PS3 to PS3 Media...
Another question/puzzle. Windows 8.1 Enterprise. I clean installed W8.1 three days ago, and the first thing I did was bring it up to date with all the offered updates. All installed successfully and I thought no more of it. At some point after this I made a system image backup, which today I...
I don't know if any of this is related, but I wanted to provide as much information as I could for you gurus to deal with. So here's what happened: I left my ASUS K55A laptop in sleep mode. I opened the lid to wake it up, logged in, and then everything started to load really slowly. This hasn't...
I'm running windows 8.1 on Toshiba Qosmio X875 Q7190. My computer kept crashing after trying to install Sabrent display adapter. I booted into recovery and did a system restore. Everything works fine now except the sound. I have visited Toshiba's website and downloaded the most recent Realtek...
An automatic update occured, and a blank box popped up continuously(Titled: C:/swsetup/sp59654/IDTSetup.exe) I was using my USB headset during that update, then all of a sudden they stop working and only my speakers were working, and no devices were being shown under playback devices nor under...
Hello, fellow... meh, I don't know. OS: Windows 8.1 Pro Processor: AMD FX-1400 Quad Core RAM: 8.00 GB Storage: 1.73 TB of 1.81 TB available System Type: 64-bit Operating System, x64 based processor ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ I...
I'll put this edit at the top, so that you won't have to read the rest if you don't want to. I fixed the problem by restoring my system to a restore point created the day I got the computer set up. I'll have to reinstall everything I've put on it in this last week, but that's better than sending...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook