Windows 8 and 8.1 Forums


Sound Blaster ZxR and Toslink - No System Volume Control

  1. #1


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional

    Sound Blaster ZxR and Toslink - No System Volume Control


    Greetings!

    I'm having a little problem here which I wasn't quite able to solve using the official Creative Support.

    First a little explanation:
    Before installing my new Sound Blaster ZxR I had to temporarily use the Onboard Sound of my Asus Rampage IV Black Edition because of a SLI Water cooling component blocking the necessary PCI Port of the former Sound Card ( a Sound Blaster Recon3D Fatal1ty Professional ).

    Because of the cracking ( grounding loop? ) I receive during the startup when using 3.5mm jacks ( or 1/4" with the ZxR ) I stopped using them whenever possible and instead started using the Toslink connection on both the Recon3D AND the RIVBE as it electrically disconnects the PC from the Sound System.

    Now here comes the Problem:
    Using the new Sound Blaster ZxR and having it connected via Toslink to my Sound System I'm not able to control the Volume using...
    • Multimedia Keys on my Keyboard
    • Volume Mixer from the Taskbar
    • Even Muting isn't possible


    The only way to change the Volume level from now on has been by doing one of the following four...
    • Change the Volume level by Hand in the corresponding App itself, not the overall System Volume - Kind of sucks
    • Using the Hardware Dial on my Speaker System - Hard to reach
    • Switch from Toslink to Jacked Cables - Startup cracking

    Also

    • Switching the default Playback Device from Speakers to Digital Audio (S/PDIF) - Will cause me to loose the ability to run Encoders like Dolby Digital Live or DTS Connect and it's DTS Neo:PC Music Mode feature which, in my opinion, really improves my listening experience as it then uses all my Satellites, not just the front ones.


    To be honest... I'm not sure how my settings were while still using the Recon3D that allowed me to go Toslink while still being able to change the System Volume simply by using the Multimedia Keys of the Keyboard but if anyone has an idea I'd really appreciate some Information.

    Thanks in Advance.

      My System SpecsSystem Spec

  2. #2


    I have a recording studio and use Toslink's. I have to control the volume level in my recording program. There are level controls on my recording interface unit (Roland Octa-Capture) but it is for analog only.

    In a PC, when you use a digital output, that bypasses all (or most all) of the sound card as the device its feeding is the one that has the volume level control. I suspect this also applies to what you have, as it apparently works the way my Toslink works (the level control in the application program).
      My System SpecsSystem Spec

  3. #3


    Posts : 148
    Windows 8.1 Update 1


    Right click the speaker system tray icon and select "playback devices". Choose "Speakers" as your default playback device. Next you should activate "Play Stereo Mix using Digital Output" in the Creative driver settings. Now you should be able to control the volume again.
      My System SpecsSystem Spec

  4. #4


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional


    Quote Originally Posted by altae View Post
    Right click the speaker system tray icon and select "playback devices". Choose "Speakers" as your default playback device. Next you should activate "Play Stereo Mix using Digital Output" in the Creative driver settings. Now you should be able to control the volume again.
    That did not really gave me access to Volume Controls via Multimedia Keys.

    But it's okay... I resolved to using the Volume Control of the Speaker System despite it being hard to reach...
    In the end it's not like I'm in constant need of doing so...
      My System SpecsSystem Spec

  5. #5


    Posts : 148
    Windows 8.1 Update 1


    And what about the software master volume/ PCM volume control? At least that one should work now if everything is configured correctly. I presume the latest drivers are installed. If you are not sure check if there is a driver update for your hardware.
    Last edited by altae; 02 Aug 2014 at 20:18.
      My System SpecsSystem Spec

Sound Blaster ZxR and Toslink - No System Volume Control
Related Threads
The Creative Sound Blaster X-fi Xtreme Audio card works fine in Windows 8. The drivers for Windows 7 work without any problem and the Creative updater and control panel also work as they should in Windows 8. The drivers can be downloaded here for the X-Fi Xtreme Audio card - Creative Worldwide...
after installing sound blaster x-fi 5.1 pro (usb) soundcard successfully and downloaded drivers from creative s website . i cant get there so called entertainment console to download .im looking for something to control sound levels and effects in a small home studio
Greetings everyone, I just received my new sound card and I'm excited to try it out. I've hooked it up and connected my headphones into the proper jack. I try out the audio and it's bloody awful, worse than on-board audio (which is not too bad). I don't know what's wrong, this (I hope) shouldn't...
Hi all, Just joined up.... What I want is actually the opposite of what most people are looking for. I want to install windows 8 on my kids computer but want the volume level to be set at a certain level so the sound is not to high no matter what they do. I am able to achieve this right now...
I recently installed Windows 8. My Creative suite is seen in the start screen, however when I try to initialize the console or anything else..nothing happens. The upgrader indicates I have the most recent version. I've been to Creatives site but cant find drivers for the X-FI MB. Anyone else have...
Solved Sound Blaster X-Fi Driver in Drivers & Hardware
On Friday 10/26 I upgraded to Windows 8 Pro and found I still had the SB driver problem for the X-Fi which is not supported by Creative anymore since my system is now over 4 years old. I'm not sure exactly when this original X-Fi card came out. I tried different Creative drivers as I had in the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook