Windows 8 and 8.1 Forums


Creative audio cards & unable to detect supported product

  1. #1


    Posts : 6
    Windows 8.1 PRO 64

    Creative audio cards & unable to detect supported product


    Just in-case anyone else is having this issue.

    When attempting to install Creative drivers for X-Fi cards you may receive this message:

    "unable to detect supported product"

    and of course that's as far as you get.

    To resolve this issue:

    1. Uninstall the current drivers.
    2. Shutdown and power off. Physically remove the audio card.
    3. VERY IMPORTANT STEP: Boot at least once with the audio card removed.
    4. Shutdown and power off. Re-install audio card.
    5. Bootup. Re-install drivers.

    If this doesn't resolve your issue you have another problem.

      My System SpecsSystem Spec

  2. #2


    Posts : 62
    Windows 8.1 Pro x64


    You could try these:

    SB X-Fi Series Support Pack 3.0 (08/11/2014)

    Working fine with X-fi Extreme Music / Win 8.1
    They actually save the settings.
      My System SpecsSystem Spec

Creative audio cards & unable to detect supported product
Related Threads
The Creative Sound Blaster X-fi Xtreme Audio card works fine in Windows 8. The drivers for Windows 7 work without any problem and the Creative updater and control panel also work as they should in Windows 8. The drivers can be downloaded here for the X-Fi Xtreme Audio card - Creative Worldwide...
Hello, Everything was ok with sound but now the computer doesn't detect any sound devices like amplifier, headphones, speakers, etc. The computer does find the audio card, but not devices. Please help. 42925429274292642928
Solved Unable to detect Samsung Modem in General Support
Hello Friends, I am again... Recently I've loaded windows 8 pro 64 bit in my netbook; after that I've installed my Samsung Galaxy Y PC Suite (Samsung Kies - already updated). When I go to Phone & Modem in control panel, under the modem my phone is not showing.. My windows 7 PC getting this...
Greetings everyone, I just received my new sound card and I'm excited to try it out. I've hooked it up and connected my headphones into the proper jack. I try out the audio and it's bloody awful, worse than on-board audio (which is not too bad). I don't know what's wrong, this (I hope) shouldn't...
have finally got two card spider solitare working but now find I can only move one card to a new position when previously on vista I could move one card or several cards in order to a new position, what am I doing wrong
I hae a dell m1710, installed win8 rtm on it. In win 7 i have 2 options of digital audio out: 1. Turtle Beach Audio Advantage Micro usb with optical S/PDIF out 2. Dell composite video adapter with digital coax out. Sigmatel high definition audio codec In win 8 i tried first the Audio...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook