Windows 8 and 8.1 Forums


TIFU by deleting my sound device

  1. #1

    TIFU by deleting my sound device


    So I was doing some uninstall housekeeping because of an issue with another program when apparently I accidentally deleted my audio device. I believed this to be Realtek so I went to the website and downloaded their free 64 bit version. BTW I'm running windows 8.1. The device manager doesn't show any issues with my realtek or AMD sound device, but the cute little audio speaker is exed out at the bottom and whether I plug headphones or speakers into the computer it does not recognize the device. I found another guy on a diff forum running win 7 who ended up just replacing his sound card, but I refuse to believe I've messed up THAT badly. Any help for a poor du? Please smart people?

      My System SpecsSystem Spec

  2. #2


    Check the Sound Panel/Playback section. Your Speakers (the Realtek) should be set as the default audio playback device.

    It that is set, go to the Device Manager, Sound Section. You should have the RealTek listed (and possibly an AMD Audio for HDMI audio) but nothing else. If you see "High Definition Audio Codec" listed, that is the generic, basic function, Windows installed sound driver and that should be uninstalled.
      My System SpecsSystem Spec

  3. #3


    If it's real Realtek driver (not MS one) you should have it's HD Audio Manager in the Control Panel, from there you can have many adjustments for sound.
      My System SpecsSystem Spec

TIFU by deleting my sound device
Related Threads
Hi, I have been having sound problems with the speakers on an HP Ultrabook. There are times when the laptop speakers stop working. When this occurs, I go to Control Panel>Sound, select the speakers(only one set to select), select Configure and Test. After selecting Test, I receive the message...
Hi, While exploring Device Manager today in my Win 8.1 system I discovered I had three entries listed under Sound, Video and Game Controllers: (1) AMD High Definition Audio Device (2) CyberLink WebCam Virtual Driver (3) Realtek High Definition Audio Every now and then when my...
Hi all. In terms of gaming, hardware and things like that, I am pretty experienced. This one has me stumped. I have searched places I know that might have a fix, but found nothing helpful. I recently purchased a Plantronics Gamecom headset, and am really enjoying it, but there is one...
Just turned my PC on and I keep getting a Windows 8 Device Connect sound every 4-6 seconds.. no USB or anything wired connected to my PC for it to give me this sound?
Whenever I'm in the Windows environment (meaning not doing anything in full-screen mode), the "Device Eject Sound" (the little do do do do that plays whenever you eject a device) will constantly play at almost random. Sometimes itll play three times in a row right after the other, sometimes it wont...
Hi, At every start-up there is ether a Device Disconnect sound or a Device Connect sound that gets interrupted by a Device Disconnect sound. This happens on every start-up, after almost everything is loaded. P.S. There are no Yellow !-s in the device manager.
I get the error attached. 22484 However, devices show up in device manager. 22485 When I try to re-install the driver from the dell site, the installation fails. Here is the error log:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook