Windows 8 and 8.1 Forums


Asus Laptop/RealTek "No Audio Output Device is Installed"

  1. #1


    Posts : 3
    Windows 8.1

    Asus Laptop/RealTek "No Audio Output Device is Installed"


    I don't know if any of this is related, but I wanted to provide as much information as I could for you gurus to deal with. So here's what happened:

    I left my ASUS K55A laptop in sleep mode. I opened the lid to wake it up, logged in, and then everything started to load really slowly. This hasn't happened before, and the computer quickly BSOD'd in that new Windows 8.1 fashion. It restarted and scanned/repaired my D drive, again in a very slow manner. It took maybe 20 minutes just to get to the login screen (as opposed to maybe a minute). I login, and again, everything's very slow. This time, I just hit the power button and reset the laptop that way, hoping it'd fix things. Unfortunately, the same thing happens. After doing this about 2 or 3 more times, each time spending about 20 to 30 minutes, I just let it run after I log in. I manage to click the "Restart" option on the side after waiting eons for it to respond to my clicks. I get it to load and it booted up normally.

    Or so I thought.

    My D drive was suddenly inaccessible and my little volume speaker at the bottom right had the red X beside it, saying "No Audio Output Device is Installed". I spend another billion years trying to fix my D drive, changing permissions and allowing full control, and eventually getting full access again, most likely with some unknown ramifications. I found out after that although my C drive didn't suffer from the same problem as my D drive, the C drive would keep asking me for my permission when I moved things around there, even though it was never like that before all of this. I do the same thing I did with the D drive and seemingly fixed the issue.

    My next focus was on the sound.

    I made the mistake of not checking my Device Manager before I blindly reinstalled a Realtek driver. I don't think it made a difference, but I'll never know now. Anyway, I downloaded a Realtek HD Audio driver that should've been compatible with my system, but I couldn't get it to finish installing, as it ended every installation that I tried with some error code 0x00000002.

    I go into Device Manager and see two icons with the exclamation marks (!) beside them: "Intel (R) Display Audio" and "Audio Device on High Definition Bus". The "Intel (R) Display Audio" was under the normal "Sound, video and game controllers", but the "Audio Device on High Definition Bus" was found under "Other Devices". So I just uninstall the "Audio Device on High Definition Bus", since I've read that sometimes you need to uninstall in order to reinstall something. After I uninstall, I manage to successfully install a compatible Realtek HD Audio Driver. However, it still wouldn't give me sound after I restarted my computer as it prompted me to. On top of that, there was no Realtek HD Audio Driver or anything similar found under "Sound, video and game controllers". Only "Intel (R) Display Audio" was there, and apparently that wasn't working either. After uninstalling and reinstalling multiple times, I just uninstalled "Intel (R) Display Audio" out of frustration, which then led to TWO "Audio Device on High Definition Bus" under "Other Devices".

    I go into msinfo32 and under "Problem Devices", there's the two "Audio Devices on High Definition Bus" and they have the error code that says "This device is not configured correctly". I also don't have anything under "Sound Device".

    I don't know what to do. Did my sound card just burn out during the whole D drive Scan/Repair fiasco?

    Edit: I forgot to add that I've tried the "Adding/Scanning Legacy/Hardware" but I might have done it incorrectly or something, because it was unable to successfully install/find anything.

      My System SpecsSystem Spec

  2. #2


    From your description, I'm going to suggest what I try to avoid at all costs. Do a complete reinstall. I know its a hassle but sometimes its what is needed.

    Backup your user data to some external media (USB flash drive, CD/DVD media, etc) first as the reinstall will wipe it all out. Then do the reinstall, using the recovery mode that I assume ASUS has (most PC vendors have a recovery partition on the hard drive that will allow restoring to the original factory condition).
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    Thanks for the reply, fireberd.

    It's gonna take a while moving everything somewhere else, but I guess there's no other choice. I just don't want to go through all this trouble only to find out that it won't solve my problem, and that it's actually a sound card issue.

    Is there any possibility that it might be because something internally burned out? I mean, how likely or unlikely would it be?
      My System SpecsSystem Spec

  4. #4


    Murphy's Law says it will be something else. But, in most cases the first step, with the multitude of problems you have had, a complete reinstall will fix it.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.1


    Everything's fixed. The reinstall fixed the sound issue.

    Thank. God.

    Irks me that I still don't know what caused it, but oh my god am I glad this is fixed.
      My System SpecsSystem Spec

Asus Laptop/RealTek "No Audio Output Device is Installed"
Related Threads
I had this same issue with Win 8.1 Pro N about year ago as well and I somehow fixed it, but I can't recall what I did at all besides that it was big headache to figure out. Now yesterday since I got a SSD I installed Windows again and that problem is back. What I checked first: 57003 Nothing...
Hi all, Recently upgraded my Dell Latitude E6420 to Windows 8. When I attempt to use my Sony TV as a second monitor via HDMI cable, I no longer get audio. Cable is fine and worked previous to upgrade. Video comes up fine. In "Playback Devices" (with both "Show Disabled" and "Show...
Hi all, I'm at a loss....trying to fix a almost brand-new Acer laptop for friends of mine. They were having issues with music files not playing at all in Windows Media Player or other audio programs, so I told them I would help them. First I thought it may be the sound drivers, so I uninstalled...
Hey Guys, My VIA drivers won't install because it can't find the device. I'm trying the driver from the Biostar Website. I've tried the ones from the via website but those don't work either. I get nice clear audio but i can't configure my drivers so I can get my sub woofers working. Links...
Hello, I have a Toshiba Satellite L875-S7110 with Windows 8 that is a few months old now, and had been working fantastic until last night. Windows did an update, and now I have a red X over my sound icon that states "No Audio Output Device is installed." Things I have tried so far to try...
I'll put this edit at the top, so that you won't have to read the rest if you don't want to. I fixed the problem by restoring my system to a restore point created the day I got the computer set up. I'll have to reinstall everything I've put on it in this last week, but that's better than sending...
Hi, I have a compaq presario V6500 which came installed with Windows Vista. I recently upgraded my OS to Windows 8 (last month). Today, just like that, the sound was lost, while I was listening to a tutorial online. The sound icon on the desktop taskbar says "No Audio Output Device is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook