Windows 8 and 8.1 Forums


Headset not showing as a playback option, no mic either

  1. #1


    Posts : 4
    Windows 8.1, 64 bit

    Mic on headset not working properly


    I have an Asus R503U laptop running Windows 8.1, 64 bit, and the headset has never worked properly with this computer. I am pretty certain it is not the headset, but a settings or software issue..

    For one thing, there is no "headset" listed as a separate playback option even after I plug the headset in - however, I can hear through the headset if I choose the speaker as a playback option, and if I unplug the headset, sound will play through the computer speaker, so I have just been using the speaker setting for playback when wanting to hear through the headset.

    However the recording/microphone option produces a horrible humming feedback sound when I try to use Skype or record through the headset mic. The recording options are "microphone" or "stereo" and even if I disable "stereo" I have the problem.

    My drivers are uptodate - I am using VIA drivers. I have fiddled with various sound settings but can get nothing to work. I have all enhancements to sound disabled and also tried using the trouble shooter to no avail. Can anyone help me figure out what to do here?

    Much appreciated - thanks
    Last edited by ajack17; 03 May 2014 at 06:46.

      My System SpecsSystem Spec

  2. #2


    Is this a standard analog mic/headset that plugs into the mic and headphone jacks, or is this a USB connected type?

    In the Recording options, the "Stereo Mix" (may be called System Mixer) should be set as the default recording device. Then if a mic or line in is used it will be heard or be able to record.

    Did this PC come with Windows 8 or was it upgraded from XP or Win 7?
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    Windows 8.1, 64 bit


    Thanks for your reply!

    1) It is a Case Logic standard analog mic/headset that plugs into the mic and headphone jacks.


    2) "Stereo Mix" (may be called System Mixer) whether set as the default recording device or not, produces no recording ability.

    3) Came with Windows 8 and since has been updated regularly all of the most recent updates.
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 8.1, 64 bit


    I should mention that the "playback" options are currently set at "speaker" (enabled, default) and AMD HDMI Output (not plugged in). The "recording" options and settings are "microphone" (VIA Hi Def audio, disabled) and "stereo mix" (enabled, default device). If I set the mic to enabled as well as the "stereo mix" as default enabled, I get horrible feedback unless the "listen to this device" for the mic is unchecked; if it is unchecked, however, I cannot hear what I am recording until I play it back, and then I see that it has recorded the voice along with the horrible feedback interference noise anyway ......BTW, dont know if this is important, but the "properties" show rear panel 3.5 jack although the actual connection is analog jacks in the front.
      My System SpecsSystem Spec

  5. #5


    This may be hardware rather than a software/driver problem. "humming" suggests one of the mic wires may not be connected (internally) and thus you are getting the hum. As the headset, too, is not functioning properly it may too be an internal connection. Many PC's have a separate I/O board that is connected to the motherboard via some type of connector. If that connector is not fully connected or not making good contact, it could cause what you have.

    If the PC is still in warranty, contact the PC vendor. If not, and you are up to it, consider getting into it and checking cable connections.
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    Windows 8.1, 64 bit


    Thanks - will do
      My System SpecsSystem Spec

Headset not showing as a playback option, no mic either
Related Threads
so i got an msi gaming z97 micro atx board, but on the io i cant find where the hell to plug in my headset.... there is a mic and the l-output and input well 3 inputs and 3 outputs. i checked the manual but it didnt say it. 56997
The Troubleshoot icon that should be under the 'Advanced Startup' Option is missing. System is a new Dell Latitude 10 ST2 Tablet running Windows 8. Have access to 9 other identical tablets, all configured the same and they all have the Troubleshoot Option. Have tried multiple methods of getting...
Hey, so yesterday I did a refresh of my PC (full) and before I did, I would have my speakers and my headset in the Playback Devices, where I would enable or disable which ever one I was usning. If I was chatting on Skype I would enable my headset and disable my speakers and vice versa....
Hello, I have Lenovo Miix 2 10 tablet and Creative WP-300 headset. When I listen to music and put the device into Connected Standby it keeps playing nice. But when I pause the playback using controls on the headset, the headphones disconnect and are unable to reconnect automatically. So I have...
Hi, I decided to upgrade my current PC (running on Vista) with a SSD drive. I also bought windows 8 and installed in on this drive. I changed the boot order in my bios so my SSD drive comes first. I was expecting to have a dual boot option at start-up but this option doens't show up. ...
No sound using 360 headset in Sound & Audio
I am using a turtle beach headset plugged in through my xbox 360 wired controller. The device displays in the sound area but does not produce any sound when i try and test it. It doesn't even act like the test is being sent to the device. The mic however does work just fine. Anybody have any...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook