Windows 8 and 8.1 Forums


Razer Megalodon - (Device Descriptor Request Failed)

  1. #1


    Posts : 2
    Windows 8.1

    Razer Megalodon - (Device Descriptor Request Failed)


    Hello Ladies & Gents.

    I would like to ask for your assistance on this slightly annoying problem.

    I have 1 pair of Razer Megalodon USB headphones, on the start up of Windows 8.1 these headphones are not detected correctly. The only proof I have of this is in the device manager displays:

    Universal Serial Bus Controllers -
    Unknown USB Device (Device Descriptor Request Failed).

    (Please see attached screenshots)

    Once the device is disconnected and reconnected device manager then displays:

    Universal Serial Bus Controllers -
    USB Composite Device

    The device then shows in "Audio inputs and outputs"

    Cheers,

    Mr Collective

    Attachment 38815
    Attached Thumbnails Attached Thumbnails Untitled.jpg  

      My System SpecsSystem Spec

  2. #2


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Razer is well known for BSOD drivers and problems, otherwise. (And taking very old drivers, changing nothing at all, giving it a new date and then claiming "Compatible!" with new OS.)

    Perhaps give a shot with uninstalling their software, rebooting, the re-installing.

    Make sure using the latest.

    When all is said and done, you might just have to live with it.

    Can't hurt to make sure chipset drivers are up to date. If Intel chipset, search their driver site for "Inf"
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8.1


    --------------------------------
    I will update this post with any specific answer I get relating to this issue for others.
    --------------------------------

    Unfortunately they don't have an updated Firmware driver above 2012 for the Razer Megalodons.

    I'm currently in a very slow responsive email conversation with Razer relating to this issue.

    I have attempted all of the above numerous time.

    Doesn't work on any 8 or 8.1 OS
    Last edited by Mr Collective; 03 Mar 2014 at 13:42.
      My System SpecsSystem Spec

Razer Megalodon - (Device Descriptor Request Failed)
Related Threads
Hi, i am having trouble connecting my camera to my PC. It works perfectly on another PC running windows 8.1 pro the same as mine. I open device manager and my device is listed under other devices as canon digital camera, though it has an exclamation mark on it. In the properties under the...
I know that a similar question has been asked before but, not with the last part of the message, (Device Descriptor Request Failed). I get this, in Device Manager, and I have searched for an answer on the net. Also it is a Code 43. I went through my laptop, with an HP Technician this morning, I...
My computer keeps telling me Unknown USB Device (Device Descriptor Request Failed), so I looked up how to fix it and they told me to uninstall it then scan for hardware changes and it will reappear working properly.:thumb: Only it did not come back working properly, it came back the same. :mad: I...
removing bluetooth device failed in Drivers & Hardware
Hi, I have got a problem with bluetooth device. I tried removing my bluetooth device but it failed to remove. It is displayed as "removing device" on the screen as shown in the picture. Now I cannot add the device again. I don't find the device when I search by clicking on "add a device" as shown...
Hi all, (Unknown USB Device - A request for the USB device descriptor failed) Massive problem I have encountered since buying a new laptop pre-installed with Windows 8.1 I have 3 external USB storage devices - 1x Corsair "Slider" 64GB, 1x HiTachi Touro 750GB, & 1x HiTachi 4TB external...
Solved USB 3.0 Device Failed Enumeration in Drivers & Hardware
I have a Seagate GoFlex 1 Tb USB 3.0 drive. All worked good until a week or two ago. Now the drive will not be recognized when plugged into a USB 3.0 port, the error given is "Unknown USB Device (Device Failed Enumeration). If I plug the GoFlex drive into a a USB 2.0 port, it works. I can...
I have a flash drive that I previously used in public computer lab (where many viruses linger) the other day to do my work. As I got home, the flash drive isn't working anymore, saying "USB Device not Recognized". I also noticed that it really took me a while to finally, safely remove it from the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook