Windows 8 and 8.1 Forums


No audio input and output

  1. #1


    Posts : 7
    Windows 8

    No audio input and output


    Well, things went on until noon yesterday, but suddenly My PC takes no audio input or gives any output.
    I have tried reinstalling driver, checking mute button, checking Cables etc, none of the audio devices work on my PC which work in other devices.
    On opening realtek audio manager and playing auto test, Nothing plays, and going to control Panel -> Sound, and playing the test tone, I get this error:
    Click image for larger version

    Just as an additional info, I reinstalled AVG Internet Security 14 yesterday, and probably the audio was working till then. Once AVG was installed and the system got restarted, a system Update was triggered automatically, if that has got anything to do with my problem.

    P.S. I could not use system restore as well, I get the following error:
    Click image for larger version
    Also, I come to know by googling that The Audio and System restore problems come in combos frequently.

      My System SpecsSystem Spec

  2. #2


    Do you have any audio listed in the device manager, other than RealTek, and possibly an HDMI audio (if your system has that capability)? If there are other audio entries, such as "HD Audio Codec" uninstall those as they can conflict with the actual sound device (RealTek).

    An uninstall/reinstall if the sound device will fix any Windows corruptions, and MAY fix your audio problem. In the Device Manager, RIGHT click on the entry for the RealTek to highlight it and then LEFT click "Uninstall". DO NOT uninstall the driver. Restart the PC and when Windows starts it will detect and reinstall the sound.

    AVG is on the list of Antivirus programs that potentially can interfere with Audio. I have a recording studio, using Sonar X3 recording software, and AVG is listed as one to avoid. For that reason (and that it works), I only use the built in (built in to Windows 8) Windows Defender (is called Microsoft Security Essentials in XP, Vista and Win 7).
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Windows 8


    fireberd, thanks for the reply,
    Three points that I should say:

    1. In device manager should I see under 'Sound,Video and Game controllers' or 'Audio Inputs and Outputs' ? In case it is 'Sound,Video and Game controllers', other than RealTek, there are three, all of which possibly would not be a trouble maker, since they had been for a long time, however the are : Leawo Audio,USB Audio device (built in my Miscrosoft Webcam) and WebCamMax VideoCapture. I tried disabling them all as well but no luck.

    2. Reinstalled the device as well, but still I could not get it working.

    3. Removed AVG and now i am using trial version of Kaspersky Internet Security 2014, still the devices dont work.
      My System SpecsSystem Spec

  4. #4


    In the Sound Panel, Playback section, what do you have as default Playback device? It should be "Speakers" (RealTek). If it is something else, set the Speakers as the default playback device and then try the speaker test.

    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    Posts : 7
    Windows 8


    Yes, speakers is the default device, and there are no others listed other than Speakers and Realtek Digital Output
    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    It has to be one of the applications you have on the PC that is conflicting and causing the problem. Skype and web cams are two that I have seen interfere. I don't know about the others. Disabling in the Device Manager may not actually be fully disabling the device. If something were running at startup, disabling may not actually fully disable the device. Disable everything except the RealTek in the Sound section of the Device Manger, then restart the PC and see if you now have audio. If you do, one of the devices is causing the problem.
      My System SpecsSystem Spec

  7. #7


    Posts : 7
    Windows 8


    Yes, that was the first thing I did after your first reply, and the others are still disabled, but I have no audio.
      My System SpecsSystem Spec

  8. #8


    Also, I come to know by googling that The Audio and System restore problems come in combos frequently.
    This suggests a Windows 8 Operating System problem, since everything associated with the sound or sound drivers has been tried.
    A Windows OS corruption can cause the no audio device problem.

    Run the SFC/Scannow.

    SFC /SCANNOW Command - Run in Windows 8
      My System SpecsSystem Spec

  9. #9


    Posts : 7
    Windows 8


    Yup, sorry if I hadnt mentioned it before, but I have tried sfc/scannow command as well, even as Administrator, but had no luck.
    And I too suspect it it an OS problem as my windows 8 is very problematic, and the last option should be a fresh install
      My System SpecsSystem Spec

  10. #10


    Looks like a new install is in order. That is a drastic step, but sometimes it is required.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
No audio input and output
Related Threads
Hi guys, I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard. I have installed the latest realtek drivers; R2.73 from...
I have a self-assembled desktop PC - full specs in the signature below, but in short, it has an AMD Phenom II X6 1090T processor on a Gigabyte GA-970A-DS3P mainboard, which uses a Realtek Azalia ALC887 on-board sound system. I have no loudspeakers and listen to the computer sounds exclusively...
Hi there, I'd really appreciate if this could work, the details of my system are as follows: Dell XPS L502X Nvidia GT 525M I have downloaded the Realtek Drivers as mentioned here for the Windows 8 version, plug in the HDMI cable but still the output doesn't go to the TV but sound plays from...
i have a dell inspiron 14z 5423 laptop which supports IDT high defination audio driver . . . when i try to insltal it from the site the box says that " the hardware detected is not supported by this IDT .software package . . the install will be aborted . . .but in the dell site it shows that my...
i have installed windows 8 pro 32 bit . but the probelm is faced . the audio service is runing in both sides, when i am plugging the headset the sound is coming in both sides I mean that in headset and also in loudspeakers. i want to play sounds only on headset when i plug the headset ,...
Hello, I have a Toshiba Satellite L875-S7110 with Windows 8 that is a few months old now, and had been working fantastic until last night. Windows did an update, and now I have a red X over my sound icon that states "No Audio Output Device is installed." Things I have tried so far to try...
Hi, I have a compaq presario V6500 which came installed with Windows Vista. I recently upgraded my OS to Windows 8 (last month). Today, just like that, the sound was lost, while I was listening to a tutorial online. The sound icon on the desktop taskbar says "No Audio Output Device is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook