Windows 8 and 8.1 Forums


AMD HDMI Output 'not plugged in', no sound

  1. #1


    Posts : 9
    Windows 8.1

    AMD HDMI Output 'not plugged in', no sound


    Hi all.

    I sucessfully got bootcamp to work on my iMac, and the only issue that I have run across is that I do not have any sound whatsoever coming out of my speakers.

    The sound icon just remains at the speaker with a red cross, and no matter what I do, I just can't get it to work.
    In Device Manager, the sound device that is being used is 'AMD High Definition Audio Device', and I can't seem to find an update for it anywhere. Under the sound area of control panel, if I go to the playback tab it says that the only available playback device is 'AMD HDMI Output', and it says that is "not plugged in".

    Would anybody have any advice whatsoever? I honestly don't know what to do at this point, I have tried to search on this topic but it just always seems to lead me to a completely different problem that doesn't help me.

    Thank you very much in advance.
    Sky W.

      My System SpecsSystem Spec

  2. #2


    Posts : 9
    Windows 8.1


    I've attached some photos for your convenience and understanding.

    Click image for larger versionClick image for larger version
      My System SpecsSystem Spec

  3. #3


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    You gotta hack the latest desktop driver .inf (from AMD's site), to add your hardware ids (for audio/video), that's similar to your HD video adapter and install. Then install both via the Device Manager by pointing to the right inf files.

    In addition, you'll have to permanently disable Driver Signing so you don't have to do it every time at boot, if you installed x64.
      My System SpecsSystem Spec

  4. #4


    Posts : 9
    Windows 8.1


    Thanks for your quick response!

    I'm sorry to sound nooby, but would you be able to explain how to get this .inf file, exactly? I've been through hell with this computer and any steps would be greatly appreciated.

    I should probably be able to disable driver signing by googling, but if you feel like including how to do that as well, that'd be magnificent.
      My System SpecsSystem Spec

  5. #5


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    It's part of the driver package.

    I'll see if I can make it for you. I need msinfo32.

    Type msinfo32 in Start screen, press Enter. File | Save on the opened screen. Right click saved file, choose Send to compressed folder.

    Attach the zip it made to a new post.
      My System SpecsSystem Spec

  6. #6


    Posts : 9
    Windows 8.1


    Here's the zip file you requested.
    AMD HDMI Output 'not plugged in', no sound Attached Files
      My System SpecsSystem Spec

  7. #7


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    I re-read your thread and checked stuff.

    You have switchable graphics, and the AMD audio driver (that would be used for when connecting by HDMI) is already installed and well.

    There's a problem with your chipset allowing Windows to even see your onboard audio, which is likely Realtek or C-Media.

    Anyway,

    this should fix it:

    http://downloadmirror.intel.com/2062...9.2.3.1022.exe

    Then install latest HD Audio Codec driver from Realtek (If you have that.)
      My System SpecsSystem Spec

  8. #8


    Posts : 1,883
    7601.18247.x86fre.win7sp1
      My System SpecsSystem Spec

  9. #9


    Posts : 9
    Windows 8.1


    I'm afraid that I've tried all of your suggestions and I'm still not getting any audio. The only available sound output that is available is the HDMI one.

    I managed to find the right driver file from Realtek (which was real hell believe me, their servers are the speed of sloths I kid you not) and nothing has changed.

    Would you be able to recommend anything else?
      My System SpecsSystem Spec

  10. #10


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    First thing is first. Did you use the newest Intel link to install the driver for the entry in Device Manager with the !

    ?

    If you tried it, install Leshcat drivers for your switchable graphics. That should make the Intel video/audio entries that are not currently well into being well, and update all video drivers to newest:

    Leshcat?s Catalyst 13.12 WHQL UnifL Updated x3 ? leshcatlabs.net

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
AMD HDMI Output 'not plugged in', no sound
Related Threads
Problem: AMD HDMI output would not play sound via HDMI cable to monitor speakers. Testing the AMD HDMI sound output gave the following error message: Device in use by another application… This FIX worked for this hardware configuration. · MSI motherboard · Realtek Audio...
Basic Specs Brand New Toshiba Satellite C855 Win 8 64-bit 6 GB RAM Display Adapter: Intel(R) HD Graphics (2000) Driver: Intel 9.17.10.3040 Playback Devices
Hi there, I'd really appreciate if this could work, the details of my system are as follows: Dell XPS L502X Nvidia GT 525M I have downloaded the Realtek Drivers as mentioned here for the Windows 8 version, plug in the HDMI cable but still the output doesn't go to the TV but sound plays from...
HI, I'm new here. I run the sfc /scannow like 5 times because when I did it, it broke or damage my HDMI output. The only problem my sfcdetails.txt file shows is that it cannot repair Amd64\CNBJ2530.DPB of the prncacla.inf file due to a hash mismatch. But you already wrote that it doesn't had to...
HDMI output not working in Graphic Cards
Hey guys, I have an ASUS s550C running windows 8 and my HDMI to my 32" RCA flatscreen doesn't work anymore. The cable works fine with the xbox, correct tv modes, but now as soon as I plug in the HDMI to the Ultrabook the Ultrabooks screen goes black and the tv screen says unsupported. What gives?...
Okay so, my computer recently crashed and had to reformat it.. lost everything :( Everything was working just fine, until I had to reformat. Now, I have no sound at all coming from my headphones and it says that the AMD HDMI Output is not plugged in. I don't really know how to fix this.. ...
HDMI Sound output issues in Sound & Audio
Hi there, new to this forum but i've been searching around today trying to find an answer to this problem i'm having. I've bought an HDMI cable to connect my laptop to TV, i've gone into the control panel and checked that "show disabled devices" and "show disconnected devices" are both...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook