Windows 8 and 8.1 Forums


Realtek HD Audio only shows one audio output at a time

  1. #1


    Posts : 1
    Windows 8.1

    Realtek HD Audio only shows one audio output at a time


    Hi guys,


    I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard.
    I have installed the latest realtek drivers; R2.73 from the official website.


    Now, here's my problem: when I was using Windows 7 on this same machine, I could plug headphones in the front panel connector, as well as speakers in the green back panel connector. This would give me two audio outputs in the device manager/sound list, which was pretty practical and enabled me to output different applications through the speakers or the headphones.


    Now, however, there's only one output, irrelevant of whether or not I have two outputs plugged in at the same time. They appear in the device manager as a single device called "speakers" (see picture). Instead of both having separate outputs, they both output exactly the same audio.

    Click image for larger version


    Any solution to this?

      My System SpecsSystem Spec

  2. #2


    Hello audiobreak,

    Try going into the Realtek HD Audio Manager (Control Panel > Hardware and Sound > Realtek HD Audio Manager), then look for a setting called 'Make front and rear output devices playback two different audio streams simultaneously'. I cannot remember where this is located (The Realtek HD Audio Manager has different skins depending on the motherboard vendor), but for an ASUS Motherboard, I believe you click the Cog Icon in the top left and the option should be in there. I don't know if this will create a separate Playback Device for the Front Panel in Window's Playback Devices, but it will at least allow you to hear audio from both your speakers and headphones at the same time.

    Hope this helps.
      My System SpecsSystem Spec

  3. #3


    I have that motherboard and yesterday updated the RealTek drivers from the ASUS site to the latest which includes Windows 8.1 support.
    The Driver version is 6.0.1.7040. It changes the look of the RealTek HD Audio Panel. It no longer has that option, that I can see.

    New Version.

    Click image for larger version
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by fireberd View Post
    I have that motherboard and yesterday updated the RealTek drivers from the ASUS site to the latest which includes Windows 8.1 support.
    The Driver version is 6.0.1.7040. It changes the look of the RealTek HD Audio Panel. It no longer has that option, that I can see.

    New Version.

    Click image for larger version
    Ah, I cannot help out then as I've never ever seen or used that Realtek HD Audio Manager. The option is either hidden somewhere in there or maybe even removed for whatever reason.

    I see a Cog in the top right of the window though. Try clicking that and see if the option is in there.
      My System SpecsSystem Spec

  5. #5


    That's it. The "gear" in the top right of the panel has the options for speakers.

    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    Posts : 1
    windows 7


    Quote Originally Posted by fireberd View Post
    That's it. The "gear" in the top right of the panel has the options for speakers.

    Click image for larger version
    Anyway to get it to play out of the optical and speaker connection (both connections are in the back) at the same time as well?
      My System SpecsSystem Spec

  7. #7


    No way that I've ever found. You can have "Analog" (Speakers) or "Digital" but not both. Internal routing of the audio is different depending on which is selected.
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by audiobreak View Post
    Hi guys,


    I'm having a little problem with my onboard audio, having just installed Windows 8.1 (clean install). I have an Asus P8Z77-V LE PLUS motherboard, which includes a "Realtek® ALC889 8-Channel High Definition Audio CODEC" onboard.
    I have installed the latest realtek drivers; R2.73 from the official website.


    Now, here's my problem: when I was using Windows 7 on this same machine, I could plug headphones in the front panel connector, as well as speakers in the green back panel connector. This would give me two audio outputs in the device manager/sound list, which was pretty practical and enabled me to output different applications through the speakers or the headphones.


    Now, however, there's only one output, irrelevant of whether or not I have two outputs plugged in at the same time. They appear in the device manager as a single device called "speakers" (see picture). Instead of both having separate outputs, they both output exactly the same audio.

    Click image for larger version


    Any solution to this?
    Just out of curiosity was this ever solved? I had a similar situation today with the same setup and it was driving me mad to fix. I have connected headphones and computer speakers and was able to finally get them to play at the same time. Although I am not sure if it will help you since I had several 'playback' devices to play around with. My solution to get them both playing on headset and computer speakers was to click on the 'recording' tab and click on 'stereo mix' device and click properties and under the 'listen' tab you should see see a bunch of options. Just look at my screenshot on the far right and see if you can duplicate what I did. Hope this helps! Where it says 'playback through this device' select your headphones.
    Attached Thumbnails Attached Thumbnails sound properties.jpg  
      My System SpecsSystem Spec

  9. #9


    Posts : 1
    Windows 8


    Quote Originally Posted by fireberd View Post
    No way that I've ever found. You can have "Analog" (Speakers) or "Digital" but not both. Internal routing of the audio is different depending on which is selected.
    I had the same problem, just made an account to tell you guys how I fixed it. Clicked on the COGS similar to your screenshot and then went to 'Connector Settings' and selected "AC97 front panel". Now its playing from both headphones and speakers.
      My System SpecsSystem Spec

  10. #10


    Posts : 1
    Windows 8.1


    I messed around with this for a couple of minutes and found out how to fix it. See Below.

    1) go to device advanced settings, then click option


    2) Under Playback Devise click "make frond and rear output devices playback two different audio streams simultaneously.
    Under Recording device click: Seperate all input jacks as independent input devices



    After you've done this, the headphones and speakers will show up as independent devices.
    Jason
    Attached Thumbnails Attached Thumbnails Untitled.png   Untitled2.png  
      My System SpecsSystem Spec

Realtek HD Audio only shows one audio output at a time
Related Threads
I have a self-assembled desktop PC - full specs in the signature below, but in short, it has an AMD Phenom II X6 1090T processor on a Gigabyte GA-970A-DS3P mainboard, which uses a Realtek Azalia ALC887 on-board sound system. I have no loudspeakers and listen to the computer sounds exclusively...
Hello all, I just got Windows 8.1 Pro as a gift from a friend and installed it just a few hours ago, and I noticed that I am having audio problems. Basically put, it's sort of random when this happens, but it seems to happen when sounds play rapidly, as letting a audio que play it's part will...
I don't know if any of this is related, but I wanted to provide as much information as I could for you gurus to deal with. So here's what happened: I left my ASUS K55A laptop in sleep mode. I opened the lid to wake it up, logged in, and then everything started to load really slowly. This hasn't...
No audio input and output in Sound & Audio
Well, things went on until noon yesterday, but suddenly My PC takes no audio input or gives any output. I have tried reinstalling driver, checking mute button, checking Cables etc, none of the audio devices work on my PC which work in other devices. On opening realtek audio manager and playing...
i have installed windows 8 pro 32 bit . but the probelm is faced . the audio service is runing in both sides, when i am plugging the headset the sound is coming in both sides I mean that in headset and also in loudspeakers. i want to play sounds only on headset when i plug the headset ,...
Hi all, I'd be grateful for any advice to my problem.... Last month I bought a new PC, a Dell XPS 8500 with an Intel Core i7-3770 processor. The PC has onboard audio (Realtek High Definition Audio). I didn't buy new speakers as I have a perfectly usable set of Creative 6.1 speakers. My...
I have already tried a lot of different drivers, including the one provided by the asus website (For win 7) and the other provided by the realtek website, but i still have the error that no audio devices are installed. Any help? Thanks in advance
Eight Forums Android App Eight Forums IOS App Follow us on Facebook