Windows 8 and 8.1 Forums

No sound device and won't let me install one!

  1. #1

    No sound device and won't let me install one!

    I get the error attached.

    Click image for larger version
    However, devices show up in device manager.

    Click image for larger version

    When I try to re-install the driver from the dell site, the installation fails. Here is the error log:

    [05/29/13 12:32:09] Update Package Execution Started
    [05/29/13 12:32:09] Original command line: "C:\Users\Cathleen\Documents\Dell Downloads\9ef71118-f3dd-4d85-90ac-914583774eb1\Audio_Driver_G22H1_WN_6.0.1.6662_A01.EXE"
    [05/29/13 12:32:09] DUP Framework EXE Version:
    [05/29/13 12:32:09] DUP Release: G22H1X00-00
    [05/29/13 12:32:09] Intializing framework...
    [05/29/13 12:32:10] logo.png
    [05/29/13 12:32:12] User Command: attended
    [05/29/13 12:32:12] DUP Capabilities Value: 16777215 (0xFFFFFF)
    [05/29/13 12:32:12] DUP Vendor Software Version:
    [05/29/13 12:32:12] Local System/Model Compatible with this Package? Yes
    [05/29/13 12:32:12] Local System OS Version:
    [05/29/13 12:32:12] OS Compatible with this Package? Yes
    [05/29/13 12:32:12] Local System OS Language: EN
    [05/29/13 12:32:12] Language Compatible with this Package? Yes
    [05/29/13 12:32:57] Identified Behavior : attended
    [05/29/13 12:32:57] Temporary payload log file name: C:\ProgramData\dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01\DUP6DF0.tmp
    [05/29/13 12:32:57] Translated Command Line : DELLMUP.exe /v" LOGFILE="C:\ProgramData\dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01\DUP6DF0.tmp""
    [05/29/13 12:32:57] Path : C:\ProgramData\dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01
    [05/29/13 12:32:57] Identified Behavior : attended
    [05/29/13 12:33:00] Append Vendor Software Log: C:\ProgramData\dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01\DUP6DF0.tmp
    [05/29/13 12:33:00]
    --- Start of Vendor Software Log ---

    [05/29/13 12:33:00] ASCII payload log file detected.
    [05/29/13 12:33:00] ==================================================================================================== ==================================
    Realtek High Definition Audio Driver update package
    ==================================================================================================== ==================================
    Command : "C:\ProgramData\Dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01\DELLMUP.exe" /v" LOGFILE="C:\ProgramData\dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01\DUP6DF0.tmp""
    Date : 2013-5-29 27:32:57.636
    User : Cathleen
    ==================================================================================================== ==================================
    Starting to get initial ...
    [OS] : 6.2
    -Build : 9200
    -Service Pack : 0
    -x64 system : 1
    -MCE system : 0
    -Server system : 0
    -System Language ID : 0x0409
    -User Language ID : 0x0409
    [Default Path] :
    -tcRtkTempDir : C:\ProgramData\Dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01
    -tcISSetupLocation : C:\ProgramData\Dell\drivers\Audio_Driver_G22H1_WN_6.0.1.6662_A01

    Collecting inventory ...
    Checking driver version...
    The version of this update driver is equal to the currently installed version .
    [Realtek HD Audio Driver]
    Installed version :
    Package version :

    ==================================================================================================== ==================================

    [Update Result]...
    Update ready to be applied at reboot .
    Rtk Code = 0x00000000
    IS Code = 0x00000000
    Install Result = 0
    UPD execution code =
    SetupAPI running code =

    Exit Code = 0003 ( Dependency software error )
    ==================================================================================================== ==================================
    End : 2013-5-29 27:32:58.56

    [05/29/13 12:33:00]
    --- End of Vendor Software Log ---

    [05/29/13 12:33:00] Vendor Software Return Code: 3
    [05/29/13 12:33:01] logo.png
    [05/29/13 12:33:01] Name of Exit Code: DEP_SOFT_ERROR
    [05/29/13 12:33:01] Exit Code set to: 3 (0x3)
    [05/29/13 12:33:01] Result: FAILURE
    [05/29/13 12:33:05] Open file: C:\ProgramData\Dell\UpdatePackage\Log\Audio_Driver_G22H1_WN_6.0.1.6662_A01.txt

    This is driving me nuts! I would very much appreciate any help on how to fix my sound. I am running Windows 8 on a Dell Inspiron.

      My System SpecsSystem Spec

  2. #2

    That error suggests that there is no default audio playback device set. The "Speakers" should be set as the default playback device.
    This is done in the Sound Panel, Playback section. I'm not on a Win 8 machine right now so I can't tell you how to access the Sound Panel.

    Also, you should only have one entry for RealTek. Uninstall one of the RealTek entries in the Device Manager.
      My System SpecsSystem Spec

  3. #3

    When I go to the sound panel, here is what I see. Everything is grayed out that might allow me to add a device.

    Click image for larger version
    I did remove the second instance of the Realtek card. The first one states the driver is up to date, and that the device is working properly.
      My System SpecsSystem Spec

  4. #4

    There are several possibilities.

    The first step, since you removed the second RealTek entry in the Device Manager is to just reboot the PC and see if it works.

    If not, there could be a Windows status corruption between the sound and Windows that was caused by the dual RealTek entries. Go to the Device Manager, and uninstall the RealTek, but DO NOT uninstall the drivers. Restart the PC and when Windows starts it will detect and reinstall the sound. Then go to the Sound Panel/Playback section and see if the "Speakers" are shown. If they are make them the default Playback device. If still not shown, RIGHT click in an empty space in that panel and check the boxes to show disabled and disconnected devices. If the Speakers now show up you can set them as the default.
      My System SpecsSystem Spec

  5. #5

    Fireberd, you're awesome. I uninstalled Realtek, rebooted and voila, sound! I didn't have to do anything else. Thank you!
      My System SpecsSystem Spec

  6. #6

    Thanks for the feedback that it worked. Glad to have helped. Please "rep" me by clicking on the "thumb up".
      My System SpecsSystem Spec

No sound device and won't let me install one!
Related Threads
Hi, I have been having sound problems with the speakers on an HP Ultrabook. There are times when the laptop speakers stop working. When this occurs, I go to Control Panel>Sound, select the speakers(only one set to select), select Configure and Test. After selecting Test, I receive the message...
Hi, While exploring Device Manager today in my Win 8.1 system I discovered I had three entries listed under Sound, Video and Game Controllers: (1) AMD High Definition Audio Device (2) CyberLink WebCam Virtual Driver (3) Realtek High Definition Audio Every now and then when my...
Hi all. In terms of gaming, hardware and things like that, I am pretty experienced. This one has me stumped. I have searched places I know that might have a fix, but found nothing helpful. I recently purchased a Plantronics Gamecom headset, and am really enjoying it, but there is one...
Just turned my PC on and I keep getting a Windows 8 Device Connect sound every 4-6 seconds.. no USB or anything wired connected to my PC for it to give me this sound?
So I was doing some uninstall housekeeping because of an issue with another program when apparently I accidentally deleted my audio device. I believed this to be Realtek so I went to the website and downloaded their free 64 bit version. BTW I'm running windows 8.1. The device manager doesn't show...
Whenever I'm in the Windows environment (meaning not doing anything in full-screen mode), the "Device Eject Sound" (the little do do do do that plays whenever you eject a device) will constantly play at almost random. Sometimes itll play three times in a row right after the other, sometimes it wont...
Hi, At every start-up there is ether a Device Disconnect sound or a Device Connect sound that gets interrupted by a Device Disconnect sound. This happens on every start-up, after almost everything is loaded. P.S. There are no Yellow !-s in the device manager.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook