Windows 8 and 8.1 Forums


Dell Cirrus Audio error

  1. #1


    New Hampshire
    Posts : 77
    windows 8 enterprise x64

    Dell Cirrus Audio error


    Hello all,
    I have been trying to resolve this error for days now. I have updated audio drivers, rolled them back, uninstalled / reinstalled and still get this error everyday on bootup. I dont have any noticeable issues with my sounds, it's just unsettling having this in my event viewer...any thoughts?



    Log Name: Application
    Source: CirrusAudioService
    Date: 3/25/2013 6:27:55 AM
    Event ID: 0
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: scottie
    Description:
    Service cannot be started. System.TypeLoadException: Could not load type 'CirrusLogicSquared.LogicSquared' from assembly 'LogicSquared, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
    at CirrusService.ServiceContractImpl..ctor()
    at CirrusService.CirrusService.CreateServiceHost()
    at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="CirrusAudioService" />
    <EventID Qualifiers="0">0</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-25T10:27:55.000000000Z" />
    <EventRecordID>16446</EventRecordID>
    <Channel>Application</Channel>
    <Computer>scottie</Computer>
    <Security />
    </System>
    <EventData>
    <Data>Service cannot be started. System.TypeLoadException: Could not load type 'CirrusLogicSquared.LogicSquared' from assembly 'LogicSquared, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
    at CirrusService.ServiceContractImpl..ctor()
    at CirrusService.CirrusService.CreateServiceHost()
    at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)</Data>
    </EventData>
    </Event>

      My System SpecsSystem Spec

  2. #2


    Can you be more specific on which Insprion 15 you have. There are many different Dell versions of this model.

    I looked at one I15 (1545) and it does not list Cirrus.
      My System SpecsSystem Spec

  3. #3


    New Hampshire
    Posts : 77
    windows 8 enterprise x64


    thanks for the reply...it's a dell I15 3520...dual core 1.7, 4 gb ram, windows 8 enterprise (preloaded). I have cirrus logic hd audio (pre loaded from dell ) see attached....
    Attached Thumbnails Attached Thumbnails devicemgr.png  
      My System SpecsSystem Spec

  4. #4


    As it is working, just that you are getting the error at bootup, suggests a corruption between Windows and the driver software.

    Two things to try.
    (1) Go to the Device Manager, RIGHT click on the Cirrus entry to highlight it and then LEFT click "Uninstall". DO NOT check the box to also uninstall the drivers. Restart the PC and when Windows starts it should detect and reinstall the sound.
    (2) If the uninstall/reinstall as noted in (1) does not fix it, do the uninstall but also check the box to uninstall the drivers. Then when you restart, Windows will probably detect it and install the generic HD Audio Codec. After that is done install the Dell provided Cirrus sound driver and see if that corrects it.

    Driver Details | Dell US

    If this does not fix it, suggest you repost on the Dell Laptop users helping users forum for additional help.
    Laptop - Dell Community
      My System SpecsSystem Spec

  5. #5


    New Hampshire
    Posts : 77
    windows 8 enterprise x64


    Thank you very much for your time and effort. I will be trying your suggestions now. I will report back no matter the out come.
      My System SpecsSystem Spec

  6. #6


    New Hampshire
    Posts : 77
    windows 8 enterprise x64


    I tried both suggestions and still have the same error. I'm off to the dell forum to see if anyone else is having this problem. Thank you again for your help
      My System SpecsSystem Spec

  7. #7


    I looked on the Dell Laptop Hardware forum and didn't see your post, if you posted as you said. I was going to monitor it over there.
      My System SpecsSystem Spec

Dell Cirrus Audio error
Related Threads
Solved Dell Backup and Recovery Error? in Installation & Setup
Hey guys, longtime user of Sevenforums, here with a question about a computer I am fixing for a co-worker. Specs: Dell XPS 12 Ultrabook Windows 8.1 Intel Core i5-3337U 1.8 GHz 4 GB RAM 128 GB SSD Trying to use the Dell Backup and Recovery Option to get this back to factory settings for...
I have Dell venue 8 pro having windows 8.1 , 32 bit version with 2GB memory. When I start dataram program(same version 4.3, which works in my laptop having 8GB memory) as admin and with settings as 11 MB as ram disk and fat16 partition, do start ramdisk, drivers are installed and when starts...
Ok so i have searched here and also on google to find out what to do. Everywhere people say download the vista 64bit or windows 7 64bit drivers and install. Then people say that worked.. for me I get an error that the software wont run on my machine. is there a trick to getting windows 8 64bit...
Hi all, I'd be grateful for any advice to my problem.... Last month I bought a new PC, a Dell XPS 8500 with an Intel Core i7-3770 processor. The PC has onboard audio (Realtek High Definition Audio). I didn't buy new speakers as I have a perfectly usable set of Creative 6.1 speakers. My...
I hae a dell m1710, installed win8 rtm on it. In win 7 i have 2 options of digital audio out: 1. Turtle Beach Audio Advantage Micro usb with optical S/PDIF out 2. Dell composite video adapter with digital coax out. Sigmatel high definition audio codec In win 8 i tried first the Audio...
Hello All, I thought I would post an interesting Installation of Windows I did on my Dads 2006 Dell Inspiron 6000. I am posting it in the Drivers section because Dell never made a Audio driver for the Inspiron 6000 past Windows XP. I had to do this trick for Widows 7, so I thought I would try...
I have installed Windows 8 Customers Preview and found that whenever I connect my Sony Headphones to my Dell Inspiron 15R laptop sound is coming from both the headphones and the Internal Speakers. I reinstalled the IDT audio driver then also the problem remains the same. Could any one give me the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook