Windows 8 and 8.1 Forums


Problem with Sound I am using Logitech s120 speakers.

  1. #11


    k one moment let me try

      My System SpecsSystem Spec

  2. #12


    should i also delete the Processor AMD drivers??
      My System SpecsSystem Spec

  3. #13


    disregard last reply.. Should i also uninstall my AMD Processor drivers??
      My System SpecsSystem Spec

  4. #14


    The Netherlands
    Posts : 87
    Android, BSD, iOS, Linux, Mac OS X, Microsoft Windows


    No, I didn't expect you to have that. Clever one, leave those the way they are. To be more precise, do you even have an AMD GFX card?

    EDIT:
    Sorry, re-read your first post. You have one, make sure you delete that one too.
    And, check your installed programs for the catalyst control center, make sure it is not installed. Else, uninstall it.
      My System SpecsSystem Spec

  5. #15


    I have no clue what a clean install even is. and Sound is still not working. All that comes out is static that sounds somwhat like the music im trying to play. and i've already checked if the speakers work on another computer. and they do, should i go back into device manager and uninstall all 6 of the Processor drivers as well as all other amd drivers and try this process again? is there any reason that it would give me better results?
      My System SpecsSystem Spec

  6. #16


    The Netherlands
    Posts : 87
    Android, BSD, iOS, Linux, Mac OS X, Microsoft Windows


    Are you sure the input is working correct? Have you tried plugging in earphones?
      My System SpecsSystem Spec

  7. #17


    I have tried plugging earphones in to both the speakers and directly into my computer and i get the same result./ My logitech headset works just fine although i have no clue if that helps.
      My System SpecsSystem Spec

  8. #18


    The Netherlands
    Posts : 87
    Android, BSD, iOS, Linux, Mac OS X, Microsoft Windows


    if it's inserted in the same hole, yeah it does. Because if that's the case, your drivers are functioning normal. Can you try to plug in your speakers again and slowly try to pull it out while there is music playing..? It might be a hardware problem. It could be that when it's half out, the thing works perfectly. In that case it's broken.
      My System SpecsSystem Spec

  9. #19


    ok let me try.. and the Logitech headset is inserted to a usb port not the back of the comp.// k it doesn't play when half way in and the music is somewhat more discernible now it just has waaaay to much static for me to be able to use
      My System SpecsSystem Spec

  10. #20


    The Netherlands
    Posts : 87
    Android, BSD, iOS, Linux, Mac OS X, Microsoft Windows


    so switching works fine, your driver is sending the right signal, my guess is that the jack is indeed broken.
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
Problem with Sound I am using Logitech s120 speakers.
Related Threads
this is my latencyMon screens 54926 54927 please give me steps what should i do
No sound from speakers in Sound & Audio
Hi. Just got my Acer Aspire E5 572g back from repair at Acer Repair Center. They switched out my prosessor, but now i got no sound. The computer came back with a clean install og win 8.1. Added a screenshot showing drivers and that sound is "playing"...
Hello, I have a Logitech G230 Headset I absolutely love them, but the microphone has too much gain. If I lower it down to DVD quality there is none, however I would very much enjoy having the highest quality possible without gain (Hopefully studio). Also the mic is too low when I do not have the...
No sound from speakers in Sound & Audio
Latest version of W8 This will take a while A few months ago W8 quit producing sound through my speakers - overnight. I've tried a number of things I'll list here. Volume Control - red 'x' in bottom right corner. AMD HDMI OUTPUT and HEADPHONES are checked. Troubleshooting Speakers/headphones...
Ghost sound/speakers.. in Sound & Audio
Hey guys So this is a weird one... I have a Xonar D2 sound card, and the Xonar D2 Audio Centre, all sound thru my speakers and headphones fine. All music, games, skype are heard and picked up on the D2 Audio Centre just fine. HOWEVER When I open the Volume mixer, almost every program I have...
Well this has gone for a few weeks and I had my laptop for about a year now. The problem is after watching 3-4 videos, the sound will not work on the next file. I tried restarting and it worked! But after another 3-4 videos, there was no sound again. Another thing is when I open a music file, it...
I have 2 speakers plugged in on m motherboards audio jacks, and my G110 keyboard has sound card of it's own built in. I was wondering if there was any way to set it up the way I want it, or something similar to it. The keyboard has a headphone mute button of its own. So I was thinking that I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook