Windows 8 and 8.1 Forums

c++ broken

  1. #1

    c++ broken


    So I was complaining about c++ runtime errors w/ shootmania and stuff.
    Turns out the problem is much deeper. I tried downloading visualstudio express 2012 for windows 8
    Download | Microsoft Visual Studio 2012

    even though I usually just use cyg and g++

    I launch it and instantly I get
    "Microsoft Visual Studio Express 2012 for Windows 8 - EN has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."


    If I hit Debug all it says is "A problem caused the program to stop working correctly Windows will close the program and notify you if a solution is available."

    Evenlong info
    Code:
    Faulting application name: win8express_full.exe, version: 11.0.50727.1, time stamp: 0x4fd9f28cFaulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x06ecef70
    Faulting process id: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report Id: %13
    Faulting package full name: %14
    Faulting package-relative application ID: %15
    Code:
    Fault bucket -986310862, type 5Event Name: BEX
    Response: Not available
    Cab Id: 0
    
    
    Problem signature:
    P1: win8express_full.exe
    P2: 11.0.50727.1
    P3: 4fd9f28c
    P4: StackHash_5861
    P5: 0.0.0.0
    P6: 00000000
    P7: PCH_29_FROM_ntdll+0x00041318
    P8: c0000005
    P9: 00000008
    P10: 
    
    
    Attached files:
    C:\Users\JigglyWiggly\AppData\Local\Temp\WER3E74.tmp.WERInternalMetadata.xml
    
    
    These files may be available here:
    C:\Users\JigglyWiggly\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_win8express_full_7f73391121f4666542e8b4e2ffe7bd1fa42ad5a_3bb59fbf
    
    
    Analysis symbol: 
    Rechecking for solution: 0
    Report Id: 98fe70c0-0c60-11e2-be88-c86000ed047e
    Report Status: 0
    Hashed bucket: 8aa67645150eb5738101d9d98516a21a

    here's that internationaldata.xml file
    Code:
    <?xml version="1.0" encoding="UTF-16"?>-<WERReportMetadata>-<OSVersionInformation><WindowsNTVersion>6.2</WindowsNTVersion><Build>9200 </Build><Product>(0x30): Windows 8 Pro</Product><Edition>Professional</Edition><BuildString>9200.16384.amd64fre.win8_rtm.120725-1247</BuildString><Revision>Unknown</Revision><Flavor>Multiprocessor Free</Flavor><Architecture>X64</Architecture><LCID>1033</LCID></OSVersionInformation>-<ProcessInformation><Pid>12684</Pid><ImageName>win8express_full.exe</ImageName><CmdLineSignature>00000000</CmdLineSignature><Uptime>1951</Uptime>-<ProcessVmInformation><PeakVirtualSize>303435776</PeakVirtualSize><VirtualSize>286846976</VirtualSize><PageFaultCount>13390</PageFaultCount><PeakWorkingSetSize>42508288</PeakWorkingSetSize><WorkingSetSize>42508288</WorkingSetSize><QuotaPeakPagedPoolUsage>474928</QuotaPeakPagedPoolUsage><QuotaPagedPoolUsage>440400</QuotaPagedPoolUsage><QuotaPeakNonPagedPoolUsage>41784</QuotaPeakNonPagedPoolUsage><QuotaNonPagedPoolUsage>41112</QuotaNonPagedPoolUsage><PagefileUsage>47992832</PagefileUsage><PeakPagefileUsage>48021504</PeakPagefileUsage><PrivateUsage>47992832</PrivateUsage></ProcessVmInformation>-<ParentProcess>-<ProcessInformation><Pid>16604</Pid><ImageName>chrome.exe</ImageName><CmdLineSignature>00000000</CmdLineSignature><Uptime>69149714</Uptime>-<ProcessVmInformation><PeakVirtualSize>998006784</PeakVirtualSize><VirtualSize>829546496</VirtualSize><PageFaultCount>26834132</PageFaultCount><PeakWorkingSetSize>485445632</PeakWorkingSetSize><WorkingSetSize>449064960</WorkingSetSize><QuotaPeakPagedPoolUsage>1241112</QuotaPeakPagedPoolUsage><QuotaPagedPoolUsage>898528</QuotaPagedPoolUsage><QuotaPeakNonPagedPoolUsage>1088496</QuotaPeakNonPagedPoolUsage><QuotaNonPagedPoolUsage>203760</QuotaNonPagedPoolUsage><PagefileUsage>374800384</PagefileUsage><PeakPagefileUsage>394567680</PeakPagefileUsage><PrivateUsage>374800384</PrivateUsage></ProcessVmInformation></ProcessInformation></ParentProcess></ProcessInformation>-<ProblemSignatures><EventType>APPCRASH</EventType><Parameter0>win8express_full.exe</Parameter0><Parameter1>11.0.50727.1</Parameter1><Parameter2>4fd9f28c</Parameter2><Parameter3>unknown</Parameter3><Parameter4>0.0.0.0</Parameter4><Parameter5>00000000</Parameter5><Parameter6>c0000005</Parameter6><Parameter7>06b2dcf0</Parameter7></ProblemSignatures>-<DynamicSignatures><Parameter1>6.2.9200.2.0.0.256.48</Parameter1><Parameter2>1033</Parameter2></DynamicSignatures>-<SystemInformation><MID>81D30A4B-D6CF-428B-A7E4-B6A4BDADA6ED</MID><SystemManufacturer>System manufacturer</SystemManufacturer><SystemProductName>System Product Name</SystemProductName><BIOSVersion>1504</BIOSVersion><OSInstallDate>1347072900</OSInstallDate></SystemInformation><DAMInformation> </DAMInformation></WERReportMetadata>



    Any help?

      My System SpecsSystem Spec

  2. #2


    Posts : 1,925
    Windows 8.1 Pro


    Sounds like something is corrupt in your system. Try doing a system restore to an earlier point in time, or to right after you installed it.
      My System SpecsSystem Spec

  3. #3


    always had c++ issues with windows 8
    this is from an upgradefrom windows 7, where C++ was fine. I know this because all my programs were working.
    I am trying to install visualstudio, so I never installed it yet.

    I am not too eager to do a clean install though.
      My System SpecsSystem Spec

  4. #4


    Posts : 636
    Windows 7/8


    Never upgrade... ever.

    You want a well running system you HAVE to clean install.

    It's particularly bad when you have some insanely tweeky stuff like dev environments installed.
      My System SpecsSystem Spec

  5. #5


    Isn't there like a repair I can do or something? I mean I can't be the only person with C++ issues.


    EDIT: Oh wow... the issue also is happening on my laptop. How is this even possible? How can C++ be broken on both machines?

    They were both upgraded.
      My System SpecsSystem Spec

  6. #6


    Posts : 1,925
    Windows 8.1 Pro


    More than likely, you installed the same program on both computers that corrupted your system files.
      My System SpecsSystem Spec

  7. #7


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Quote Originally Posted by jigglywiggly View Post
    Isn't there like a repair I can do or something? I mean I can't be the only person with C++ issues.


    EDIT: Oh wow... the issue also is happening on my laptop. How is this even possible? How can C++ be broken on both machines?

    They were both upgraded.
    Seems there are some problems there. I use VS 2010 and C++ is ok there. Oh, the dev os is running in a VM now, I also had problems on the main machine even in VS 2010: something corrupted after sp1 (what a mess) and I wasn't able to build any projects.

    g++ x64 is running well here also.

    Quote Originally Posted by FSeal View Post
    Never upgrade... ever.
    Quote Originally Posted by FSeal View Post

    You want a well running system you HAVE to clean install.

    It's particularly bad when you have some insanely tweeky stuff like dev environments installed.

    Hence the dev os is running as VM: when you got problems, you easily restore from backup/snapshots.


      My System SpecsSystem Spec

  8. #8


    so i just reformatted
    everything works now
    guess microsoft didn't work very hard on the upgrade option =/
      My System SpecsSystem Spec

c++ broken
Related Threads
is my pc broken in General Support
I was using my dell inspiron 2330 earlier when it said it needed to reboot when it did this it started scanning and repairing drive c it did this 10 times when i managed to get into bios it gave me error code 2000-0142 i managed to log in but now my screen kept flashing then said hard drive error ...
Although it appears to work (screen dims briefly), there's no sign of any screenshot in Libraries, or indeed anywhere else. Is it broken, or is it just me? Doing it the 'old' way via MS Paint still works. Wenda.
Windows FAX broken in 8.1 in Software and Apps
Still broken. FAX send will hang/redial. Didn't work in 8.1PV - may have functioned in 8. The problem is FXST30.dll. Replacing it with the Windows 7 copy resolves it. This may require taking ownership. Someone here with Microsoft's ear might pass that along to the higher echelon.
UAC off, metro broken in Software and Apps
Hi All,Got a brand new windows 8 laptop, loaded solidworks onto it, no go. Google tells me I must turn off UAC for solidworks to work properly on windows 8. No problem, turn UAC off, solidworks is fine. Except now the metro screen is useless, not a single program (tile? app?) works, they all...
Windows 8 OS broken in BSOD Crashes and Debugging
I have a Dell Inspiring 15r and yesterday it started running extremely slow. I realised that installed software had restarted the laptop while it was in the middle of an important windows update. After a few attempts to fix it I'm stuck with nothing. Now when booting up I get to a screen...
Win 8 BROKEN! NEED HELP in General Support
My laptop was running slow so I tried the new 'refresh' option, wrong decision. Windows 8 loaded it and finished it, when it restarted the blue windows logo showed and said please wait for about 5 seconds and then the screen goes black but I can move the mouse around. I desperately need help with...
I'm not a big fan of the gadgets that ship with Window releases. Instead I tend to pick up a few from third party sources such as Addgadget.com or OrbLog Sidebar Gadgets. However, since I upgraded to the CP from DP, most of these third party gadgets are working properly. One of my...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook