Windows 8 and 8.1 Forums

7-ZIP and administrator rights problem.

  1. #11

    New Jersey
    Posts : 114
    Windows 8.1 Pro X64

    As I stated in my first couple of posts made when I installed W8 the first time I had problems extracting a firefox zip build to the firefox folder in program files(x86). I eventually discovered that I had to give Admin rights to 7zFM.exe. I had to do the same thing this time around for my W8 install. For good measure I gave the other two executables Admin rights also.

    That's about all I did. I just can't get the 7-Zip context menu in Explorer to do any options on the menu. Either nothing happens or I get the 'elevated' message.

      My System SpecsSystem Spec

  2. #12

    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64

    Have you tried the 9.22 yet?

    Or you probably want the speed improvements for Ivy Bridge in the latest alpha.

    This is 7-zip 9.22 on Win8 RTM x64:
    Click image for larger version
    -The Windows theme is from RP version, I said it just to avoid confusion.
    -The 7zip theme is my own, for the rest, original 9.22 version.
    -I ran 7z as admin just to assign it to its format (see icon left)
    -The shell commands in the right click menu work, I just removed the e-mail links with in the options just to prove it works, and I don't need those.

    So I think it has to be new code in the alpha that still needs some testing. I'm not gonna use it until it becomes more stable.
    Win8 is also on Ivy Bridge here and for the moment 7z has been stable.
      My System SpecsSystem Spec

  3. #13

    New Jersey
    Posts : 114
    Windows 8.1 Pro X64

    I tried v9.20 and it does the same thing. Also as I said, I had v9.30 alpha working on my old install of W8 Pro x64 so it's not a problem with the alpha version in my case.

    I tried a couple of other similar products and they all worked fine. None of them required me to do anything regarding security rights. Why the heck do I have to it with 7-Zip? Never had this problem with W7 btw.
      My System SpecsSystem Spec

  4. #14

    Posts : 7
    8x64 | 10x64

    Quote Originally Posted by streetwolf View Post
    .... Why the heck do I have to it with 7-Zip? Never had this problem with W7 btw.
    Yep. Went through <exactly> the same steps trying to find an answer, found none. And years later, we're still here in 2012.
      My System SpecsSystem Spec

  5. #15

    Posts : 1
    Windows 10 Pro

    Through trial and error, here's how I fixed it in order:
    1. Uninstall (using uninstaller in the 7z folder) -> Restart PC -> Re-install
    2. Run this program as administrator for 7z.exe, 7zFM.exe, 7zG.exe
    3. Ran CCleaner, analyzed & cleaned 7z
    4. Disabled Run this program as administrator for 7z.exe BUT the privilege remained active -> error gone, able to use the program normally

    I hope that helps.

    If anyone knows what actually happened, do inform. I'm interested.
      My System SpecsSystem Spec

  6. #16

    WinRar rocks, never had a problem and has everything. Workin great on 8.1 pro
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
7-ZIP and administrator rights problem.
Related Threads
administrator rights in General Support
First of all my computer skills are just average. Sometimes when doing certain things. It says I need administrator rights. ( Windows 8 ) Whats the easiest way to do this? Also the things I heard on ( You Tube ) is not to leave administrator rights allways on. Hackers will mess with...
I am getting error "Save failed - Please check if this file is opened in another program" when trying to edit the hosts file in Notepad++. This has only started happening after a fresh installation of Windows 8 on a new computer. My previous computer with Windows 8.1 was able to do it correctly...
Win 8.1 Pro x64, single-user computer. I don't know if it started with updating from 8 to 8.1 in December, but roughly since then I've getting been a fair number of error messages while saving or changing a program's default setting, saying directly or indirectly that I need administrator rights...
Solved Administrator rights for software in Standard account in User Accounts and Family Safety
Hi, I'm currently using Windows 8.0. Would like to check if it is possible to allow a particular software to be run as Administrator, even when I am using a "standard account", without the need to enter the administrator password everytime I open it? Essentially like making an exception to allow...
Good day all, I've done a quick search (here and google) but can't find a solution for the following: Windows 8 pro: I have a user account with admin rights. It used to work fine till one day, after rebooting, I had no tiles in the start view. I ran chkdsk and it seems to have fixed the...
Admin rights problem in User Accounts and Family Safety
I have windows 8. I recently restored my laptop to factory settings. I entered my microsoft account to make a user, and this was an admin. I created another user, went to control panel, and made my first account standard, and my new account admin. The account I changed to standard still acts...
lost all administrator rights... in User Accounts and Family Safety
A couple of days ago i noticed that my C: Drive doesnt have its usual name and i cant access it, now its just Local Disk C. the PC work fine, except for the fact that i cant install anything, or open anything that requires admin rights. I cant perform a factory reset from the "advanced tools" menu,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook