Windows 8 and 8.1 Forums

WMP Codec Problem

  1. #1


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64

    Windows 8 Black Screen on Videos


    Hello everyone,

    Been using sevenforums for years and I can only say I feel safer knowing that eightforums is here too.
    I didn't know where to post this thread as I expected some kind of media board, so I'll just do it here and feel free to move it to the appropriate place.

    I recently installed the Windows 8 Enterprise Evaluation. As a matter of fact, I still got 86 days left.
    I can't remember what I did exactly right after I was presented with the new start menu and all, I remember I was excited. One of the first things I did was to install the K-Lite Codec Pack. I expected everything to be fine, my Media Player Classic worked as it was supposed to (although I had to configure it a bit). However, I tried Windows Media Player too but I got a black screen in every video I tried. I really came to like WMP recently and I need it functional at all costs. So I removed all the codecs, installed a different one, Shark007's this time, as I was advised that it's better. Still nothing. I like VLC but I hate having to start it up and be forced to play my videos there. I need my WMP back.

    I have considered resetting my windows to factory settings but I'm too reluctant. I'm using my Windows Live ID as a user, will my apps and settings return once I reconnect? Would it worth a try?

    I have updated my GPU drivers to the latest version possible, I haven't touched anything audio related since WMP plays audio fine but not video.

    I am looking forward to any replies that can help solving this problem.

    Thank you for your time.
    Last edited by Wael90; 15 Sep 2012 at 18:43.

      My System SpecsSystem Spec

  2. #2


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    Uninstall any codec pack you have, then try to play a generic movie file. Tell me if it can play. If it can't then the problem is not with the codec packs, but with something else.
      My System SpecsSystem Spec

  3. #3


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by eXcite View Post
    Uninstall any codec pack you have, then try to play a generic movie file. Tell me if it can play. If it can't then the problem is not with the codec packs, but with something else.
    I haven't tried this yet but I noticed something interesting. While applied Office 365 Consumer Preview, the installer was supposed to show me an introduction video. However, I also got a black screen there, in the set-up window. So I guess the problem is that my Windows are not recognizing the codecs or not even seeing them at all? I also had to configure all my 3 browsers to be able to watch anything online.

    By generic, you mean MP4, AVI, WMV? I tried MP4 and AVI with no luck when I had no codec packs at all.
      My System SpecsSystem Spec

  4. #4


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    Yes, MP4, AVI, WMV. Try those without codec packs and see if they play.
    On a side note, I have heard that some of the TechNet/MSDN ISOs are messed up. I don't know if that had anything to do with this, but videos are working fine on my computer.
      My System SpecsSystem Spec

  5. #5


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by eXcite View Post
    Yes, MP4, AVI, WMV. Try those without codec packs and see if they play.
    On a side note, I have heard that some of the TechNet/MSDN ISOs are messed up. I don't know if that had anything to do with this, but videos are working fine on my computer.
    That's the ISO file I downloaded.

    HRM_CENA_X64FREE_EN-US_DV5

    I'll try a WMV file (it's the only one I haven't tried) and update my post shortly.

    Thanks.
      My System SpecsSystem Spec

  6. #6


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    I removed any codec packs and tried again with any generic files, this time including WMV.
    A friend of mine gave me the link to this ISO as he downloaded it himself and it was working properly. Can you confirm it's alright?
    I'm also using a Sony Vaio. I appreciate the help and thank you for your time.

    Sorry for double posting.
      My System SpecsSystem Spec

  7. #7


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    No problem. The problem is I have the leaked version of Enterprise, not the 90-day trial. I thought of something, do all your drivers support Windows 8? I have a problem where the video card drivers are installed, but Minecraft crashes because it says my drivers are bad. The drivers don't have full support for Windows 8.
      My System SpecsSystem Spec

  8. #8


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by eXcite View Post
    No problem. The problem is I have the leaked version of Enterprise, not the 90-day trial. I thought of something, do all your drivers support Windows 8? I have a problem where the video card drivers are installed, but Minecraft crashes because it says my drivers are bad. The drivers don't have full support for Windows 8.
    I just reformatted, I couldn't take it. And well, no progress. I was missing a few undetermined drivers but I had the GPU ones up to date. Well, at least that's what they say. I'm hating my laptop right now. Do you think you could PM me the link of your Windows version? I would really appreciate it.

    Thanks.
      My System SpecsSystem Spec

  9. #9


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    Of course! I'll PM it to you now. It is a torrent though. Also:
    - It has 1000 rearms, with 180 days each.
    - A watermark pops up after 2 hours, restart explorer to fix that
      My System SpecsSystem Spec

  10. #10


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by eXcite View Post
    Of course! I'll PM it to you now. It is a torrent though. Also:
    - It has 1000 rearms, with 180 days each.
    - A watermark pops up after 2 hours, restart explorer to fix that
    PM received, I'll be burning it and formatting once I get it. I am grateful.

    Other than that, I'd really like to know if there's anyone else with such an issue. Or more suggestions on it. Thank you.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
WMP Codec Problem
Related Threads
Dear All Happy New Year to you! I have a problem with software asking for LUMIX RAW codec 64bit for windows 8.1 for my camera Panasonic Lumix FZ200. I cannot find this, only for 32 bit, but my PC is 64bit. I tried to install it anyway, but it was not accepted. Can anybody help me please?...
Hello, I've been trying to configure my brand new hp PC with Windows 8.1 pro to auto-sleep but I have been unable to do so. If it hit the power button or select sleep from the menu it will sleep, however. I ran powercfg/energy and it appears from the report that this is the issue: System...
Hello! Having a bit of a problem and trying to see if there is an easy solution. I have a Surface Pro and I want to watch some video on it. I wasn't able to find a specific video app that would play MKVs, but I did find Files&Folders which has a built in player that actually does! Been...
Indeo 5.x codec on W8.1 in General Support
Can someone confirm if that procedure works on 8.1 as well as W7 or 8? The command registers the .dll successfully, but I'm still getting an error message when trying to play those legacy .avi videos. Indeo 5.x codec - Windows 7 Help Forums Thanks!
I have a Windows 8 system and I am into video recording and burning onto dvd-r disc. My question is this: Should I install --> "K-Lite Codec Pack 10.15 (Full)" or "Windows 8 Codec Pack 2.0.1" Thank you so very much and any reply and help is greatly appreciated. God Bless, Artic
Like on Windows 7? I'd like to use the Windows 8 Video App to play FLV Files, but it seems like I'm gonna need to install Wondershare Player on W8 like I had on W7
Realtek HD Audio 2.68 audio driver download from Guru3D.com To easily install, go to device manager first. Then right click the Realtek audio, choose uninstall and also check the box to delete the driver. This saves you a reboot in the process to install. When you run the installer, it won't...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook