Windows 8 and 8.1 Forums

Net framework 4

  1. #1


    Posts : 24
    Windows 8 32 bit

    Net framework 4



    Hello one and all

    I tried a few programs that require net framework 3.5 or higher to work

    NFwork 4 is a part of the operating system and these programs wont install as they dont recognise it,

    I have tried installing the standalone version from microsoft but same result

    It is still telling me it wont install because a more up to date version is already installed, so why cant the software locate it, is it worth rebuilding the index, maybe its not indexed

    any ideas ??

    email me please PValentine1965@live.co.uk

      My System SpecsSystem Spec

  2. #2


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Normally Windows 8 asks you to install .net 2 + 3 and you need to be connected to the internet.
    The installation happens automatically.
    That's what happened on my pc, but I refused the install since I don't use such programs.
    You can still manually enable it on demand.

    Try to go here:
    Control Panel -> Programs and Features -> (on the left) turn Windows Features on or off:
    Click image for larger version
    And enable the (first) feature from there. Make sure you have internet access, Windows will take care from there.
    After a reboot or not (depends on the installer when ready), .Net 3.5 and lower should be enabled.

    That should be it.

    Good luck
      My System SpecsSystem Spec

  3. #3


    Posts : 24
    Windows 8 32 bit


    no already tried that and just for the sake of it tried it again, 4.5 is enabled but still wont install the lower version, there are others who have had the same problem I think its an error in the program

    I have tried the standalone version as well both direct from microsoft own site and through windows update
      My System SpecsSystem Spec

  4. #4


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    This doesn't look too good.

    Try sfc /scannow in an elevated command prompt and see if it fixes something. Then try enabling .Net 3.5 again.
    Don't know if it works (or if you tried it already) but let's hope it fixes something.

    Let's hope this is fixed in the final release.
      My System SpecsSystem Spec

  5. #5


    INDIA
    Posts : 148
    Windows 8 RP, Windows 7
      My System SpecsSystem Spec

  6. #6


    Posts : 24
    Windows 8 32 bit


    Thank you all I reinstalled windows 8 from a disc I made when I initially installed it and now its all good with framework 3.5

    still cant get video off windows media player 12 but the other stuff works now. also attempted to put windows 7 back on but it tells me that the system can no longer support it, despite it having windows 7 when I bought it pre installed

    it was a lot easier in the old days when you actually had the software with the computer on disc, , hint hint microsoft
      My System SpecsSystem Spec

Net framework 4
Related Threads
net framework in Software and Apps
when i try to install or activate net framework from the control panel i get the following error the feature could not be installed net framework windows cant connect to internet to download the necessary files i've ran sfc /scannow & Dism /Online /Cleanup-Image /RestoreHealth & they...
I have a windows 8 laptop and there is software that I need to install that requires that I already have Microsoft .NET 3.5 Framework. However, how do I determine if I have it on my laptop? I tried the instructions for Start, regedit, etc. and also looked in Control Panel, Program Features, but...
Microsoft net framework 3.5 in Software and Apps
Pls I bought an HP probook 4540s with windows 8 64bit preinstalled then I removed it and installed window 7 32bit I now discovered that my driver didn't install so I clean install the window8 again now my Microsoft net framework 3.5 did not install I need help pls my softwares are not installing
Can't install .NET Framework 3.5 in Windows Updates & Activation
I can't install .NET Framework 3.5 no matter what I do. I tried downloading it and in the midway get the error 0x800f0906. I tried installing through DISM but that didn't work either. It always stops at 65.8 %. Can somebody tell me how to fix it? It's really driving me nuts.
Solved .NET framework 3.5 problem ? in General Support
I tried to install .NET 3.5 Framework using windows 8 features (turn on or off). But the window is empty like in the attachment (Image1). when I tried to install from the Microsoft site it showed a window with two option of skip feature and preparing after that it was replaced by a window like...
Problem with .NET Framework 3.5 in Software and Apps
Hello!I have a problem with aplications requiring .NET Framework 3.5. When I try to run such an aplication, appears a box, which says that that function is needed to run this program. I can choose the option of downloading and installing it, but after a while appears an error that says that the...
Net Framework 3.51 in Windows Updates & Activation
I can't update NetFramework 3.5. Pls help.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook