Windows 8 and 8.1 Forums

Only one application goes into Not Responding

  1. #1

    Posts : 18
    8.1, 7, XP

    Only one application goes into Not Responding


    I have a custom built PC (about 3 months ago) running Windows 8.1 Pro with Gen 5 Intel chip (almost top of the line) with 32Gb and an SSD drive. I have one application that frequently, but not always, goes into a Not Responding mode and only in a very specific circumstance. Allow me to explain:

    The system was built specifically for trading and there are very few other applications installed, purposely to keep it as clean as possible. Defender is the AV and Windows is kept up to date with maintenance, within reason. One of these applications almost always fails when it attempts to shutdown which it does according to a set time. Because it is an auto trading application there is an interface to a broker site when it gets streaming stock data and will also open and close trades. I am not yet using the latter capabilities as I am only doing simulation trading. Every time the application goes NR it has always been in the interface to the brokers data feed and always at shut down time. The application has a "watchdog" service that starts and stops the main application. I've varied the shut down times and the NR moves with it.

    The software vendor states that I am the only one of "thousands" of users having this problem therefore it must be in my PC. Essentially he is not working on finding a solution because of limited resources and because I supposedly am the only one having this problem. He has offered to return my license fee but it's not about the money, although I will obviously take it if the problem can not be resolved. My options of having him look deeper are mostly limited.

    I have several other trading platforms, all of which need real time data and not a one of them ever goes into NR mode. One of the possibilities that I've considered is that because I have a high end system that there may be some sort of memory contention problem caused by being able to run multiple threads (up to 12) at the same time. Somehow, somewhere proper locks are not being used therefore there is (maybe) a situation that occasionally arises that causes memory contamination that some how causes the NR situation. I just recently though about setting CPU Affinity and limit the number of CPUs available to this application. Am I barking up the wrong tree here and should be looking elsewhere or doing something else?

    I really want to use the application and not want to give it up because I haven't looked deep enough. Other than this one problem the application runs fine and does what it supposed to do.

    Any suggestions are appreciated.
    Last edited by Cheech; 01 Aug 2016 at 16:54.

      My System SpecsSystem Spec

Only one application goes into Not Responding
Related Threads
Solved pc not responding in Installation & Setup
pc was not responding to any commands.. so thought i would do a reinstall, however when i get to the format part,, it says windows cannot be installed to this disk,, the disk is gpt partition style please
Some keys are not responding in Drivers & Hardware
Hello everyone, the 5,T,G,B keys on my Toshiba A55-P5200 have stopped working. I have done a system restore, even an upgrade, installed all keyboard updates but it still wouldn't work. I have tried opening it but i cant figure out how to remove the keyboard since i'm still troubleshooting. Can...
I am running Windows 8 Pro 64-bit. In the hidden folder "All Users" is a folder named "Application Data". Inside it is a folder named "Application Data". Inside that is yet another folder named "Application Data". This nonsense repeats itself to a depth of 16 folders, all named "Application Data"....
I have accidently set my .ext default program to Notepad and I want to change it back to an unknown application I have tried deleting it in regedit and it just sets it back to notepad even when I restart my computer afterwards any help would be much appreciated
Solved Tiles not responding in Software and Apps
My wife has a Toshiba Laptop with windows 8, upgraded to 8.1. About a month ago I set up Skype on her computer and all was working fine. Then 2 days ago she tells me it is not working. If you click on the tile, it tries to open, but after 3 second or so it goes back to the desktop. If I move the...
stops responding in Performance & Maintenance
Why do so many programs just stop working, stop responding for no apparent reason??? This includes IE9, e-mail service, new printer/scanner installation, etc, etc, etc. Sometimes even writing a letter or "Save as" just stops responding. How can this be??? Windows says "we're looking for a...
Microsoft Not Responding in General Support
After logging in, Windows will do next to nothing. Almost nothing will, including Microsoft conifg and pc settings (so I can't just reset to factory condition). Among the very few things that will open are libraries and control panel, libraries only responding long enough for me to select all my...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook