Windows 8 and 8.1 Forums

Can't Install .NET Framework 3.5

  1. #1

    Posts : 2
    Windows 8.1

    Can't Install .NET Framework 3.5

    Hi, everyone. I've been trying to do this for hours to run a program that needs it and I'm about to lose my mind. On my 8.1 laptop, I run a program (.exe) that tries to install ".NET Framework 3.5 (includes .NET 2.0 and 3.0)". Well, it only ever leaves me with this message:

    The component store has been corrupted.

    Error code: 0x80073712

    I've tried so many things to make it run that I have no idea what to do anymore. The exact same program runs perfectly fine on my windows 7 desktop, and it is supposed to be fully compatible with 8. Can you guys please help me out?

      My System SpecsSystem Spec

  2. #2

    Austin TX metro area
    Posts : 640
    Windows 7 Pro 64bit [MS blue-disk set]

    Normally, .net framework 3.5 is included with Windows 8. I haven't tried these 2 links, but found this on Google:
    How to remove and reinstall the Microsoft .NET Framework | AutoCAD | Autodesk Knowledge Network
    How to Repair or Reinstall .NET Framework 3.5

    From Microsoft:
    .NET Framework on Windows 8 - Windows Help
      My System SpecsSystem Spec

  3. #3

    this is MS article regarding your error code, Windows Update error 0x80073712 - Windows Help

    since windows is telling you that the component store is corrupted, you might want to just run DISM right off the bat. This is a link to Brink's guide for using DISM DISM - Fixing Component Store Corruption in Windows 8
      My System SpecsSystem Spec

  4. #4

    Posts : 2
    Windows 8.1

    When I run DISM, CheckHealth works and says that the corruption is repairable. However, ScanHealth and RestoreHealth both give me the same error. They say:

    Error: 1392

    The file or directory is corrupted and unreadable.

    The DISM log file can be found at C:/Windows/Logs/DISM/dism.log

    I might be misunderstanding something, but isn't the whole purpose of DISM to fix the corruption? I don't understand why it just gives up at about 20%.
      My System SpecsSystem Spec

  5. #5

    Trying to Sith things out
    Bamberg Germany
    Posts : 2,290
    Windows 10 Pro 64 bit

    To install .NET 3.5 If you have Windows OS install media you can use this command in an admin command prompt:

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:d:\sources\sxs

    Where the source marked in red must be the drive letter of the OS install media (USB or DVD)
      My System SpecsSystem Spec

Can't Install .NET Framework 3.5
Related Threads
I'm trying to install the .NET Framework 3.5 When I enable it in Programs and Features, it starts installing, and stops when it gets here. It's been like this for a few hours. 57721
:mad: I need to install the .Net framework 3.5 sp1 on Windows 8.1 for Autodesk 3ds Max for work. I initially noticed this in the Max installer...just quit installing and says I need to connect to the internet. Of course I am connected just fine. Tried Windows update, gave me this error:...
Hi there. I hope you're fine. I'm new here, so let me thank you for your help. :thumb: OKAY. I've a problem with my Win 8. It's 2 month now that i'm trying to install the framework 3.5... I've tried with Windows 8, I've tried Ofline too with the boot device... But it still the same. I...
Hi there, I've tried a lot of different methods in order to install 3.5. All have failed so far. I'm really hoping that somebody in the know will be able to help me with this. First of all, I was running 3.5 fine as I could run programs that use it fine previously. This was on Windows 8.1...
Can't install .NET Framework 3.5 in Windows Updates & Activation
I can't install .NET Framework 3.5 no matter what I do. I tried downloading it and in the midway get the error 0x800f0906. I tried installing through DISM but that didn't work either. It always stops at 65.8 %. Can somebody tell me how to fix it? It's really driving me nuts.
I can't install net framework on Build 9369. I have tried the Command Prompt; "DISM /Online /Enable-Feature /FeatureName:NetFx3 /Source:d:\sources\sxs" and I get an error that it can't download the file
3019 hello i installed win developer preview yesterday and tryed to install hp wireless assistant but it required net framework so computer started to download it by windows update but i canceled downloading and downloaded ne framework from microsoft site and every time i try to install it or...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook