Windows 8 and 8.1 Forums


<program> has stopped working

  1. #11


    Posts : 2,690
    Windows 3.1 > Windows 10


    Gema

    Code:
    [Process]
    Echo,"Processing %ScriptTitle% for %ProjectName%..."
    If,ExistFile,%ProjectTemp%\HostOSTools\regedit.exe,Set,%RegeditexeFolder%,%ProjectTemp%\HostOSTools\
    If,Not,ExistFile,%ProjectTemp%\HostOSTools\regedit.exe,If,Not,%SysType%,Equal,x86,Echo,"regedit.exe MAY write wrong values",WARN
    If,ExistFile,%ProjectTemp%\HostOSTools\reg.exe,Set,%RegexeFolder%,%ProjectTemp%\HostOSTools\
    If,Not,ExistFile,%ProjectTemp%\HostOSTools\reg.exe,If,Not,%SysType%,Equal,x86,Echo,"reg.exe MAY write wrong values",WARN
    IniRead,%ProjectDir%\script.project,IniVariables,NoWarnRegOverWrite,%NoWarnROW%
    //--
    If,ExistDir,%ProjectTemp%\Config,DirDelete,%ProjectTemp%\Config
    If,ExistDir,%ProjectTemp%\Config,Shellexecute,Hide,cmd.exe,"/C rd /s /q #$q%ProjectTemp%\Config#$q"
    If,ExistDir,%ProjectTemp%\Config,Echo,"ProjectTemp\Config Folder can not be deleted",Warn
    If,ExistDir,%ProjectTemp%\Config,Message,"ProjectTemp\Config Folder can not be deleted",Error
    If,ExistDir,%ProjectTemp%\Config,Halt,"ProjectTemp\Config Folder can not be deleted"
    DirMake,%ProjectTemp%\Config
    Unpack,,Archive,Tools,EnablePE81%OSArch%.7z,%ProjectTemp%\Config
    //--
    ShellExecute,Hide,"%Tools%\%OSArch%\SetAcl.exe"," -ot #$qfile#$q -on #$q%TargetDir%#$q -actn ace -actn setprot -op #$qdacl:p_nc#$q  -ace #$qn:S-1-1-0;p:full;s:y#$q -silent"
    //--
    Unpack,,Archive,Tools,Tools_%SourceArch%.7z,%target_sys%
    // AU331*
    If,ExistFile,%Tools%\%SourceArch%\AU331*.exe,If,Not,ExistFile,%target_sys%\AU331*.exe,FileCopy,%Tools%\%SourceArch%\AU331*.exe,%target_sys%
    // devcon
    If,ExistFile,%Tools%\%SourceArch%\devcon.exe,If,Not,ExistFile,%target_sys%\devcon.exe,FileCopy,%Tools%\%SourceArch%\devcon.exe,%target_sys%\devcon.exe
    //--
    // With Win8.1SE Ram and administrator account, NTUSER.DAT is used as default hive.
    // To continue working with Default %RegDefault% in project, Apps, reverse (change) hive files for %RegUser% and %RegDefault% (Already done)
    //Set,%RegUser%,%TargetDir%\Windows\System32\config\Default,Permanent
    //Set,%RegDefault%,%TargetDir%\Users\Default\NTUSER.DAT,Permanent
    //--
    Run,%ScriptFile%,Software_Registry
    Run,%ScriptFile%,System_Registry
    If,%BuildType%,Equal,OS,Run,%ScriptFile%,Sam_RegistryOS
    Run,%ScriptFile%,User_Registry
    Run,%ScriptFile%,Default_Registry
    Run,%ScriptFile%,Drivers_Registry
    //--
    // au3 a3x association
    Run,%ScriptFile%,au3association
    Run,%ScriptFile%,a3xassociation
    //--
    // RunOnceEx
    Run,%ScriptFile%,RunOnceEx
    //--
    //Run,%scriptfile%,Keep_in_Mind_postconfig
    //--
    Run,%scriptfile%,Shortcut
    Run,%scriptfile%,Numlock
    Run,%scriptfile%,OemLogo
    // TEST maybe not required
    Run,%scriptfile%,Environment
    // Remove Interactive User Allready done
    //Run,%scriptfile%,Process_RemoveInteractiveUser
    //--
    DirDelete,%ProjectTemp%\Config
    If,ExistDir,%ProjectTemp%\Config,Shellexecute,Hide,cmd.exe,"/C rd /s /q #$q%ProjectTemp%\Config#$q"
    If,ExistDir,%ProjectTemp%\Config,Echo,"ProjectTemp\Config Folder can not be deleted",Warn
    Yeah it could be any general syntax error..

    A Better Title would be > GEMA Program has stopped working

      My System SpecsSystem Spec

  2. #12


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Quote Originally Posted by RolandJS View Post
    Is GEMA a German-based program? I googled and most of the links on 1st page points to something from Germany.
    gema / Wiki / Home was written by David Gray (if you wanted to try it...)
      My System SpecsSystem Spec

  3. #13


    Posts : 20
    Windows 8.1


    No, I think David Gray is American. You can see a bit more about Gema at General-purpose macro processor - Wikipedia, the free encyclopedia, or see the main page on Sourceforge. Gema is extremely powerful for text processing, and can do some amazing things in a very small amount of code. I havre used it to create what is almost a new language for my specific domain, and to convert it into assembler code.
      My System SpecsSystem Spec

  4. #14


    Posts : 20
    Windows 8.1


    >Yeah it could be any general syntax error..

    I repeat my previous question; a syntax error where? It can't be a syntax error in the Gema source, or it would not have compiled. A syntax error in my input files is irrelevant. Gema should be able to process any input file. If it crashes with my input, that is down to a bug in Gema, it's not the fault of my input file.. What would be the use of a C compiler that crashed on every syntax error?

    >A Better Title would be > GEMA Program has stopped working

    You might think so, but I chose to call it what I called it, because I'm not looking for help from this forum on Gema (I would do that in a Gema forum, not a Windows one), but on Windows. I just want to know when Windows creates that error message, to help me find out why Gema is crashing with a stack overflow message. I just don't believe those of you who are saying this message is "unspecific", because error messages are only produced when someone writes in their code "if (condition) then print ("<program> has stopped working"). I'm just asking what this condition or these conditions are. Someone in the world must know the answer to this, even if it is only the guy in Redmond who wrote the code.

    Rowan
      My System SpecsSystem Spec

  5. #15


    Posts : 2,690
    Windows 3.1 > Windows 10


    I just want to know when Windows creates that error message, to help me find out why Gema is crashing with a stack overflow message.
    It is a PROGRAM Stack overflow that is causing WINDOWS to popup an Generic ERROR Message..

    Windows does not know the cause of the program's error.. Windows is just telling you there was an error..
    Reason being, it is not a windows program..

    Does the PROGRAM create a .log file? If so check the program's log file for the cause of the stack overflow..

    Another thing you may want to consider is that the PROGRAM was written using Code and Syntax Structure from 1995, the Lines of code used then may have changed since then..
      My System SpecsSystem Spec

  6. #16


    Posts : 20
    Windows 8.1


    >It is a PROGRAM Stack overflow that is causing WINDOWS to popup an Generic ERROR Message..

    Yes, I understand that. When I started this thread, all that I knew was that I had an error message saying "<program> has stopped working". That is a totally unhelpful message, since I already know that (it has hung, or exited prematurely). I now know that it was due to a stack overflow, which is much more useful. I understand that tracing what is causing the stack overflow is something that I, or the guy who wrote the program, will have to do, using the source code (which I have) and a debugger.

    I guess therefore that I can mark this issue as solved. I have learned what type of problem cause the program to stop working, and I have learned how to discover this from the Windows logs. Thanks to all for that.

    Rowan
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
<program> has stopped working
Related Threads
Log Name: Application Source: Application Hang Date: 3/23/2015 1:22:01 PM Event ID: 1002 Task Category: (101) Level: Error Keywords: Classic User: N/A Description: The program backgroundTaskHost.exe version 6.3.9600.17415 stopped interacting...
My usb gamepad stopped working suddenly and never work again in this computer I tried the gamepad in other computers and it works good, but not in this computer, I tried to reinstall windows several times, install all kind of drivers, I tried to configure it in different ways and its not working...
Hi! I am repeatedly getting the error "Internet Explorer not working" / Windows checking for solution/Last browsing closed unexpectedly , then Restore Session. I went to google to find a fix for this error .I'm being told to Press Window + W key then type in Troubleshooting in the Search box , then...
IN IE 11 some of my favicon links have stopped working. The ones that have an individualised icon logo for the site all work. Many have a generic internet explorer icon. Of these some work and some of them have stopped working (in the past 24 hours). I have system restored back 2 weeks but this...
Solved dwm.exe stopped working. in Software and Apps
Greetings, I am stuck with this problem where I get the error message about "dwm.exe has stopped working". Now as far as I know it only comes up if I am streaming something on the net using flash player and while using Google Chrome. Tried using it with IE allso but then I dont get the...
Hi I play a lot of BF3. Win 7 had no problems. But on Win8 I get a lot of bf3.exe have stopped working. Wonder if its a Win or game problem? :)
Nightly stopped working in Browsers & Mail
Just did today's update of nightly and it has stopped working. Have updated it on my Win7 computer and had no problems. Does anyone else have this problem? Have uninstalled with Revo Uninstaller and reinstalled and still no go
Eight Forums Android App Eight Forums IOS App Follow us on Facebook